summaryrefslogtreecommitdiff
path: root/sys-apps/cpuid/files/cpuid-20200203-makefile.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /sys-apps/cpuid/files/cpuid-20200203-makefile.patch
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'sys-apps/cpuid/files/cpuid-20200203-makefile.patch')
-rw-r--r--sys-apps/cpuid/files/cpuid-20200203-makefile.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/cpuid/files/cpuid-20200203-makefile.patch b/sys-apps/cpuid/files/cpuid-20200203-makefile.patch
new file mode 100644
index 000000000000..9cfad5ef594d
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20200203-makefile.patch
@@ -0,0 +1,37 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,11 +1,11 @@
+-CFLAGS+=-g
++CFLAGS+=
+ CPPFLAGS?=
+ LDFLAGS?=
+ ifneq (,$(findstring arch=i386,$(CFLAGS)))
+ CISA=-m32
+ endif
+ CFL=$(CPPFLAGS) $(CFLAGS) $(CISA) -Wall -W -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wimplicit-fallthrough -Wunused-parameter -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
+-INSTALL_STRIP=-s
++INSTALL_STRIP=
+
+ PACKAGE=cpuid
+ VERSION=20200203
+@@ -40,7 +40,7 @@
+
+ BUILDROOT=
+
+-default: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
++default: $(PROG) cpuinfo2cpuid
+
+ $(PROG): cpuid.c Makefile
+ $(CC) $(CFL) $(LDFLAGS) -o $@ cpuid.c
+@@ -56,9 +56,9 @@
+
+ install: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
+ install -D $(INSTALL_STRIP) -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
+- install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
++ install -D -m 444 $(PROG).man $(BUILDROOT)/usr/share/man/man1/$(PROG).1
+ install -D -m 755 cpuinfo2cpuid $(BUILDROOT)/usr/bin/cpuinfo2cpuid
+- install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz
++ install -D -m 444 cpuinfo2cpuid.man $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1
+
+ clean:
+ rm -f $(PROG) $(PROG).i386 $(PROG).x86_64