summaryrefslogtreecommitdiff
path: root/sys-apps/dbus/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-09 03:25:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-09 03:25:11 +0000
commit7db983f17e59dfa621d994bcbdbddc71a6e70a57 (patch)
treed3b613e9a32bbf84e338c3303136477226d57d04 /sys-apps/dbus/files
parent4cf2f7cc6bbea59e8aec44b9508c759cf8bb4adf (diff)
gentoo auto-resync : 09:11:2022 - 03:25:11
Diffstat (limited to 'sys-apps/dbus/files')
-rw-r--r--sys-apps/dbus/files/80-dbus13
-rw-r--r--sys-apps/dbus/files/dbus-1.12.22-check-fd.patch33
-rw-r--r--sys-apps/dbus/files/dbus-1.14.0-oom_score_adj.patch115
-rw-r--r--sys-apps/dbus/files/dbus-1.14.0-x-autoconf-fixes.patch147
4 files changed, 0 insertions, 308 deletions
diff --git a/sys-apps/dbus/files/80-dbus b/sys-apps/dbus/files/80-dbus
deleted file mode 100644
index 5593e2cd7390..000000000000
--- a/sys-apps/dbus/files/80-dbus
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/bash
-
-# launches a session dbus instance
-
-dbuslaunch="`which dbus-launch 2>/dev/null`"
-if [ -n "$dbuslaunch" ] && [ -x "$dbuslaunch" ] && [ -z "$DBUS_SESSION_BUS_ADDRESS" ]; then
- if [ -n "$command" ]; then
- command="$dbuslaunch --exit-with-session $command"
- else
- eval `$dbuslaunch --sh-syntax --exit-with-session`
- fi
-fi
-
diff --git a/sys-apps/dbus/files/dbus-1.12.22-check-fd.patch b/sys-apps/dbus/files/dbus-1.12.22-check-fd.patch
deleted file mode 100644
index 9038411bb13b..000000000000
--- a/sys-apps/dbus/files/dbus-1.12.22-check-fd.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 769a0462befb9829594a76e675526aba8579317e Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Sun, 27 Mar 2022 15:09:48 -0400
-Subject: [PATCH] sysdeps-unix: check fd before calling
- _dbus_fd_set_close_on_exec()
-
-If /proc/self/oom_score_adj does not exist, fd will invalid (-1).
-Attempting to set the CLOEXEC flag will obviously fail, and we lose the
-original errno value from open().
-
-Bug: https://bugs.gentoo.org/834725
-Signed-off-by: Mike Gilbert <floppym@gentoo.org>
----
- dbus/dbus-sysdeps-util-unix.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/dbus/dbus-sysdeps-util-unix.c b/dbus/dbus-sysdeps-util-unix.c
-index 314ce64b..8f079cbf 100644
---- a/dbus/dbus-sysdeps-util-unix.c
-+++ b/dbus/dbus-sysdeps-util-unix.c
-@@ -1633,7 +1633,8 @@ _dbus_reset_oom_score_adj (const char **error_str_p)
- if (fd < 0)
- {
- fd = open ("/proc/self/oom_score_adj", O_RDWR);
-- _dbus_fd_set_close_on_exec (fd);
-+ if (fd >= 0)
-+ _dbus_fd_set_close_on_exec (fd);
- }
-
- if (fd >= 0)
---
-GitLab
-
diff --git a/sys-apps/dbus/files/dbus-1.14.0-oom_score_adj.patch b/sys-apps/dbus/files/dbus-1.14.0-oom_score_adj.patch
deleted file mode 100644
index 094529708088..000000000000
--- a/sys-apps/dbus/files/dbus-1.14.0-oom_score_adj.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-From 499cdfde1b3f5d812912e89b1a1a0d7a4fb83306 Mon Sep 17 00:00:00 2001
-From: Simon McVittie <smcv@collabora.com>
-Date: Fri, 1 Apr 2022 18:58:34 +0100
-Subject: [PATCH 1/2] activation-helper: Never crash if unable to write
- oom_score_adj
-
-_dbus_warn() normally only logs a warning, but can be made fatal by
-environment variables. In particular, we do that during unit testing,
-which can result in a build-time test failure if dbus is built in a
-sandbox environment that prevents write access.
-
-_dbus_log() does only the logging part of _dbus_warn(), which seems
-more appropriate here.
-
-Signed-off-by: Simon McVittie <smcv@collabora.com>
----
- bus/activation-helper.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/bus/activation-helper.c b/bus/activation-helper.c
-index 8a4fd732..df0472ce 100644
---- a/bus/activation-helper.c
-+++ b/bus/activation-helper.c
-@@ -348,7 +348,7 @@ exec_for_correct_user (char *exec, char *user, DBusError *error)
- /* Resetting the OOM score adjustment is best-effort, so we don't
- * treat a failure to do so as fatal. */
- if (!_dbus_reset_oom_score_adj (&error_str))
-- _dbus_warn ("%s: %s", error_str, strerror (errno));
-+ _dbus_log (DBUS_SYSTEM_LOG_WARNING, "%s: %s", error_str, strerror (errno));
-
- if (!switch_user (user, error))
- return FALSE;
---
-GitLab
-
-
-From 5c8e5b7140c4f1f88684c7a83ce9587fff2def0c Mon Sep 17 00:00:00 2001
-From: Simon McVittie <smcv@collabora.com>
-Date: Fri, 1 Apr 2022 18:56:26 +0100
-Subject: [PATCH 2/2] sysdeps: Only open oom_score_adj read/write if we need to
- write it
-
-If we're running in a sandbox, we might not have write access to
-oom_score_adj. In the common case where we don't have any special
-protection from the OOM-killer, we can detect that with only read
-access, and skip the part where we open it for writing.
-
-(We would also not have write access to oom_score_adj if we're running
-with elevated Linux capabilities while not root, but that should never
-actually happen for dbus-daemon-launch-helper, which is setuid root
-for production use or has no capabilities during unit-testing.)
-
-Signed-off-by: Simon McVittie <smcv@collabora.com>
----
- dbus/dbus-sysdeps-util-unix.c | 26 +++++++++++++++++++++++---
- 1 file changed, 23 insertions(+), 3 deletions(-)
-
-diff --git a/dbus/dbus-sysdeps-util-unix.c b/dbus/dbus-sysdeps-util-unix.c
-index 8f079cbf..ca130cff 100644
---- a/dbus/dbus-sysdeps-util-unix.c
-+++ b/dbus/dbus-sysdeps-util-unix.c
-@@ -1627,12 +1627,12 @@ _dbus_reset_oom_score_adj (const char **error_str_p)
- const char *error_str = NULL;
-
- #ifdef O_CLOEXEC
-- fd = open ("/proc/self/oom_score_adj", O_RDWR | O_CLOEXEC);
-+ fd = open ("/proc/self/oom_score_adj", O_RDONLY | O_CLOEXEC);
- #endif
-
- if (fd < 0)
- {
-- fd = open ("/proc/self/oom_score_adj", O_RDWR);
-+ fd = open ("/proc/self/oom_score_adj", O_RDONLY);
- if (fd >= 0)
- _dbus_fd_set_close_on_exec (fd);
- }
-@@ -1680,6 +1680,26 @@ _dbus_reset_oom_score_adj (const char **error_str_p)
- goto out;
- }
-
-+ close (fd);
-+#ifdef O_CLOEXEC
-+ fd = open ("/proc/self/oom_score_adj", O_WRONLY | O_CLOEXEC);
-+
-+ if (fd < 0)
-+#endif
-+ {
-+ fd = open ("/proc/self/oom_score_adj", O_WRONLY);
-+ if (fd >= 0)
-+ _dbus_fd_set_close_on_exec (fd);
-+ }
-+
-+ if (fd < 0)
-+ {
-+ ret = FALSE;
-+ error_str = "open(/proc/self/oom_score_adj) for writing";
-+ saved_errno = errno;
-+ goto out;
-+ }
-+
- if (pwrite (fd, "0", sizeof (char), 0) < 0)
- {
- ret = FALSE;
-@@ -1700,7 +1720,7 @@ _dbus_reset_oom_score_adj (const char **error_str_p)
- else
- {
- ret = FALSE;
-- error_str = "open(/proc/self/oom_score_adj)";
-+ error_str = "open(/proc/self/oom_score_adj) for reading";
- saved_errno = errno;
- goto out;
- }
---
-GitLab
-
diff --git a/sys-apps/dbus/files/dbus-1.14.0-x-autoconf-fixes.patch b/sys-apps/dbus/files/dbus-1.14.0-x-autoconf-fixes.patch
deleted file mode 100644
index d9eb2a611bfd..000000000000
--- a/sys-apps/dbus/files/dbus-1.14.0-x-autoconf-fixes.patch
+++ /dev/null
@@ -1,147 +0,0 @@
-https://gitlab.freedesktop.org/dbus/dbus/-/commit/7d462fe93844df711ff8433ad798b54e57f8609d.patch
-(dropped NEWS to avoid conflicts with more patches in future)
-
-From fdbb32bd1f3c972d3d5fd3998930749206a1095a Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Tue, 1 Mar 2022 15:56:30 +0100
-Subject: [PATCH 1/6] build: Treat --with-x[=yes] the same as --with-x=auto
-
-Previously, --with-x would disable the check for X11 libraries, which
-was not intended.
-
-(cherry picked from commit 99cc28e0eb1a37233c0f7d3595175d1f331550e7)
---- a/configure.ac
-+++ b/configure.ac
-@@ -1115,7 +1115,7 @@ if test "x$dbus_win" = xyes; then
-
- enable_x11_autolaunch=no
- have_x11=no
--else if test "x$with_x" = xauto; then
-+else if test "x$with_x" != xno; then
- PKG_CHECK_MODULES([X], [x11],
- [AC_DEFINE([HAVE_X11], [1], [Define to 1 if you have X11 library])],
- [ have_x11=no ])
-GitLab
-From 5f2577aea3c5291dbb97e77c7384924851b30102 Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Tue, 1 Mar 2022 16:01:29 +0100
-Subject: [PATCH 2/6] Move DBUS_X_* definitions into PKG_CHECK_MODULES block
-
-(cherry picked from commit 51e468d828785cbc7060678f6f257723ba11cd10)
---- a/configure.ac
-+++ b/configure.ac
-@@ -1117,15 +1117,15 @@ if test "x$dbus_win" = xyes; then
- have_x11=no
- else if test "x$with_x" != xno; then
- PKG_CHECK_MODULES([X], [x11],
-- [AC_DEFINE([HAVE_X11], [1], [Define to 1 if you have X11 library])],
-+ [AC_DEFINE([HAVE_X11], [1], [Define to 1 if you have X11 library])
-+ have_x11=yes
-+ DBUS_X_LIBS="$X_LIBS"
-+ DBUS_X_CFLAGS="$X_CFLAGS"
-+ ],
- [ have_x11=no ])
-
- if test "x$have_x11" = xno; then
- AC_MSG_WARN([Couldn't found X11, tried with pkg-config.])
-- else
-- have_x11=yes
-- DBUS_X_LIBS="$X_LIBS"
-- DBUS_X_CFLAGS="$X_CFLAGS"
- fi
- else
- AS_IF([test "x$enable_x11_autolaunch" = "xyes"], [
-GitLab
-From 5dad12f34c54e2359adfe8e7f122681df1d24bcb Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Tue, 1 Mar 2022 16:05:52 +0100
-Subject: [PATCH 3/6] Emit an error when --with-x was given but no X11 libs
- were found
-
-(cherry picked from commit 17c88a894499da64460a0ef76db1d8b88ceb9eeb)
---- a/configure.ac
-+++ b/configure.ac
-@@ -1121,12 +1121,13 @@ else if test "x$with_x" != xno; then
- have_x11=yes
- DBUS_X_LIBS="$X_LIBS"
- DBUS_X_CFLAGS="$X_CFLAGS"
-- ],
-- [ have_x11=no ])
--
-- if test "x$have_x11" = xno; then
-- AC_MSG_WARN([Couldn't found X11, tried with pkg-config.])
-- fi
-+ ], [
-+ AS_IF([test "x$with_x" = xyes],
-+ [AC_MSG_ERROR([Couldn't find X11, tried with pkg-config.])],
-+ [AC_MSG_WARN([Couldn't find X11, tried with pkg-config.])]
-+ )
-+ have_x11=no
-+ ])
- else
- AS_IF([test "x$enable_x11_autolaunch" = "xyes"], [
- AC_MSG_ERROR([--enable-x11-autolaunch and --without-x are not compatible])
-GitLab
-From e03554eb0bf2731e39c06191403f7544df9bb307 Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Tue, 1 Mar 2022 16:08:06 +0100
-Subject: [PATCH 4/6] Add have_x11=no if --without-x was given to make later
- checks happy
-
-(cherry picked from commit bf3cb42c6db1f4479467d66a111b08a98afef31b)
---- a/configure.ac
-+++ b/configure.ac
-@@ -1129,6 +1129,7 @@ else if test "x$with_x" != xno; then
- have_x11=no
- ])
- else
-+ have_x11=no
- AS_IF([test "x$enable_x11_autolaunch" = "xyes"], [
- AC_MSG_ERROR([--enable-x11-autolaunch and --without-x are not compatible])
- ])
-GitLab
-From 62361f47f9da2346a9ff9a8c4b4bd4a288dc44d5 Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Tue, 1 Mar 2022 16:11:05 +0100
-Subject: [PATCH 5/6] Convert "if" calls to AS_IF macro for the block that
- handles X11
-
-(cherry picked from commit c71f013a64cd7f6de4c9cf3cf3b236239d713eb1)
---- a/configure.ac
-+++ b/configure.ac
-@@ -1108,14 +1108,14 @@ AC_ARG_ENABLE([x11-autolaunch],
- AS_HELP_STRING([--enable-x11-autolaunch], [build with X11 auto-launch support]),
- [], [enable_x11_autolaunch=auto])
-
--if test "x$dbus_win" = xyes; then
-- if test "x$enable_x11_autolaunch" = xyes; then
-+AS_IF([test "x$dbus_win" = xyes], [
-+ AS_IF([test "x$enable_x11_autolaunch" = xyes], [
- AC_MSG_ERROR([X11 auto-launch is not supported on Windows])
-- fi
-+ ])
-
- enable_x11_autolaunch=no
- have_x11=no
--else if test "x$with_x" != xno; then
-+], [test "x$with_x" != xno], [
- PKG_CHECK_MODULES([X], [x11],
- [AC_DEFINE([HAVE_X11], [1], [Define to 1 if you have X11 library])
- have_x11=yes
-@@ -1128,13 +1128,12 @@ else if test "x$with_x" != xno; then
- )
- have_x11=no
- ])
--else
-+], [
- have_x11=no
- AS_IF([test "x$enable_x11_autolaunch" = "xyes"], [
- AC_MSG_ERROR([--enable-x11-autolaunch and --without-x are not compatible])
- ])
--fi
--fi
-+])
-
- if test "x$enable_x11_autolaunch,$have_x11" = xyes,no; then
- AC_MSG_ERROR([X11 auto-launch requires X headers/libraries])
-GitLab