summaryrefslogtreecommitdiff
path: root/sys-apps/edid-fixdim/edid-fixdim-1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /sys-apps/edid-fixdim/edid-fixdim-1.ebuild
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'sys-apps/edid-fixdim/edid-fixdim-1.ebuild')
-rw-r--r--sys-apps/edid-fixdim/edid-fixdim-1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-apps/edid-fixdim/edid-fixdim-1.ebuild b/sys-apps/edid-fixdim/edid-fixdim-1.ebuild
new file mode 100644
index 000000000000..d02cbbfe9821
--- /dev/null
+++ b/sys-apps/edid-fixdim/edid-fixdim-1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_5 python3_6 python3_7 )
+inherit python-single-r1
+
+DESCRIPTION="Tool to fix screen dimensions in EDID data dumps"
+HOMEPAGE="https://github.com/mgorny/edid-fixdim"
+SRC_URI="https://github.com/mgorny/edid-fixdim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+ python_doscript edid-fixdim
+}