summaryrefslogtreecommitdiff
path: root/sys-apps/elfix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
commit7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (patch)
tree02bad8e4f1f060d4858a1a2ec3fc9404f0b7a197 /sys-apps/elfix
parent43c2a85d4e20318dd3d35872e348707900870067 (diff)
gentoo auto-resync : 07:05:2024 - 00:00:56
Diffstat (limited to 'sys-apps/elfix')
-rw-r--r--sys-apps/elfix/Manifest3
-rw-r--r--sys-apps/elfix/elfix-0.9.5-r1.ebuild45
-rw-r--r--sys-apps/elfix/elfix-9999.ebuild12
3 files changed, 52 insertions, 8 deletions
diff --git a/sys-apps/elfix/Manifest b/sys-apps/elfix/Manifest
index 9992af50c60c..45f527b20e55 100644
--- a/sys-apps/elfix/Manifest
+++ b/sys-apps/elfix/Manifest
@@ -1,4 +1,5 @@
DIST elfix-0.9.5.tar.gz 401722 BLAKE2B 184f8944c62412675819ca86f13bcf23039ebcf069df528267f3e4272859e6cc442a1e05a7a121d88987c282d7e2f513d02f28ce41a8e3c0c226b456fa256aa6 SHA512 e15ab664357796f3a63ac54912eb43ae659947088a10ef16aafcbdd713cc3670fb0319cb2b95a2d29092866d322ef69df1d63847dfc0c4ab2cdd49e6eaa4635e
+EBUILD elfix-0.9.5-r1.ebuild 1134 BLAKE2B f381fe3629582265fb6a3d2cf0a82c9a9d97d9f8d4bd6310f26a143ebd4fa0ae19e79973865ca05307e86c8c65c97ef0b12923dcf48274b287ade0156a163375 SHA512 9324deb26bd058a7cfe7b66d4fd05bfb22a4f4274a2507f6e3aca795cc53bfd34c74384ddc90c4061f997bc394362b6365abed132e804959ae349cf6495a5d3e
EBUILD elfix-0.9.5.ebuild 1176 BLAKE2B 608346b90278839d1681a6e50c4d3cc211c18514f04b276ebfd97ba8f8ca4200565780aeeb2ab1c9e0ef6c30a4219482bd8c9846dd789fa1620c0ad998f96ca7 SHA512 34fd8da00406541e94c0de2fcad346fdc0977c849dcb42cfb7533b8d9c920a600885469660b1dd5bd59514011e9ee9589226aad9774fe964f19b94619b21a03b
-EBUILD elfix-9999.ebuild 1183 BLAKE2B c6f089178776378a236f3e34c2034d7c9d116e864fe0b46c944163271b3135481b1cb1c68c9783c87decdd053be3d43ccfd871bd2e10e76909ac39ab9b97adcc SHA512 f685ca0da674d30d5055140aecc97c590e1438c3fc51a3efe7c1daf38afa8cb592d3ab731f76fab4f92092532f5df5ebbb5ed1e9572c8aecc02728e49187fb81
+EBUILD elfix-9999.ebuild 1134 BLAKE2B f381fe3629582265fb6a3d2cf0a82c9a9d97d9f8d4bd6310f26a143ebd4fa0ae19e79973865ca05307e86c8c65c97ef0b12923dcf48274b287ade0156a163375 SHA512 9324deb26bd058a7cfe7b66d4fd05bfb22a4f4274a2507f6e3aca795cc53bfd34c74384ddc90c4061f997bc394362b6365abed132e804959ae349cf6495a5d3e
MISC metadata.xml 624 BLAKE2B 67192c9d6f15c3e4f4c2c38cee73f5f7e191c42fc56dfb17713e47f2bd91dc50e50e2fafb0a70bdd71da35d60a614a9ac4101aaecf1f1f0d22671a8d7fd03727 SHA512 238813f6095de8b7ab64b764773fe05a0d5d4e6a972fbef1c0dc49ad0653375c168eef3d17cb2fba0864a4f7ce7a1c89441632b0f193da9a51a140427429c121
diff --git a/sys-apps/elfix/elfix-0.9.5-r1.ebuild b/sys-apps/elfix/elfix-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..b852f0585a0b
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.9.5-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="Suite of tools to work with ELF objects on Hardened Gentoo"
+HOMEPAGE="https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
+ https://dev.gentoo.org/~blueness/elfix/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+ptpax test +xtpax"
+REQUIRED_USE="|| ( ptpax xtpax )"
+# These only work with a properly configured PaX kernel
+RESTRICT="!test? ( test ) test"
+
+DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ if [[ ${PV} == *9999* ]]; then
+ eautoreconf
+ cd doc && ./make.sh || die
+ fi
+}
+
+src_configure() {
+ rm -f "${S}/scripts/setup.py" || die
+ econf \
+ $(use_enable test tests) \
+ $(use_enable ptpax) \
+ $(use_enable xtpax)
+}
diff --git a/sys-apps/elfix/elfix-9999.ebuild b/sys-apps/elfix/elfix-9999.ebuild
index 05b415e1f5d3..b852f0585a0b 100644
--- a/sys-apps/elfix/elfix-9999.ebuild
+++ b/sys-apps/elfix/elfix-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
@@ -11,19 +11,17 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo"
+DESCRIPTION="Suite of tools to work with ELF objects on Hardened Gentoo"
HOMEPAGE="https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
https://dev.gentoo.org/~blueness/elfix/"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
IUSE="+ptpax test +xtpax"
REQUIRED_USE="|| ( ptpax xtpax )"
# These only work with a properly configured PaX kernel
RESTRICT="!test? ( test ) test"
-DOCS=( AUTHORS ChangeLog INSTALL README THANKS TODO )
-
DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
ptpax? ( dev-libs/elfutils )
xtpax? ( sys-apps/attr )"
@@ -39,7 +37,7 @@ src_prepare() {
}
src_configure() {
- rm -f "${S}/scripts/setup.py"
+ rm -f "${S}/scripts/setup.py" || die
econf \
$(use_enable test tests) \
$(use_enable ptpax) \