summaryrefslogtreecommitdiff
path: root/sys-apps/ethtool/ethtool-6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
commitf356af92b88d56b78588e81310493d4f5a2f6d18 (patch)
tree0326fb33173ae3d096527af28f85685515533fbb /sys-apps/ethtool/ethtool-6.3.ebuild
parent560358ad7081e6bb2a4e097d4c442b0bab626163 (diff)
gentoo auto-resync : 10:05:2023 - 23:44:41
Diffstat (limited to 'sys-apps/ethtool/ethtool-6.3.ebuild')
-rw-r--r--sys-apps/ethtool/ethtool-6.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-apps/ethtool/ethtool-6.3.ebuild b/sys-apps/ethtool/ethtool-6.3.ebuild
new file mode 100644
index 000000000000..a7eff7664c78
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-6.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils"
+
+src_configure() {
+ econf $(use_enable netlink)
+}