summaryrefslogtreecommitdiff
path: root/sys-apps/fakechroot/fakechroot-2.20.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /sys-apps/fakechroot/fakechroot-2.20.1.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'sys-apps/fakechroot/fakechroot-2.20.1.ebuild')
-rw-r--r--sys-apps/fakechroot/fakechroot-2.20.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-apps/fakechroot/fakechroot-2.20.1.ebuild b/sys-apps/fakechroot/fakechroot-2.20.1.ebuild
new file mode 100644
index 000000000000..4657276f544b
--- /dev/null
+++ b/sys-apps/fakechroot/fakechroot-2.20.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Provide a faked chroot environment without requiring root privileges"
+HOMEPAGE="https://github.com/dex4er/fakechroot"
+SRC_URI="https://github.com/dex4er/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RESTRICT="test"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}