summaryrefslogtreecommitdiff
path: root/sys-apps/findutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sys-apps/findutils
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/Manifest2
-rw-r--r--sys-apps/findutils/findutils-4.9.0.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/sys-apps/findutils/Manifest b/sys-apps/findutils/Manifest
index a2c4d339f3d1..9b48477e39b7 100644
--- a/sys-apps/findutils/Manifest
+++ b/sys-apps/findutils/Manifest
@@ -1,4 +1,6 @@
DIST findutils-4.8.0.tar.xz 1983096 BLAKE2B e1f030ef11c252d33e92bf58dca20a6dd681938aad74b1bbd2bf64a0d175d64c8edac1edce71d13379e04a27e47ffa6099e105bb731957cf5247ffe01d856538 SHA512 eaa2da304dbeb2cd659b9210ac37da1bde4cd665c12a818eca98541c5ed5cba1050641fc0c39c0a446a5a7a87a8d654df0e0e6b0cee21752ea485188c9f1071e
+DIST findutils-4.9.0.tar.xz 2046252 BLAKE2B 3ada8903fc552ad2e580a7b631a4b9d941935b3f4231029564c6f2b7b10ba6f2244e2de57f6d79268c5e0481a193f64edbbae637e7a51ae6f495e3eefabf52c9 SHA512 ba4844f4403de0148ad14b46a3dbefd5a721f6257c864bf41a6789b11705408524751c627420b15a52af95564d8e5b52f0978474f640a62ab86a41d20cf14be9
EBUILD findutils-4.8.0-r1.ebuild 1846 BLAKE2B 78cc2bbfc0c05c13bcc4772692d15ebe2e0780cb5a5fd8b5689b10777530e9901e8af14688fac6b135ee57d69e4e9ac4f521ccda6d16c1db0d1679db852e8a75 SHA512 a71c349ea7075efc7c4149b917a84ded5b8e0e400f2373aa0b7fdce817593c7db00efd5670bd3acf82b8d01d77f11092fa54300119c2e1bc2ec0e9d6b2805709
EBUILD findutils-4.8.0.ebuild 1784 BLAKE2B ac28cb4d32588549ae9201d665ed03b84eae7ce20f333fa3b952eb404fdf71d4dfb548c2d41a167c729031c2e051f6f69b0f9d45a87738a3b69a70a97f8c5f5a SHA512 d9d2ec21b79b742f411e8d94ad8c5b605fdb1c0113a7885fd0f10acd562d1a1afbb6fd55e9156bcec7920326593b35c4dcb751eeb90bcd95085e767fb255c9c3
+EBUILD findutils-4.9.0.ebuild 1792 BLAKE2B 1ddd424a8a5f39b43fbb8e765790c6f9564185f7d0be51de72e7765b9b4a1e7e501acffbad273ea2a2826df231a26a1ab6445ea409b1ce7671f1d870ecef906b SHA512 a8526fb1e8eae170f41eca686d7f4e3ff8b62b08f8ee2f8b7cf063a53d0cff2ce8bc3dd8f80abab559e5722ccd1a43e83e2fb3b1fb8c452d3a6e222f2cbee3ae
MISC metadata.xml 333 BLAKE2B 321643b5c847879de4e8c0a4abebd5534e91fc7e58313ec3258520fc1f1266f98cc1892b57589cd1427ad4a0cea39b3c03ce12741b04f75290346fddc6c245fe SHA512 b36dfd42e3af70bc1ef3c7629297a390dced3edb1dc3d7d10d7672ff532da743453d9382cb15d3102885150c2440bd85019865d61c4e4342004db2dcf993f0a2
diff --git a/sys-apps/findutils/findutils-4.9.0.ebuild b/sys-apps/findutils/findutils-4.9.0.ebuild
new file mode 100644
index 000000000000..c57ebc1c2ccf
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.9.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit flag-o-matic python-any-r1
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="https://www.gnu.org/software/findutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls selinux static test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Don't build or install locate because it conflicts with mlocate,
+ # which is a secure version of locate. See bug 18729
+ sed \
+ -e '/^SUBDIRS/s@locate@@' \
+ -e '/^built_programs/s@ frcode locate updatedb@@' \
+ -i Makefile.in || die
+
+ default
+}
+
+src_configure() {
+ if use static; then
+ append-flags -pthread
+ append-ldflags -static
+ fi
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00050.html
+ # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00051.html
+ append-cppflags '-D__nonnull\(X\)='
+ fi
+
+ local myeconfargs=(
+ --with-packager="Gentoo"
+ --with-packager-version="${PVR}"
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+ $(use_enable nls)
+ $(use_with selinux)
+ --libexecdir='$(libdir)'/find
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # We don't build locate, but the docs want a file in there.
+ emake -C locate dblocation.texi
+ default
+}