summaryrefslogtreecommitdiff
path: root/sys-apps/fwupdate/fwupdate-8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/fwupdate/fwupdate-8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/fwupdate/fwupdate-8.ebuild')
-rw-r--r--sys-apps/fwupdate/fwupdate-8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/fwupdate/fwupdate-8.ebuild b/sys-apps/fwupdate/fwupdate-8.ebuild
new file mode 100644
index 000000000000..bd9f9fc1fd01
--- /dev/null
+++ b/sys-apps/fwupdate/fwupdate-8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mount-boot
+
+DESCRIPTION="Tools for using the ESRT and UpdateCapsule() to apply firmware updates"
+HOMEPAGE="https://github.com/rhinstaller/fwupdate"
+SRC_URI="https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/popt
+ sys-libs/efivar
+ >=sys-libs/libsmbios-2.3.2
+"
+DEPEND="
+ ${RDEPEND}
+ sys-boot/gnu-efi
+"
+
+do_make() {
+ emake \
+ EFIDIR="gentoo" \
+ GNUEFIDIR="/usr/$(get_libdir)" \
+ "${@}"
+}
+
+src_compile() {
+ do_make
+}
+
+src_install() {
+ do_make DESTDIR="${D}" install
+}