summaryrefslogtreecommitdiff
path: root/sys-apps/goawk/goawk-1.21.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-29 08:14:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-29 08:14:41 +0000
commit60a9341c4f6c39cadd9f0aef12438b41d69279a8 (patch)
tree9d867f76f68e6ecf26b6d9dde816672e3d66c55b /sys-apps/goawk/goawk-1.21.0.ebuild
parenta493ba7d75043e8e649ee8d6d4942c1f4b31d1c5 (diff)
gentoo auto-resync : 29:12:2022 - 08:14:41
Diffstat (limited to 'sys-apps/goawk/goawk-1.21.0.ebuild')
-rw-r--r--sys-apps/goawk/goawk-1.21.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/goawk/goawk-1.21.0.ebuild b/sys-apps/goawk/goawk-1.21.0.ebuild
new file mode 100644
index 000000000000..7f7a8282cd24
--- /dev/null
+++ b/sys-apps/goawk/goawk-1.21.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="POSIX-compliant AWK interpreter written in Go, with CSV support"
+HOMEPAGE="https://github.com/benhoyt/goawk"
+SRC_URI="https://github.com/benhoyt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build
+}
+
+src_test() {
+ ego test
+}
+
+src_install() {
+ einstalldocs
+
+ dobin goawk
+}