summaryrefslogtreecommitdiff
path: root/sys-apps/guix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /sys-apps/guix
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'sys-apps/guix')
-rw-r--r--sys-apps/guix/Manifest1
-rw-r--r--sys-apps/guix/guix-1.0.0-r1.ebuild156
2 files changed, 157 insertions, 0 deletions
diff --git a/sys-apps/guix/Manifest b/sys-apps/guix/Manifest
index 57c8cc9d04ea..7fe4ed8a55d6 100644
--- a/sys-apps/guix/Manifest
+++ b/sys-apps/guix/Manifest
@@ -8,5 +8,6 @@ DIST guix-bootstrap-i686-linux-20131110-guile-2.0.9.tar.xz.bootstrap 2656076 BLA
DIST guix-bootstrap-mips64el-linux-20131110-guile-2.0.9.tar.xz.bootstrap 2734180 BLAKE2B 8ac6d9cfb59b1e2214c112fa7bfe865966cd06cb0214f360dc337a54e16cb59e4e3aa6da0662a52e6bceedfbb2a9ebb0eb62fe08491e5761912e2ee17b7ecd48 SHA512 8c4be098a31f63d56e7d35c174ce4095ba8317662c365d44c005980b38ba499461926754a4659e699ab271bb841c9da514f1a36b812d881c212a5f12177d73c0
DIST guix-bootstrap-x86_64-linux-20131110-guile-2.0.9.tar.xz.bootstrap 2885996 BLAKE2B c16595fcb821468d5d293201046642dd4f0b149bb5e64f7b784f29f513ce26243b9747a8eefee3128e813a9b4b27a6a60a1693706b3fcb8cbb238fb4ad6e56c1 SHA512 96efc583f42f6c7647bc026e2d2a96d603e7bea12ca02f6bcc65e819b9966082ac4c9f7e42f64536ff42a988e4766e695d87a82c73dd97d80745975a05badb23
EBUILD guix-0.16.0.ebuild 4095 BLAKE2B 7f66213e8c2ccfb4f50ecd55e8e028528c87479342fd5dad02b3a6d63dd04133a3419493a4a8ee80d7d2f538720d212d9cbe2059f95b8667a987e882200932b1 SHA512 1ad0bb9251c9b12668c6a345857117aebac6851893c5017db9da4c912fe7b1b367081339f90fa9589c5401598f7e7ad4861df0526458eeaddcd83367fa38ca8f
+EBUILD guix-1.0.0-r1.ebuild 4318 BLAKE2B 0b772abfb69fbd24492842bcb477ec8ea9c6003e385912cd254f35962a10e86dfe56981adc3b83651a7499a322a7b60bf66cfc1048d5f696a816ae14cb499604 SHA512 fedf3fff7bb23ef49e16fe49280a6a52947f3bdef38897f2fc135837d9d2fc1a884c70a1f63eb56a9d58c89eb6bdff33216bf0ed13bf034b828fe20b764cd14f
EBUILD guix-1.0.0.ebuild 4099 BLAKE2B 6972352ba69a95522407debbe30b71a5b7a418a0ceb721390c3987eec72b895281f704b213a891e4ecfb6f6b9be81c1f85a176832be2b5779bfbe0152971adfb SHA512 de5fd8a904bf15bdd3b810ab865e42ac0cca977e3fa1d10df052e27548c20af9cb07e85878c4a344a48337c1f209da7338c4a0f9b66d2ca7da6a5de2fa8e6036
MISC metadata.xml 251 BLAKE2B 9785c4729d0751280d104965bab25a268219a7fee217dcd8c01a5642a13f8abc471a3dff54ae0d34d3cf3dc8267fb483d93bd3b16aa3617e8fa8e9abd1703dfe SHA512 cc2bd3977894946ee4ea5b739cc3998bcd6017b9e7a52aa501409d0988954339a9a22fe751d0a5e967ddac9225d9b23f20b4fb1e2c62ee91d1d23c383d9776dd
diff --git a/sys-apps/guix/guix-1.0.0-r1.ebuild b/sys-apps/guix/guix-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..475d3bba8b83
--- /dev/null
+++ b/sys-apps/guix/guix-1.0.0-r1.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools readme.gentoo-r1 systemd user
+
+DESCRIPTION="GNU package manager (nix sibling)"
+HOMEPAGE="https://www.gnu.org/software/guix/"
+
+# taken from gnu/local.mk and gnu/packages/bootstrap.scm
+BOOT_GUILE=(
+ "aarch64-linux 20170217 guile-2.0.14.tar.xz"
+ "armhf-linux 20150101 guile-2.0.11.tar.xz"
+ "i686-linux 20131110 guile-2.0.9.tar.xz"
+ "mips64el-linux 20131110 guile-2.0.9.tar.xz"
+ "x86_64-linux 20131110 guile-2.0.9.tar.xz"
+)
+
+binary_src_uris() {
+ local system_date_guilep uri
+ for system_date_guilep in "${BOOT_GUILE[@]}"; do
+ # $1 $2 $3
+ # "armhf-linux 20150101 guile-2.0.11.tar.xz"
+ set -- ${system_date_guilep}
+ uri="mirror://gnu-alpha/${PN}/bootstrap/$1/$2/$3"
+ # ${uri} -> guix-bootstrap-armhf-linux-20150101-guile-2.0.11.tar.xz.bootstrap
+ echo "${uri} -> guix-bootstrap-$1-$2-$3.bootstrap"
+ done
+}
+
+# copy bootstrap binaries from DISTDIR to ${S}
+copy_boot_guile_binaries() {
+ local system_date_guilep
+ for system_date_guilep in "${BOOT_GUILE[@]}"; do
+ # $1 $2 $3
+ # "armhf-linux 20150101 guile-2.0.11.tar.xz"
+ set -- ${system_date_guilep}
+ cp "${DISTDIR}"/guix-bootstrap-$1-$2-$3.bootstrap gnu/packages/bootstrap/$1/$3 || die
+ done
+}
+
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ $(binary_src_uris)"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # complains about size of config.log and refuses to start tests
+
+RDEPEND="
+ dev-libs/libgcrypt:0=
+ >=dev-scheme/guile-2.2:=[regex,networking,threads]
+ dev-scheme/bytestructures
+ dev-scheme/guile-gcrypt
+ >=dev-scheme/guile-git-0.2.0
+ dev-scheme/guile-json
+ dev-scheme/guile-sqlite3
+ net-libs/gnutls[guile]
+ sys-libs/zlib
+ app-arch/bzip2
+ dev-db/sqlite
+"
+
+DEPEND="${RDEPEND}
+"
+
+PATCHES=("${FILESDIR}"/${PN}-0.16.0-default-daemon.patch)
+
+QA_PREBUILT="usr/share/guile/site/*/gnu/packages/bootstrap/*"
+
+DISABLE_AUTOFORMATTING=yes
+DOC_CONTENTS="Quick start user guide on Gentoo:
+
+[as root] allow binary substitution to be downloaded (optional)
+ # guix archive --authorize < /usr/share/guix/ci.guix.info.pub
+[as root] enable guix-daemon service:
+ [systemd] # systemctl enable guix-daemon
+ [openrc] # rc-update add guix-daemon
+[as a user] ln -sf /var/guix/profiles/per-user/\$USER/guix-profile \$HOME/.guix-profile
+[as a user] install guix packages:
+ \$ guix package -i hello
+[as a user] configure environment:
+ Somewhere in .bash_profile you might want to set
+ export GUIX_LOCPATH=\$HOME/.guix-profile/lib/locale
+
+Next steps:
+ guix package manager user manual: https://www.gnu.org/software/guix/manual/guix.html
+"
+
+pkg_setup() {
+ enewgroup guixbuild
+ for i in {1..10}; do
+ # we list 'guixbuild' twice to
+ # both assign a primary group for user
+ # and add a user to /etc/group
+ enewuser guixbuilder${i} -1 -1 /var/empty guixbuild,guixbuild
+ done
+}
+
+src_prepare() {
+ copy_boot_guile_binaries
+
+ default
+ # build system is very eager to run automake itself: bug #625166
+ eautoreconf
+
+ # guile is trying to avoid recompilation by checking if file
+ # /usr/lib64/guile/2.2/site-ccache/guix/modules.go
+ # is newer than
+ # guix/modules.scm
+ # In case it is instead of using 'guix/modules.scm' guile
+ # loads system one (from potentially older version of guix).
+ # To work it around we bump last modification timestamp of
+ # '*.scm' files.
+ find "${S}" -name "*.scm" -exec touch {} + || die
+
+ # Gentoo stores systemd unit files in lib, never in lib64: bug #689772
+ sed -i nix/local.mk \
+ -e 's|systemdservicedir = $(libdir)/systemd/system|systemdservicedir = '"$(systemd_get_systemunitdir)"'|' || die
+}
+
+src_configure() {
+ # to be compatible with guix from /gnu/store
+ econf \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ # guile occasionally fails with 'bad address'
+ emake -j1
+}
+
+src_install() {
+ # TODO: emacs highlighter
+ default
+
+ readme.gentoo_create_doc
+
+ keepdir /etc/guix
+ # TODO: will need a tweak for prefix
+ keepdir /gnu/store
+ fowners root:guixbuild /gnu/store
+ fperms 1775 /gnu/store
+
+ keepdir /var/guix/profiles/per-user
+ fperms 1777 /var/guix/profiles/per-user
+
+ newinitd "${FILESDIR}"/guix-daemon.initd guix-daemon
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}