summaryrefslogtreecommitdiff
path: root/sys-apps/haveged/haveged-1.9.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
commit171a011ad3a131671aeb5a98b9e3adf219ad2865 (patch)
tree0c877a3d1a37f10e37ad7168cfc52054aa0948a7 /sys-apps/haveged/haveged-1.9.2-r1.ebuild
parent75fc75ae1f0481ffdb78450e801a9b443ba641bd (diff)
gentoo resync : 02.04.2018
Diffstat (limited to 'sys-apps/haveged/haveged-1.9.2-r1.ebuild')
-rw-r--r--sys-apps/haveged/haveged-1.9.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/haveged/haveged-1.9.2-r1.ebuild b/sys-apps/haveged/haveged-1.9.2-r1.ebuild
new file mode 100644
index 000000000000..e43732a8d98e
--- /dev/null
+++ b/sys-apps/haveged/haveged-1.9.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+DESCRIPTION="A simple entropy daemon using the HAVEGE algorithm"
+HOMEPAGE="http://www.issihosts.com/haveged/"
+SRC_URI="http://www.issihosts.com/haveged/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="selinux static-libs"
+
+DEPEND=""
+RDEPEND="!<sys-apps/openrc-0.11.8
+ selinux? ( sec-policy/selinux-entropyd )"
+
+# threads are broken right now, but eventually
+# we should add $(use_enable threads)
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --bindir=/usr/sbin \
+ --enable-nistest \
+ --disable-threads
+}
+
+src_install() {
+ default
+
+ # Install gentoo ones instead
+ newinitd "${FILESDIR}"/haveged-init.d.3 haveged
+ newconfd "${FILESDIR}"/haveged-conf.d haveged
+
+ systemd_newunit "${FILESDIR}"/service.gentoo ${PN}.service
+ insinto /etc
+ doins "${FILESDIR}"/haveged.conf
+}