summaryrefslogtreecommitdiff
path: root/sys-apps/hd-idle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
commit38b7258d086dd5e263c3bbe3880c8c956676bc71 (patch)
tree6fce284d5bfddaf597a490ac66069d16c6a485db /sys-apps/hd-idle
parent0ebf740b9c9bc7c10ac41bea315ecc6c01c79166 (diff)
gentoo resync : 25.01.2018
Diffstat (limited to 'sys-apps/hd-idle')
-rw-r--r--sys-apps/hd-idle/Manifest5
-rw-r--r--sys-apps/hd-idle/files/hd-idle-conf30
-rw-r--r--sys-apps/hd-idle/files/hd-idle-init12
-rw-r--r--sys-apps/hd-idle/hd-idle-1.05.ebuild26
-rw-r--r--sys-apps/hd-idle/metadata.xml16
5 files changed, 89 insertions, 0 deletions
diff --git a/sys-apps/hd-idle/Manifest b/sys-apps/hd-idle/Manifest
new file mode 100644
index 000000000000..8a078834f1d2
--- /dev/null
+++ b/sys-apps/hd-idle/Manifest
@@ -0,0 +1,5 @@
+AUX hd-idle-conf 1530 BLAKE2B a67f5d13a3a204c0e49e66c91c1503d1b9cb191d35def96f3e98ba6f3ce9094559eaaaf5cc974c2bb9f3017c9dfe99461fbf7ba8bf4e48935d30a2ea1c451c70 SHA512 d7f2b2324f3a248ddf0d205ed188aa6c886701bf18189c16284bb16143bda8e3707d30226c69b440058dd9eb4d6222ebe10df7e10c6bbb7c9fd442f88df216fe
+AUX hd-idle-init 296 BLAKE2B e4d2b4a7f7ff816198c7e9b1b5289ec3abb1a928d4bfe50175af2d25d4333a661ad7beaa0c6a6a6fc73775a2e61408e7b6ea2721239648d1e4142be09e07c9cd SHA512 aa26ad5f4d0e97197801ca3e791301a88bcf86f094b338f2c9f7b5000de7fbb91efb9cab8e3b142039b17d5dfb47bf07465a85d12a3ed3594a9d0f38e6e518f2
+DIST hd-idle-1.05.tgz 17951 BLAKE2B f99dd25d41f2ac4391025ff652827a8687db19df2dafe0f07eeeea700eaf0d67a255ee67017123510a3b89f3aba2f50de7204923d9ab85e80138f657f5e120d3 SHA512 8636d8bf2bce40f380afdea859aef7d142258071c62f87884a9af55c7c84310d89de712f56dff2bd825f0c7d79b04356df92e3012d8f683d8c41ebb23cd3920b
+EBUILD hd-idle-1.05.ebuild 564 BLAKE2B ce81e6345abc58ae06f99934760805ad5617d0cea1c8a3541432279cabe53100875c84baaf347adf8ee280b0cda1ed47279f0f3a011bd99b83bebbbf6f1ae531 SHA512 9e2f9fe60301428b8c99e16ab6ea8a2c5b68f36e52a1e0d854cfc383b4d52c2a0c9b841d58be7b3cfefa7ca13a58585485e31fce216bb128409555114aa2cd2f
+MISC metadata.xml 531 BLAKE2B ff7be843730e8fb8168e9ce1f738c1966f3d840e374e89e7e83d4600685b70eb1e08509b6d4e46b5f88bdc678bd22dcef524435c73cfa94f8ba2013967d35d90 SHA512 86911ee41d9874d57984d4d7d526a7a21913bccc3a3b3db52d1d2dee7b7d0cfcf11e1e8b7e3d547ee33036966dccf175a75699721e104401843382cf81b3ccd6
diff --git a/sys-apps/hd-idle/files/hd-idle-conf b/sys-apps/hd-idle/files/hd-idle-conf
new file mode 100644
index 000000000000..a0bd68336e2a
--- /dev/null
+++ b/sys-apps/hd-idle/files/hd-idle-conf
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# defaults file for hd-idle
+
+# hd-idle command line options
+# Options are:
+# -a Set (partial) device name of disks for subsequent
+# idle-time parameters (-i). This parameter is optional
+# in the sense that there's a default entry for all
+# disks which are not named otherwise by using this
+# parameter.
+# -i <idle_time> Idle time in seconds.
+# -l <logfile> Name of logfile (written only after a disk has spun
+# up). Please note that this option might cause the
+# disk which holds the logfile to spin up just because
+# another disk had some activity. This option should
+# not be used on systems with more than one disk
+# except for tuning purposes. On single-disk systems,
+# this option should not cause any additional spinups.
+#
+# Options not exactly useful here:
+# -t <disk> Spin-down the specfified disk immediately and exit.
+# -d Debug mode. This will prevent hd-idle from
+# becoming a daemon and print debugging info to
+# stdout/stderr
+# -h Print usage information.
+
+#HD_IDLE_OPTS="-i 180 -l /var/log/hd-idle.log"
+
diff --git a/sys-apps/hd-idle/files/hd-idle-init b/sys-apps/hd-idle/files/hd-idle-init
new file mode 100644
index 000000000000..650d1934a437
--- /dev/null
+++ b/sys-apps/hd-idle/files/hd-idle-init
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="Utility for spinning down hard disks after a period of idle time"
+
+command="/usr/sbin/hd-idle"
+command_args="${HD_IDLE_OPTS}"
+
+depend() {
+ after bootmisc
+}
diff --git a/sys-apps/hd-idle/hd-idle-1.05.ebuild b/sys-apps/hd-idle/hd-idle-1.05.ebuild
new file mode 100644
index 000000000000..4da29a661672
--- /dev/null
+++ b/sys-apps/hd-idle/hd-idle-1.05.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info
+
+DESCRIPTION="Utility for spinning down hard disks after a period of idle time"
+HOMEPAGE="http://hd-idle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+
+CONFIG_CHECK="~PROC_FS"
+
+DOCS=( debian/changelog README )
+
+src_install() {
+ default_src_install
+ newinitd "${FILESDIR}"/hd-idle-init hd-idle
+ newconfd "${FILESDIR}"/hd-idle-conf hd-idle
+}
diff --git a/sys-apps/hd-idle/metadata.xml b/sys-apps/hd-idle/metadata.xml
new file mode 100644
index 000000000000..6a1a90c15b59
--- /dev/null
+++ b/sys-apps/hd-idle/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>o.freyermuth@googlemail.com</email>
+ <name>Oliver Freyermuth</name>
+ <description>Proxy-maintainer, assign bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">hd-idle</remote-id>
+ </upstream>
+</pkgmetadata>