summaryrefslogtreecommitdiff
path: root/sys-apps/heirloom-tools/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sys-apps/heirloom-tools/files
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sys-apps/heirloom-tools/files')
-rw-r--r--sys-apps/heirloom-tools/files/heirloom-tools-070715-gcc-10.patch278
-rw-r--r--sys-apps/heirloom-tools/files/heirloom-tools-070715-glibc-2.30.patch13
-rw-r--r--sys-apps/heirloom-tools/files/heirloom-tools-070715-glibc-2.31.patch41
-rw-r--r--sys-apps/heirloom-tools/files/heirloom-tools-070715-major.patch70
-rw-r--r--sys-apps/heirloom-tools/files/heirloom-tools-070715-makefile.patch16
5 files changed, 415 insertions, 3 deletions
diff --git a/sys-apps/heirloom-tools/files/heirloom-tools-070715-gcc-10.patch b/sys-apps/heirloom-tools/files/heirloom-tools-070715-gcc-10.patch
new file mode 100644
index 000000000000..ce0c2bdc5be5
--- /dev/null
+++ b/sys-apps/heirloom-tools/files/heirloom-tools-070715-gcc-10.patch
@@ -0,0 +1,278 @@
+--- a/cpio/cpio.c
++++ b/cpio/cpio.c
+@@ -748,6 +748,7 @@ static struct stat globst;
+ */
+ #define SANELIMIT 0177777
+
++enum fmttype fmttype;
+ char *progname; /* argv[0] to main() */
+ static struct dslot *devices; /* devices table */
+ static struct dslot *markeddevs; /* unusable device numbers */
+@@ -826,6 +827,9 @@ static int compressed_bar; /* this is a compressed bar archive */
+ static int formatforced; /* -k -i -Hfmt forces a format */
+ static long long lineno; /* input line number */
+
++enum pax pax;
++enum pax_preserve pax_preserve;
++
+ int pax_dflag; /* directory matches only itself */
+ int pax_kflag; /* do not overwrite files */
+ int pax_nflag; /* select first archive member only */
+--- a/cpio/cpio.h
++++ b/cpio/cpio.h
+@@ -31,7 +31,7 @@
+ #include <sys/stat.h>
+ #include <inttypes.h>
+
+-enum {
++enum fmttype {
+ FMT_NONE = 00000000, /* no format chosen yet */
+
+ TYP_PAX = 00000010, /* uses pax-like extended headers */
+@@ -70,7 +70,8 @@ enum {
+ FMT_BAR = 00400001, /* bar format type */
+
+ FMT_ZIP = 01000000 /* zip format */
+-} fmttype;
++};
++extern enum fmttype fmttype;
+
+ /*
+ * Zip compression method.
+@@ -173,11 +174,12 @@ extern int printsev;
+ extern char *progname;
+ extern struct glist *patterns;
+
+-enum { /* type of pax command this is */
++enum pax { /* type of pax command this is */
+ PAX_TYPE_CPIO = 0, /* not a pax command */
+ PAX_TYPE_PAX1992 = 1, /* POSIX.2 pax command */
+ PAX_TYPE_PAX2001 = 2 /* POSIX.1-2001 pax command */
+-} pax;
++};
++extern enum pax pax;
+ extern int pax_dflag;
+ extern int pax_kflag;
+ extern int pax_nflag;
+@@ -185,14 +187,15 @@ extern int pax_sflag;
+ extern int pax_uflag;
+ extern int pax_Xflag;
+
+-enum {
++enum pax_preserve {
+ PAX_P_NONE = 0000,
+ PAX_P_ATIME = 0001,
+ PAX_P_MTIME = 0004,
+ PAX_P_OWNER = 0010,
+ PAX_P_MODE = 0020,
+ PAX_P_EVERY = 0400
+-} pax_preserve;
++};
++extern enum pax_preserve pax_preserve;
+
+ extern size_t (*ofiles)(char **, size_t *);
+ extern void (*prtime)(time_t);
+--- a/tabs/tabspec.c
++++ b/tabs/tabspec.c
+@@ -36,6 +36,8 @@
+ #include <blank.h>
+ #include "tabspec.h"
+
++enum taberrno taberrno;
++
+ static const struct {
+ const char *c_nam;
+ const char *c_str;
+--- a/tabs/tabspec.h
++++ b/tabs/tabspec.h
+@@ -34,14 +34,15 @@ struct tabulator {
+ int t_rep; /* repetitive tab count */
+ };
+
+-enum {
++enum taberrno {
+ TABERR_NONE,
+ TABERR_CANTOP, /* can't open */
+ TABERR_FILIND, /* file indirection */
+ TABERR_UNKTAB, /* unknown tab code */
+ TABERR_ILLINC, /* illegal increment */
+ TABERR_ILLTAB /* illegal tabs */
+-} taberrno;
++};
++extern enum taberrno taberrno;
+
+ extern void *scalloc(size_t nmemb, size_t size);
+ extern struct tabulator *tabstops(const char *s, int cols);
+--- a/diff/diff.c
++++ b/diff/diff.c
+@@ -92,6 +92,23 @@ static void usage(void);
+ static void xadd(const char *);
+ static void Xadd(const char *);
+
++char *ifdef1;
++char *ifdef2;
++int wantelses;
++char *file1, *file2;
++char *tempfile1, *tempfile2;
++char **diffargv;
++struct stat stb1, stb2;
++jmp_buf recenv;
++const char *start;
++struct xclusion *xflag;
++struct stackblk *curstack;
++int hflag,tflag,aflag,lflag,Nflag,sflag,rflag,Bflag,iflag,wflag,bflag,pflag;
++int mb_cur_max;
++int opt;
++int context;
++int status;
++
+ int
+ main(int argc, char **argv)
+ {
+--- a/diff/diff.h
++++ b/diff/diff.h
+@@ -106,7 +106,7 @@
+ /*
+ * Output format options
+ */
+-int opt;
++extern int opt;
+
+ #define D_NORMAL 0 /* Normal output */
+ #define D_EDIT -1 /* Editor script out */
+@@ -117,66 +117,66 @@ int opt;
+ lines and no trailing . */
+ #define D_UNIFIED 5 /* Unified diff */
+
+-int aflag; /* diff binary files */
+-int tflag; /* expand tabs on output */
+-int pflag; /* show surrounding C function */
++extern int aflag; /* diff binary files */
++extern int tflag; /* expand tabs on output */
++extern int pflag; /* show surrounding C function */
+
+ /*
+ * Algorithm related options
+ */
+-int hflag; /* -h, use halfhearted DIFFH */
+-int bflag; /* ignore blanks in comparisons */
+-int wflag; /* totally ignore blanks in comparisons */
+-int iflag; /* ignore case in comparisons */
+-int Bflag; /* ignore changes that consist of blank lines */
++extern int hflag; /* -h, use halfhearted DIFFH */
++extern int bflag; /* ignore blanks in comparisons */
++extern int wflag; /* totally ignore blanks in comparisons */
++extern int iflag; /* ignore case in comparisons */
++extern int Bflag; /* ignore changes that consist of blank lines */
+
+ /*
+ * Options on hierarchical diffs.
+ */
+-int lflag; /* long output format with header */
+-int rflag; /* recursively trace directories */
+-int sflag; /* announce files which are same */
+-int Nflag; /* write text of nonexistant files */
+-const char *start; /* do file only if name >= this */
++extern int lflag; /* long output format with header */
++extern int rflag; /* recursively trace directories */
++extern int sflag; /* announce files which are same */
++extern int Nflag; /* write text of nonexistant files */
++extern const char *start; /* do file only if name >= this */
+
+ struct xclusion {
+ struct xclusion *x_nxt;
+ const char *x_pat;
+-} *xflag; /* patterns to exclude from comparison */
++};
++extern struct xclusion *xflag; /* patterns to exclude from comparison */
+
+ /*
+ * Variables for -I D_IFDEF option.
+ */
+-int wantelses; /* -E */
+-char *ifdef1; /* String for -1 */
+-char *ifdef2; /* String for -2 */
+-char *endifname; /* What we will print on next #endif */
+-int inifdef;
++extern int wantelses; /* -E */
++extern char *ifdef1; /* String for -1 */
++extern char *ifdef2; /* String for -2 */
+
+ /*
+ * Variables for -c context option.
+ */
+-int context; /* lines of context to be printed */
++extern int context; /* lines of context to be printed */
+
+ /*
+ * State for exit status.
+ */
+-int status;
+-int anychange;
+-char *tempfile1; /* used when comparing against std input */
+-char *tempfile2; /* used when comparing against std input */
++extern int status;
++extern int anychange;
++extern char *tempfile1; /* used when comparing against std input */
++extern char *tempfile2; /* used when comparing against std input */
+
+ /*
+ * Variables for diffdir.
+ */
+-char **diffargv; /* option list to pass to recursive diffs */
+-int recdepth; /* recursion depth */
+-jmp_buf recenv; /* jump stack on error */
++extern char **diffargv; /* option list to pass to recursive diffs */
++extern int recdepth; /* recursion depth */
++extern jmp_buf recenv; /* jump stack on error */
+
+ struct stackblk {
+ struct stackblk *s_prev;
+ struct stackblk *s_next;
+-} *curstack;
++};
++extern struct stackblk *curstack;
+
+ /*
+ * Input file names.
+@@ -184,13 +184,13 @@ struct stackblk {
+ * and padded with a '/', and then efile0 and efile1 point after
+ * the '/'.
+ */
+-char *file1, *file2, *efile1, *efile2;
+-struct stat stb1, stb2;
++extern char *file1, *file2;
++extern struct stat stb1, stb2;
+
+ extern const char diffh[], diff[], pr[];
+ extern const char *argv0;
+ extern const char *progname;
+-int mb_cur_max;
++extern int mb_cur_max;
+ extern int sysv3;
+
+ /* diff.c */
+--- a/diff/diffdir.c
++++ b/diff/diffdir.c
+@@ -142,6 +142,10 @@ static char *mkpath(const char *, const char *);
+ static void mktitle(void);
+ static int xclude(const char *);
+
++int anychange;
++int recdepth;
++static char *efile1, *efile2;
++
+ void
+ diffdir(char **argv)
+ {
+--- a/diff/diffreg.c
++++ b/diff/diffreg.c
+@@ -186,6 +186,8 @@ static int (*chrtran)(int);/* translation for case-folding */
+ static long pstart; /* start of last search for -p */
+ static long plast; /* match of last search for -p */
+ static long *saveJ; /* saved J for -p */
++static char *endifname; /* What we will print on next #endif */
++static int inifdef;
+
+ /* chrtran points to one of 3 translation functions:
+ * cup2low if folding upper to lower case
diff --git a/sys-apps/heirloom-tools/files/heirloom-tools-070715-glibc-2.30.patch b/sys-apps/heirloom-tools/files/heirloom-tools-070715-glibc-2.30.patch
new file mode 100644
index 000000000000..19b90cea6d2a
--- /dev/null
+++ b/sys-apps/heirloom-tools/files/heirloom-tools-070715-glibc-2.30.patch
@@ -0,0 +1,13 @@
+diff --git a/shl/shl.c b/shl/shl.c
+index 6f5c2df..30d296c 100644
+--- a/shl/shl.c
++++ b/shl/shl.c
+@@ -86,7 +86,7 @@ extern int sysv3;
+ #include <libgen.h>
+ #include <limits.h>
+ #include <stdarg.h>
+-#if !defined (__dietlibc__) && !defined (__UCLIBC__)
++#if !defined (__dietlibc__) && !defined (__UCLIBC__) && !defined(__linux__)
+ #include <stropts.h>
+ #endif
+ #include <poll.h>
diff --git a/sys-apps/heirloom-tools/files/heirloom-tools-070715-glibc-2.31.patch b/sys-apps/heirloom-tools/files/heirloom-tools-070715-glibc-2.31.patch
new file mode 100644
index 000000000000..5186aa1cc2e1
--- /dev/null
+++ b/sys-apps/heirloom-tools/files/heirloom-tools-070715-glibc-2.31.patch
@@ -0,0 +1,41 @@
+--- a/date/date.c
++++ b/date/date.c
+@@ -134,26 +134,13 @@ badtime:
+ return (time_t)-1;
+ }
+
+-#if defined (__FreeBSD__) || defined (__NetBSD__) || defined (__OpenBSD__) || \
+- defined (__DragonFly__) || defined (__APPLE__)
+-static int
+-stime(time_t *t)
+-{
+- struct timeval tv;
+-
+- tv.tv_sec = *t;
+- tv.tv_usec = 0;
+-
+- return settimeofday(&tv, NULL);
+-}
+-#endif /* __FreeBSD__, __NetBSD__, __OpenBSD__, __DragonFly__, __APPLE__ */
+-
+ static void
+ settime(char *op)
+ {
+ struct utmpx before, after;
+ const char wtmpxfile[] = "/var/log/wtmp";
+ time_t newtime;
++ struct timeval tv;
+
+ memset(&before, 0, sizeof before);
+ memset(&after, 0, sizeof after);
+@@ -164,7 +151,9 @@ settime(char *op)
+ if ((newtime = timeop(op)) == (time_t)-1)
+ badconv();
+ gettimeofday(&before.ut_tv, NULL);
+- if (stime(&newtime) < 0) {
++ tv.tv_sec = newtime;
++ tv.tv_usec = 0;
++ if (settimeofday(&tv, NULL) < 0) {
+ fprintf(stderr, "%s: no permission\n", progname);
+ exit(1);
+ }
diff --git a/sys-apps/heirloom-tools/files/heirloom-tools-070715-major.patch b/sys-apps/heirloom-tools/files/heirloom-tools-070715-major.patch
index 82d32315d819..81e6755e7e32 100644
--- a/sys-apps/heirloom-tools/files/heirloom-tools-070715-major.patch
+++ b/sys-apps/heirloom-tools/files/heirloom-tools-070715-major.patch
@@ -1,6 +1,8 @@
+diff --git a/cpio/cpio.c b/cpio/cpio.c
+index 89c5cbc..210287b 100644
--- a/cpio/cpio.c
+++ b/cpio/cpio.c
-@@ -91,9 +91,9 @@
+@@ -91,11 +91,12 @@
#include <sfile.h>
#include <atoll.h>
@@ -10,11 +12,45 @@
-#endif /* _AIX */
+#endif /* _AIX || __GLIBC__ */
- #ifndef major
+-#ifndef major
++#include <sys/sysmacros.h>
++#if 0
#include <sys/mkdev.h>
+ #endif /* !major */
+
+diff --git a/file/file.c b/file/file.c
+index 6609734..d90af86 100644
+--- a/file/file.c
++++ b/file/file.c
+@@ -66,7 +66,8 @@ static const char sccsid[] USED = "@(#)file.sl 1.33 (gritter) 4/14/06";
+ #include <fcntl.h>
+ #include <libgen.h>
+ #include <inttypes.h>
+-#ifndef major
++#include <sys/sysmacros.h>
++#if 0
+ #include <sys/mkdev.h>
+ #endif
+ #include "iblok.h"
+diff --git a/find/find.c b/find/find.c
+index fac70f0..28e1b7f 100644
+--- a/find/find.c
++++ b/find/find.c
+@@ -83,7 +83,8 @@ static const char sccsid[] USED = "@(#)find.sl 1.45 (gritter) 5/8/06";
+ #ifdef _AIX
+ #include <sys/sysmacros.h>
+ #endif
+-#ifndef major
++#include <sys/sysmacros.h>
++#if 0
+ #include <sys/mkdev.h>
+ #endif
+ #if __NetBSD_Version__>= 300000000
+diff --git a/ls/ls.c b/ls/ls.c
+index e4480d0..17186ba 100644
--- a/ls/ls.c
+++ b/ls/ls.c
-@@ -119,7 +119,7 @@
+@@ -119,7 +119,7 @@ static char ifmt_c[] = "-pc-d-b--nl-SD--";
#include <termcap.h>
#endif /* USE_TERMCAP */
@@ -23,3 +59,31 @@
#include <sys/sysmacros.h>
#endif
+diff --git a/mknod/mknod.c b/mknod/mknod.c
+index b772b88..f465883 100644
+--- a/mknod/mknod.c
++++ b/mknod/mknod.c
+@@ -45,7 +45,8 @@ static const char sccsid[] USED = "@(#)mknod.sl 1.8 (gritter) 5/29/05";
+ #include <string.h>
+ #include <limits.h>
+ #include <unistd.h>
+-#ifndef major
++#include <sys/sysmacros.h>
++#if 0
+ #include <sys/mkdev.h>
+ #endif /* !major */
+
+diff --git a/tar/tar.c b/tar/tar.c
+index 2d3dada..a8f1ccb 100644
+--- a/tar/tar.c
++++ b/tar/tar.c
+@@ -98,7 +98,8 @@ static const char sccsid[] USED = "@(#)tar.sl 1.177 (gritter) 4/14/07";
+ #include <sys/sysmacros.h>
+ #endif
+
+-#ifndef major
++#include <sys/sysmacros.h>
++#if 0
+ #include <sys/mkdev.h>
+ #endif /* !major */
+
diff --git a/sys-apps/heirloom-tools/files/heirloom-tools-070715-makefile.patch b/sys-apps/heirloom-tools/files/heirloom-tools-070715-makefile.patch
new file mode 100644
index 000000000000..a4ce2970589d
--- /dev/null
+++ b/sys-apps/heirloom-tools/files/heirloom-tools-070715-makefile.patch
@@ -0,0 +1,16 @@
+diff --git a/Makefile.mk b/Makefile.mk
+index 28a20f1..1cf36b8 100644
+--- a/Makefile.mk
++++ b/Makefile.mk
+@@ -73,11 +73,6 @@ links:
+ sh build/crossln $(ROOT)$(SV3BIN)/more $(ROOT)$(UCBBIN)/more $(ROOT)
+ rm -f $(ROOT)$(UCBBIN)/catman
+ sh build/crossln $(ROOT)$(DEFSBIN)/catman $(ROOT)$(UCBBIN)/catman $(ROOT)
+- for i in sccs prt; \
+- do \
+- rm -f $(ROOT)$(UCBBIN)/$$i; \
+- sh build/crossln $(ROOT)$(CCSBIN)/$$i $(ROOT)$(UCBBIN)/$$i $(ROOT); \
+- done
+ rm -f $(ROOT)$(SV3BIN)/awk
+ sh build/crossln $(ROOT)$(DEFBIN)/oawk $(ROOT)$(SV3BIN)/awk $(ROOT)
+ rm -f $(ROOT)$(S42BIN)/awk