summaryrefslogtreecommitdiff
path: root/sys-apps/hwdata/hwdata-0.376.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-04 16:07:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-04 16:07:53 +0000
commitbc968d15e7f24968eb69567c7f2fca470fdedacd (patch)
tree83b6eb5cd28c5ee30fcf8818f84b201e5dde503d /sys-apps/hwdata/hwdata-0.376.ebuild
parent7813a8a74857ef01cb12bd755ea0a94688a3efe2 (diff)
gentoo auto-resync : 04:11:2023 - 16:07:52
Diffstat (limited to 'sys-apps/hwdata/hwdata-0.376.ebuild')
-rw-r--r--sys-apps/hwdata/hwdata-0.376.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/hwdata/hwdata-0.376.ebuild b/sys-apps/hwdata/hwdata-0.376.ebuild
new file mode 100644
index 000000000000..afddd20d2fd1
--- /dev/null
+++ b/sys-apps/hwdata/hwdata-0.376.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo
+
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="https://github.com/vcrhonek/hwdata"
+SRC_URI="https://github.com/vcrhonek/hwdata/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT="test"
+
+src_configure() {
+ # configure is not compatible with econf
+ local conf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/lib"
+ --datadir="${EPREFIX}/usr/share"
+ )
+
+ edo "${conf[@]}"
+}