summaryrefslogtreecommitdiff
path: root/sys-apps/irqbalance/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:52:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:52:04 +0100
commit71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /sys-apps/irqbalance/files
parent6612a728ea11526a849618ec515ad57131d64416 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'sys-apps/irqbalance/files')
-rw-r--r--sys-apps/irqbalance/files/irqbalance-1.2.0-tinfo.patch32
-rw-r--r--sys-apps/irqbalance/files/irqbalance-1.4.0-configure.patch68
-rw-r--r--sys-apps/irqbalance/files/irqbalance.init.327
-rw-r--r--sys-apps/irqbalance/files/irqbalance.service.18
4 files changed, 68 insertions, 67 deletions
diff --git a/sys-apps/irqbalance/files/irqbalance-1.2.0-tinfo.patch b/sys-apps/irqbalance/files/irqbalance-1.2.0-tinfo.patch
deleted file mode 100644
index 20716542b6dd..000000000000
--- a/sys-apps/irqbalance/files/irqbalance-1.2.0-tinfo.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 287d50594fe624bdb4400611d0dbecec6ff38a41 Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Wed, 1 Mar 2017 17:11:42 +0100
-Subject: [PATCH] Prefer pkgconfig to check for ncursesw.
-
-That way we take possible separate tinfo lib into account.
----
- configure.ac | 8 +++++++-
- 1 file changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 17b879a..77d8aa4 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -26,7 +26,13 @@ AC_CHECK_FUNCS(getopt_long)
- AC_CHECK_LIB(numa, numa_available)
- AC_CHECK_LIB(m, floor)
-
--AC_CHECK_LIB(curses, mvprintw)
-+PKG_CHECK_MODULES([NCURSESW], [ncursesw], [has_ncursesw=yes], [AC_CHECK_LIB(curses, mvprintw)])
-+AS_IF([test "x$has_ncursesw" = "xyes"], [
-+ AC_SUBST([NCURSESW_CFLAGS])
-+ AC_SUBST([NCURSESW_LIBS])
-+ LIBS="$LIBS $NCURSESW_LIBS"
-+ AC_SUBST([LIBS])
-+])
-
- AC_C_CONST
- AC_C_INLINE
---
-2.12.0
-
diff --git a/sys-apps/irqbalance/files/irqbalance-1.4.0-configure.patch b/sys-apps/irqbalance/files/irqbalance-1.4.0-configure.patch
new file mode 100644
index 000000000000..6008e45126c7
--- /dev/null
+++ b/sys-apps/irqbalance/files/irqbalance-1.4.0-configure.patch
@@ -0,0 +1,68 @@
+From 8ad74cdabac37599d20a985e6a456b1faca92df8 Mon Sep 17 00:00:00 2001
+From: Manuel Mommertz <2kmm@gmx.de>
+Date: Mon, 9 Jul 2018 14:08:35 +0200
+Subject: [PATCH 1/2] configure.ac: Fix --without-caps option
+
+irqbalance links to libcap-ng if it is installed, even when useflag
+caps is disabled. This is an error in the configure-script, which
+checks for the wrong variable to determine if the user used --with/
+--without for libcap-ng.
+
+Downstream bug report: https://bugs.gentoo.org/660782
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index f6c60da..19b148a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -65,7 +65,7 @@ AC_ARG_WITH([libcap-ng],
+ AS_HELP_STRING([libcap-ng], [Add libcap-ng-support @<:@default=auto@:>@]))
+
+ AS_IF(
+- [test "x$libcap_ng" != "xno"],
++ [test "x$with_libcap_ng" != "xno"],
+ [
+ PKG_CHECK_MODULES([LIBCAP_NG], [libcap-ng],
+ [AC_DEFINE(HAVE_LIBCAP_NG,1,[libcap-ng support])],
+--
+2.18.0
+
+From bc56dbd4eead9ad19ff1d84dc8810123c96503c0 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Mon, 9 Jul 2018 14:11:44 +0200
+Subject: [PATCH 2/2] configure.ac: Fix --enable-irqbalance-ui logic
+
+Before this patch --enable-irqbalance-ui disabled compilation/
+installation of the ui because AC_ARG_WITH is used wrong.
+The third arguement to AC_ARG_WITH is _action-if-present_ which means
+that this action gets triggered once the --enable option has been
+submitted to configure on command line no matter if it's enabled or
+disabled.
+See also https://autotools.io/autoconf/arguments.html chapter 3.1
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 19b148a..75c234d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -43,9 +43,9 @@ AM_PROG_CC_C_O
+ AC_ARG_WITH([irqbalance-ui],
+ [AC_HELP_STRING([--without-irqbalance-ui],
+ [Dont build the irqbalance ui component])],
+- [with_irqbalanceui=false], [with_irqbalanceui=true])
++ [with_irqbalanceui=$withval], [with_irqbalanceui=yes])
+
+-AM_CONDITIONAL([IRQBALANCEUI], [test x$with_irqbalanceui = xtrue])
++AM_CONDITIONAL([IRQBALANCEUI], [test x$with_irqbalanceui = xyes])
+
+ AC_ARG_WITH([systemd],
+ [ AS_HELP_STRING([--with-systemd],[Add systemd-lib support])]
+--
+2.18.0
+
diff --git a/sys-apps/irqbalance/files/irqbalance.init.3 b/sys-apps/irqbalance/files/irqbalance.init.3
deleted file mode 100644
index 9ed16416510d..000000000000
--- a/sys-apps/irqbalance/files/irqbalance.init.3
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-
-depend() {
- need localmount
- after bootmisc
-}
-
-command="/usr/sbin/irqbalance"
-command_args="${IRQBALANCE_OPTS}"
-
-check_sysfs() {
- if grep -q MSI /proc/interrupts 2>/dev/null && \
- test -z "$(find /sys/devices -type d -name msi_irqs 2>/dev/null)"; then
- eerror "MSI interrupts found in /proc/interrupts but none found in sysfs."
- eerror "You need to update your kernel."
- return 1
- fi
-}
-
-start() {
- check_sysfs || return 1
- ebegin "Starting irqbalance"
- start-stop-daemon --exec ${command} --start -- ${IRQBALANCE_OPTS}
- eend $?
-}
diff --git a/sys-apps/irqbalance/files/irqbalance.service.1 b/sys-apps/irqbalance/files/irqbalance.service.1
deleted file mode 100644
index af7a979a25d0..000000000000
--- a/sys-apps/irqbalance/files/irqbalance.service.1
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Description=CPU Interrupt Balancer
-
-[Service]
-ExecStart=/usr/sbin/irqbalance --foreground
-
-[Install]
-WantedBy=multi-user.target