summaryrefslogtreecommitdiff
path: root/sys-apps/logwatch/logwatch-7.5.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-apps/logwatch/logwatch-7.5.6.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-apps/logwatch/logwatch-7.5.6.ebuild')
-rw-r--r--sys-apps/logwatch/logwatch-7.5.6.ebuild93
1 files changed, 0 insertions, 93 deletions
diff --git a/sys-apps/logwatch/logwatch-7.5.6.ebuild b/sys-apps/logwatch/logwatch-7.5.6.ebuild
deleted file mode 100644
index 24fb4fa00cfe..000000000000
--- a/sys-apps/logwatch/logwatch-7.5.6.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit tmpfiles
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
- inherit git-r3
-else
- SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ppc ppc64 sparc x86"
-fi
-
-DESCRIPTION="Analyzes and Reports on system logs"
-HOMEPAGE="https://sourceforge.net/projects/logwatch/"
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="virtual/cron
- virtual/mta
- virtual/mailx
- dev-lang/perl
- dev-perl/Date-Calc
- dev-perl/Date-Manip
- dev-perl/Tie-IxHash
- dev-perl/Sys-CPU
- dev-perl/Sys-MemInfo"
-
-PATCHES=()
-
-src_install() {
- dodir /usr/share/logwatch/lib
- dodir /usr/share/logwatch/scripts/services
- dodir /usr/share/logwatch/scripts/shared
- dodir /usr/share/logwatch/default.conf/logfiles
- dodir /usr/share/logwatch/default.conf/services
- dodir /usr/share/logwatch/default.conf/html
- keepdir /etc/logwatch
-
- # logwatch.pl requires cache dir (bug #607668)
- newtmpfiles "${FILESDIR}"/logwatch.tmpfile ${PN}.conf
-
- newsbin scripts/logwatch.pl logwatch.pl
-
- exeinto /usr/share/logwatch/lib
- doexe lib/*.pm
-
- exeinto /usr/share/logwatch/scripts/services
- doexe scripts/services/*
-
- exeinto /usr/share/logwatch/scripts/shared
- doexe scripts/shared/*
-
- insinto /usr/share/logwatch/default.conf
- doins conf/logwatch.conf
-
- insinto /usr/share/logwatch/default.conf/logfiles
- doins conf/logfiles/*
-
- insinto /usr/share/logwatch/default.conf/services
- doins conf/services/*
-
- insinto /usr/share/logwatch/default.conf/html
- doins conf/html/*
-
- # Make sure logwatch is run before anything else #100243
- exeinto /etc/cron.daily
- newexe "${FILESDIR}"/logwatch 00-logwatch
-
- doman logwatch.8
- dodoc README HOWTO-Customize-LogWatch
-
- # Do last due to insopts modification.
- insinto /usr/share/logwatch/scripts/logfiles
- insopts -m755
- doins -r scripts/logfiles/*
-}
-
-pkg_postinst() {
- # Migration from /etc/cron.daily/logwatch -> /etc/cron.daily/00-logwatch (bug #100243)
- if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
- local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
- [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
- && rm -f "${ROOT}"/etc/cron.daily/logwatch \
- || ewarn "You have two logwatch files in /etc/cron.daily/"
- fi
-
- # Trigger cache dir creation to allow immediate use of logwatch (bug #607668)
- tmpfiles_process ${PN}.conf
-}