summaryrefslogtreecommitdiff
path: root/sys-apps/openrc/openrc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /sys-apps/openrc/openrc-9999.ebuild
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'sys-apps/openrc/openrc-9999.ebuild')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild31
1 files changed, 14 insertions, 17 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index dc6f3b58eabc..eda95f741414 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -53,6 +53,8 @@ RDEPEND="${COMMON_DEPEND}
>=sec-policy/selinux-base-policy-2.20170204-r4
>=sec-policy/selinux-openrc-2.20170204-r4
)
+ !app-shells/gentoo-bashcomp
+ !<app-shells/gentoo-zsh-completions-20180228
"
PDEPEND="netifrc? ( net-misc/netifrc )"
@@ -73,7 +75,7 @@ src_compile() {
MAKE_ARGS="${MAKE_ARGS}
LIBNAME=$(get_libdir)
- LIBEXECDIR=${EPREFIX}/$(get_libdir)/rc
+ LIBEXECDIR=${EPREFIX}/lib/rc
MKBASHCOMP=yes
MKNET=$(usex newnet)
MKSELINUX=$(usex selinux)
@@ -124,9 +126,9 @@ src_install() {
gen_usr_ldscript librc.so
if ! use kernel_linux; then
- keepdir /$(get_libdir)/rc/init.d
+ keepdir /lib/rc/init.d
fi
- keepdir /$(get_libdir)/rc/tmp
+ keepdir /lib/rc/tmp
# Backup our default runlevels
dodir /usr/share/"${PN}"
@@ -295,24 +297,19 @@ pkg_postinst() {
elog "# rc-update add consolefont boot"
fi
- # Handle the conf.d/local.{start,stop} -> local.d transition
- if path_exists -o "${EROOT}"etc/conf.d/local.{start,stop} ; then
- elog "Moving your ${EROOT}etc/conf.d/local.{start,stop}"
- elog "files to ${EROOT}etc/local.d"
- mv "${EROOT}"etc/conf.d/local.start "${EROOT}"etc/local.d/baselayout1.start
- mv "${EROOT}"etc/conf.d/local.stop "${EROOT}"etc/local.d/baselayout1.stop
- chmod +x "${EROOT}"etc/local.d/*{start,stop}
- fi
-
- if use kernel_linux && [[ "${EROOT}" = "/" ]]; then
- if ! /$(get_libdir)/rc/sh/migrate-to-run.sh; then
- ewarn "The dependency data could not be migrated to /run/openrc."
- ewarn "This means you need to reboot your system."
+ # Added for 0.35.
+ if use kernel_linux && [[ ! -h "${EROOT}"/lib ]]; then
+ if [[ -d "${EROOT}$(get_libdir)"/rc ]]; then
+ cp -RPp "${EROOT}$(get_libdir)/rc" "${EROOT}"lib
+ fi
+ elif ! use kernel_linux; then
+ if [[ -d "${EROOT}$(get_libdir)"/rc ]]; then
+ cp -RPp "${EROOT}$(get_libdir)/rc" "${EROOT}"lib
fi
fi
# update the dependency tree after touching all files #224171
- [[ "${EROOT}" = "/" ]] && "${EROOT}/${LIBDIR}"/rc/bin/rc-depend -u
+ [[ "${EROOT}" = "/" ]] && "${EROOT}"/lib/rc/bin/rc-depend -u
if ! use newnet && ! use netifrc; then
ewarn "You have emerged OpenRc without network support. This"