summaryrefslogtreecommitdiff
path: root/sys-apps/openrc/openrc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /sys-apps/openrc/openrc-9999.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'sys-apps/openrc/openrc-9999.ebuild')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 891a73480c4b..6bf7ded639ba 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -159,10 +159,10 @@ src_install() {
pkg_preinst() {
# avoid default thrashing in conf.d files when possible #295406
- if [[ -e "${EROOT}"etc/conf.d/hostname ]] ; then
+ if [[ -e "${EROOT}"/etc/conf.d/hostname ]] ; then
(
unset hostname HOSTNAME
- source "${EROOT}"etc/conf.d/hostname
+ source "${EROOT}"/etc/conf.d/hostname
: ${hostname:=${HOSTNAME}}
[[ -n ${hostname} ]] && set_config /etc/conf.d/hostname hostname "${hostname}"
)
@@ -183,11 +183,11 @@ pkg_postinst() {
# Added for 0.35.
if use kernel_linux && [[ ! -h "${EROOT}"/lib ]]; then
if [[ -d "${EROOT}$(get_libdir)"/rc ]]; then
- cp -RPp "${EROOT}$(get_libdir)/rc" "${EROOT}"lib
+ cp -RPp "${EROOT}$(get_libdir)/rc" "${EROOT}"/lib
fi
elif ! use kernel_linux; then
if [[ -d "${EROOT}$(get_libdir)"/rc ]]; then
- cp -RPp "${EROOT}$(get_libdir)/rc" "${EROOT}"lib
+ cp -RPp "${EROOT}$(get_libdir)/rc" "${EROOT}"/lib
fi
fi
@@ -202,7 +202,7 @@ pkg_postinst() {
ewarn
fi
- if use newnet && [ ! -e "${EROOT}"etc/runlevels/boot/network ]; then
+ if use newnet && [ ! -e "${EROOT}"/etc/runlevels/boot/network ]; then
ewarn "Please add the network service to your boot runlevel"
ewarn "as soon as possible. Not doing so could leave you with a system"
ewarn "without networking."