summaryrefslogtreecommitdiff
path: root/sys-apps/openrc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-05 12:08:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-05 12:08:58 +0000
commitf29a41111b3a606f5d95049b1ba92daabbc68cc0 (patch)
tree310589df1ffb427b1a0595a329cfb2845335b778 /sys-apps/openrc
parent083bdfbef9bc532b72cf116591025916eebaf676 (diff)
gentoo auto-resync : 05:01:2023 - 12:08:57
Diffstat (limited to 'sys-apps/openrc')
-rw-r--r--sys-apps/openrc/Manifest2
-rw-r--r--sys-apps/openrc/openrc-0.46.ebuild169
2 files changed, 171 insertions, 0 deletions
diff --git a/sys-apps/openrc/Manifest b/sys-apps/openrc/Manifest
index 698366d0542e..6a0994dd76ed 100644
--- a/sys-apps/openrc/Manifest
+++ b/sys-apps/openrc/Manifest
@@ -2,6 +2,8 @@ AUX openrc-0.45.2-grep-3.8.patch 1175 BLAKE2B ba19778859730be7f85558ba5577eec414
AUX openrc.logrotate 43 BLAKE2B 0587cd211767937fd6273e6b159271490443a94d80a54b5a20ef625a1959e77dbf38cd1756838337fb39a061c4ee19a39cccd2f5867fab9f04fb916a74029aaa SHA512 12bb6354e808fbf47bbab963de55ee7901738b4a912659982c57ef2777fff9a670e867fcb8ec316a76b151032c92dc89a950d7d1d835ef53f753a8f3b41d2cec
AUX start-stop-daemon.pam 63 BLAKE2B df39a1a12fe09dbbc0746eac67035d9e6d4a63323f6c937ef3888c70787354128e415b3c1c8bccccec0c987b3e789711cd1ddaba55e9b53a7f67b332c4ca9d5b SHA512 85cf440611b8f87f51bf24bdd9fa03639a75b950f00096d81b8826c21ae85ff9784b8c56b8ddb482e70f08bce933d4561b30750346d51fb2cef3be34acc065cb
DIST openrc-0.45.2.tar.gz 246515 BLAKE2B bb7d52b183612eb8924a2d0f9ec63eea88253d8d83964d6341a4715a6cdc372b3fd99ad0f972f4f539da9d741548777dabf4ced86fd20be741a89a69ffe2ff01 SHA512 ca2958772240f6e5037e39db1ee62a81091a2efa654da967f68e03a721868c6c0a41d32a2bddf55c8eadbc9bf5837b710cc2e4564844a7fbc0e585366da4fdf9
+DIST openrc-0.46.tar.gz 247679 BLAKE2B 55490afc179e1e56a58408e8a2b7ebd5376ffee25cb61f2838a47cc97ad1e4eadabcc7f74e5cc2a2d9217917eb42517cf01766de2e82b50a3500bdbe263b0d88 SHA512 7c837e4b553511f0621944222ca0d35bd553a9888bd482ca0f8f3d2923d5b51cbd1f1c2f33cccb26d9f13dfb488939b95064673bedb7fcbf78d68664df2678c7
EBUILD openrc-0.45.2-r2.ebuild 4595 BLAKE2B da0df99c14b6984dc97aee9beaf5cb777bb3d15076d6f6be64459327c4848fecd0957a3e42c2135bbc3dd6e2e9ee17f4004a4750108a4b3e33c4dc22c2e68e2c SHA512 e2a3fd3dc7aab7bcdcc81aaa8f9ac4b889cfaf82229054f0c71e9caeb49a8fa9395fa39eb215b66d73b78b7c18a661a4289ca2844a907a5c92250898b7809e35
+EBUILD openrc-0.46.ebuild 4553 BLAKE2B 34db45754ffdb78bd14c6350685f09ca5ea4ba7c1eff03c58b86737d7be2211a6662c7d50d9cd47e8e91a08f0965dead30689b7c822ef1afb01624a21ea9f1e1 SHA512 e28ca92b5815123deec1b5922bdf189eaa7df692a828493726dd8940c6dbcafca81bea7f5741f9faf3fe556bdd12f2d2ddc8b46df7a596cf8a25bb55613b5e73
EBUILD openrc-9999.ebuild 4553 BLAKE2B f806b0547ff994c52c342715043d2f0c7fff2a6dfe61151e58c0bb46a40afae03ce3d5c0e45220b89c89f70018981d97390a181603a134447169d1ade94aea3b SHA512 5215b2129a086deefc099f802329189faf219feab85897ced9b47d4c31405e64ca85d98ca9a1218ddb671204e5678c60a02c9551c7a8ff57d5c4681a4ec7a973
MISC metadata.xml 707 BLAKE2B 713b69a4e4d6a61051c9f6dfda46da3afa62c590c62b4f371f3949140eaecfa665a977091ac858bff99380dfc3758038ee6a96b0c8b88c142e2e751b20318fba SHA512 5260e1aec8973d42bf059b1f20b3a5f95b98608efeac614d46b20d774a3453c25348cea4a45d745abe829ad016dbc524080c482c1666032e969e08fefe1efc37
diff --git a/sys-apps/openrc/openrc-0.46.ebuild b/sys-apps/openrc/openrc-0.46.ebuild
new file mode 100644
index 000000000000..605fcb7487f8
--- /dev/null
+++ b/sys-apps/openrc/openrc-0.46.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson pam
+
+DESCRIPTION="OpenRC manages the services, startup and shutdown of a host"
+HOMEPAGE="https://github.com/openrc/openrc/"
+
+if [[ ${PV} =~ ^9{4,}$ ]]; then
+ EGIT_REPO_URI="https://github.com/OpenRC/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/OpenRC/openrc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="audit bash debug ncurses pam newnet +netifrc selinux sysv-utils unicode"
+
+COMMON_DEPEND="
+ ncurses? ( sys-libs/ncurses:0= )
+ pam? ( sys-libs/pam )
+ audit? ( sys-process/audit )
+ sys-process/psmisc
+ selinux? (
+ sys-apps/policycoreutils
+ >=sys-libs/libselinux-2.6
+ )"
+DEPEND="${COMMON_DEPEND}
+ virtual/os-headers
+ ncurses? ( virtual/pkgconfig )"
+RDEPEND="${COMMON_DEPEND}
+ bash? ( app-shells/bash )
+ !prefix? (
+ sysv-utils? (
+ !sys-apps/systemd[sysv-utils(-)]
+ !sys-apps/sysvinit
+ )
+ !sysv-utils? (
+ || (
+ >=sys-apps/sysvinit-2.86-r6[selinux?]
+ sys-apps/s6-linux-init[sysv-utils(-)]
+ )
+ )
+ virtual/tmpfiles
+ )
+ selinux? (
+ >=sec-policy/selinux-base-policy-2.20170204-r4
+ >=sec-policy/selinux-openrc-2.20170204-r4
+ )
+"
+
+PDEPEND="netifrc? ( net-misc/netifrc )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature audit)
+ "-Dbranding=\"Gentoo Linux\""
+ $(meson_use newnet)
+ -Dos=Linux
+ $(meson_use pam)
+ $(meson_feature selinux)
+ -Drootprefix="${EPREFIX}"
+ -Dshell=$(usex bash /bin/bash /bin/sh)
+ $(meson_use sysv-utils sysvinit)
+ -Dtermcap=$(usev ncurses)
+ )
+ # export DEBUG=$(usev debug)
+ meson_src_configure
+}
+
+# set_config <file> <option name> <yes value> <no value> test
+# a value of "#" will just comment out the option
+set_config() {
+ local file="${ED}/$1" var=$2 val com
+ eval "${@:5}" && val=$3 || val=$4
+ [[ ${val} == "#" ]] && com="#" && val='\2'
+ sed -i -r -e "/^#?${var}=/{s:=([\"'])?([^ ]*)\1?:=\1${val}\1:;s:^#?:${com}:}" "${file}"
+}
+
+set_config_yes_no() {
+ set_config "$1" "$2" YES NO "${@:3}"
+}
+
+src_install() {
+ meson_install
+
+ keepdir /lib/rc/tmp
+
+ # Setup unicode defaults for silly unicode users
+ set_config_yes_no /etc/rc.conf unicode use unicode
+
+ # Cater to the norm
+ set_config_yes_no /etc/conf.d/keymaps windowkeys '(' use x86 '||' use amd64 ')'
+
+ # On HPPA, do not run consolefont by default (bug #222889)
+ if use hppa; then
+ rm -f "${ED}"/etc/runlevels/boot/consolefont
+ fi
+
+ # Support for logfile rotation
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/openrc.logrotate openrc
+
+ if use pam; then
+ # install gentoo pam.d files
+ newpamd "${FILESDIR}"/start-stop-daemon.pam start-stop-daemon
+ newpamd "${FILESDIR}"/start-stop-daemon.pam supervise-daemon
+ fi
+
+ # install documentation
+ dodoc *.md
+}
+
+pkg_preinst() {
+ # avoid default thrashing in conf.d files when possible #295406
+ if [[ -e "${EROOT}"/etc/conf.d/hostname ]] ; then
+ (
+ unset hostname HOSTNAME
+ source "${EROOT}"/etc/conf.d/hostname
+ : ${hostname:=${HOSTNAME}}
+ [[ -n ${hostname} ]] && set_config /etc/conf.d/hostname hostname "${hostname}"
+ )
+ fi
+
+ # set default interactive shell to sulogin if it exists
+ set_config /etc/rc.conf rc_shell /sbin/sulogin "#" test -e /sbin/sulogin
+ return 0
+}
+
+pkg_postinst() {
+ if use hppa; then
+ elog "Setting the console font does not work on all HPPA consoles."
+ elog "You can still enable it by running:"
+ elog "# rc-update add consolefont boot"
+ fi
+
+ if ! use newnet && ! use netifrc; then
+ ewarn "You have emerged OpenRc without network support. This"
+ ewarn "means you need to SET UP a network manager such as"
+ ewarn " net-misc/netifrc, net-misc/dhcpcd, net-misc/connman,"
+ ewarn " net-misc/NetworkManager, or net-vpn/badvpn."
+ ewarn "Or, you have the option of emerging openrc with the newnet"
+ ewarn "use flag and configuring /etc/conf.d/network and"
+ ewarn "/etc/conf.d/staticroute if you only use static interfaces."
+ ewarn
+ fi
+
+ if use newnet && [ ! -e "${EROOT}"/etc/runlevels/boot/network ]; then
+ ewarn "Please add the network service to your boot runlevel"
+ ewarn "as soon as possible. Not doing so could leave you with a system"
+ ewarn "without networking."
+ ewarn
+ fi
+
+ # added for 0.45 to handle seedrng/urandom switching (2022-06-07)
+ for v in ${REPLACING_VERSIONS}; do
+ [[ -x $(type rc-update) ]] || continue
+ if ver_test $v -lt 0.45; then
+ if rc-update show boot | grep -q urandom; then
+ rc-update del urandom boot
+ rc-update add seedrng boot
+ fi
+ fi
+ done
+}