summaryrefslogtreecommitdiff
path: root/sys-apps/rename/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/rename/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/rename/files')
-rw-r--r--sys-apps/rename/files/rename-1.3-build.patch11
-rw-r--r--sys-apps/rename/files/rename-1.3-gcc44.patch16
-rw-r--r--sys-apps/rename/files/rename-1.3-rename.patch95
3 files changed, 122 insertions, 0 deletions
diff --git a/sys-apps/rename/files/rename-1.3-build.patch b/sys-apps/rename/files/rename-1.3-build.patch
new file mode 100644
index 000000000000..6d184435ddc1
--- /dev/null
+++ b/sys-apps/rename/files/rename-1.3-build.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -16,7 +16,7 @@
+ all: rename
+
+ rename: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+
+ static: $(OBJS)
diff --git a/sys-apps/rename/files/rename-1.3-gcc44.patch b/sys-apps/rename/files/rename-1.3-gcc44.patch
new file mode 100644
index 000000000000..71f5e88b3398
--- /dev/null
+++ b/sys-apps/rename/files/rename-1.3-gcc44.patch
@@ -0,0 +1,16 @@
+diff -NrU5 rename-1.3.original/rename.c rename-1.3/rename.c
+--- a/rename.c 2009-06-14 00:21:43.000000000 -0600
++++ b/rename.c 2009-06-14 00:22:21.000000000 -0600
+@@ -63,11 +63,11 @@
+ #endif
+ #endif
+
+ #if HAVE_REGEX_H
+ #include <regex.h>
+-#elif
++#else
+ #include "regex.h"
+ #endif
+
+ #if HAVE_GETOPT_H
+ #include <getopt.h>
diff --git a/sys-apps/rename/files/rename-1.3-rename.patch b/sys-apps/rename/files/rename-1.3-rename.patch
new file mode 100644
index 000000000000..127959fb3b34
--- /dev/null
+++ b/sys-apps/rename/files/rename-1.3-rename.patch
@@ -0,0 +1,95 @@
+--- a/rename.c
++++ b/rename.c
+@@ -594,7 +594,7 @@
+ } else {
+ rs = rename(oldp, new);
+ if (rs < 0)
+- perror("rename");
++ perror("renamexm");
+ else if (attr & MOD_VERBO)
+ printf("ok\n");
+
+@@ -628,8 +628,8 @@
+ {
+
+ char *help = "\
+-Usage: rename SOURCE DEST\n\
+- or: rename [OPTION] file ...\n\
++Usage: renamexm SOURCE DEST\n\
++ or: renamexm [OPTION] file ...\n\
+ Rename SOURCE to DEST, or substitute characters match the specified pattern\n\
+ in the filename.\n\
+ \n\
+--- a/rename.1
++++ b/rename.1
+@@ -1,16 +1,16 @@
+ .TH NAME SECTION
+ .SH Name
+-rename \- file rename tool
++renamexm \- file rename tool
+
+ .SH SYNOPSIS
+-.B rename
++.B renamexm
+ .I OldName NewName
+ .P
+-.B rename
++.B renamexm
+ .I [options] files ...
+
+ .SH DESCRIPTION
+ This
+-.I rename
++.I renamexm
+ is a quick and powerful tool for
+ .I upcasing,
+@@ -276,5 +276,5 @@
+ .SH EXAMPLES
+ .TP
+-.I rename foo food
++.I renamexm foo food
+ Change file 'foo' to 'food', just like
+ .I mv(1)
+@@ -282,23 +282,23 @@
+
+ .TP
+-.I rename -lR *
++.I renamexm -lR *
+ To lowcase all filenames, directories and filenames and directories under
+ subdirectories.
+
+ .TP
+-.I rename -s/abc/xyz/gi *.c
++.I renamexm -s/abc/xyz/gi *.c
+ Substitute all 'abc' substrings appeared in C sources files with 'xyz',
+ ignoring case.
+
+ .TP
+-.I rename -vs/.c/.cpp/s *.c
++.I renamexm -vs/.c/.cpp/s *.c
+ Change C sources suffix to C++ sources suffix, with verbose information.
+
+ .TP
+-.I rename -s/abc/12345/bi *
++.I renamexm -s/abc/12345/bi *
+ Find the last occurrence of 'abc' and replace it with '12345', ignoring case.
+
+ .TP
+-.I rename -o guest -R /home/custom
++.I renamexm -o guest -R /home/custom
+ change the owner of the file '/home/custom' to 'guest'. The 'guest' should
+ be an effective user in the current system. If '/home/custom' is a directory,
+@@ -306,5 +306,5 @@
+
+ .TP
+-.I rename -s/^[A-Z].*file/nofile/r *
++.I renamexm -s/^[A-Z].*file/nofile/r *
+ The target substring starts with a capital letter, and ends with string 'file'.
+ There are 0 or any numbers of characters between the capital letter and 'file'.
+@@ -312,5 +312,5 @@
+
+ .TP
+-.I rename -s/^[A-Z].+file/nofile/eg *
++.I renamexm -s/^[A-Z].+file/nofile/eg *
+ Similar to last example, except it uses extended regular expression, such as
+ the '+' metacharacter, and replaces all matching strings with 'nofile'.