summaryrefslogtreecommitdiff
path: root/sys-apps/sandbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-08 06:41:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-08 06:41:21 +0000
commit9991465b0b90d77b2a8a2ae833b6ecd99e6b5101 (patch)
tree28adc48ed9c9af3eec4c870d7a7efc8da5e0d8f1 /sys-apps/sandbox
parentd69399c7befdd98cda62d6a1788ae2aa7f104c5e (diff)
gentoo auto-resync : 08:01:2025 - 06:41:21
Diffstat (limited to 'sys-apps/sandbox')
-rw-r--r--sys-apps/sandbox/Manifest1
-rw-r--r--sys-apps/sandbox/sandbox-2.9999.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index e7639141d82e..54ea4632b790 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -7,4 +7,5 @@ EBUILD sandbox-2.39.ebuild 1731 BLAKE2B 0597372e7ed3b698e8a45243170e68b175f025f9
EBUILD sandbox-2.40.ebuild 1739 BLAKE2B 090794105c6616689b819cbe1c715714402c81777bda0dc5a7c55ac7669080d775b1e3d09f6abceaa92e403f0ffc56d92eba5165ff3199b47a3b521d822be7d7 SHA512 36b0309d807cc86cce508b2ffea5b504338d35b730eb980d5205a4b420d6e9bc05835cc70259d8b76c532f1e3aea241a47457376a1934745bef7bd159dd6f608
EBUILD sandbox-2.41.ebuild 1739 BLAKE2B 090794105c6616689b819cbe1c715714402c81777bda0dc5a7c55ac7669080d775b1e3d09f6abceaa92e403f0ffc56d92eba5165ff3199b47a3b521d822be7d7 SHA512 36b0309d807cc86cce508b2ffea5b504338d35b730eb980d5205a4b420d6e9bc05835cc70259d8b76c532f1e3aea241a47457376a1934745bef7bd159dd6f608
EBUILD sandbox-2.42.ebuild 1739 BLAKE2B 090794105c6616689b819cbe1c715714402c81777bda0dc5a7c55ac7669080d775b1e3d09f6abceaa92e403f0ffc56d92eba5165ff3199b47a3b521d822be7d7 SHA512 36b0309d807cc86cce508b2ffea5b504338d35b730eb980d5205a4b420d6e9bc05835cc70259d8b76c532f1e3aea241a47457376a1934745bef7bd159dd6f608
+EBUILD sandbox-2.9999.ebuild 2047 BLAKE2B 57b382786b10dab836d3212320b01394818c5fc4405945b62e7fc50ac9a8ebc7ccf2ea0b1795d185eb2d10f6a53d2bc20bb777adc3f767b4856e79b0925b440c SHA512 49eb21fab7edf8e7b76b4d3b419347371f27478c1cf6b8daf39a112e4ea830094f1bc712a1c359d51a700c7242fa8655ef83055b1f9136fe639e39d82b6134a2
MISC metadata.xml 512 BLAKE2B 2befd96e6697e45e04b9e5c6594d30987f035b52fe2d642e10b67b3a2f9657b63f66f48439cd6df71f07ad6fe112220f195d453595c4bf1ef47561cfb8c0428d SHA512 1869fc1c558817f7c7ace988184b74647a82c94e51f0bdb610011bd6736034188abb778e3c5b852ff39daad5a7ef131b09468353b0764a4957dfe72da4767601
diff --git a/sys-apps/sandbox/sandbox-2.9999.ebuild b/sys-apps/sandbox/sandbox-2.9999.ebuild
new file mode 100644
index 000000000000..bf0e493e800c
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-2.9999.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit flag-o-matic multilib-minimal multiprocessing
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/sandbox.git
+ https://github.com/gentoo/sandbox.git"
+ EGIT_BRANCH="stable-2.x"
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Sandbox"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+nnp"
+
+# pax-utils lower bound for bug #265376
+DEPEND=">=app-misc/pax-utils-0.1.19"
+# Avoid folks installing with older file, bug #889046. We still need the
+# >= dep in Portage but this is a safety net if people do partial upgrades.
+RDEPEND="!<sys-apps/file-5.44-r1"
+BDEPEND="app-arch/xz-utils"
+
+has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS+=" sandbox_death_notice"
+
+sandbox_death_notice() {
+ ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
+ ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
+}
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == *9999 ]]; then
+ eautoreconf
+ fi
+
+ if ! use nnp ; then
+ sed -i 's:PR_SET_NO_NEW_PRIVS:___disable_nnp_hack:' src/sandbox.c || die
+ fi
+}
+
+src_configure() {
+ # sandbox uses `__asm__ (".symver "...` which does
+ # not play well with gcc's LTO: https://gcc.gnu.org/PR48200
+ filter-lto
+
+ filter-lfs-flags #90228
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local ECONF_SOURCE="${S}"
+ econf
+}
+
+multilib_src_test() {
+ # Default sandbox build will run with --jobs set to # cpus.
+ emake check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
+}
+
+multilib_src_install_all() {
+ doenvd "${FILESDIR}"/09sandbox
+
+ dodoc AUTHORS ChangeLog* README.md
+}
+
+pkg_postinst() {
+ mkdir -p "${EROOT}"/var/log/sandbox
+ chown root:portage "${EROOT}"/var/log/sandbox
+ chmod 0770 "${EROOT}"/var/log/sandbox
+}