summaryrefslogtreecommitdiff
path: root/sys-apps/sed
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /sys-apps/sed
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/Manifest3
-rw-r--r--sys-apps/sed/metadata.xml3
-rw-r--r--sys-apps/sed/sed-4.4-r1.ebuild66
3 files changed, 71 insertions, 1 deletions
diff --git a/sys-apps/sed/Manifest b/sys-apps/sed/Manifest
index 751130fefb8a..ee083e215e16 100644
--- a/sys-apps/sed/Manifest
+++ b/sys-apps/sed/Manifest
@@ -7,5 +7,6 @@ DIST sed-4.3.tar.xz 1167168 BLAKE2B 5751943cb64d03afef727deba3bee7027a1611b4729c
DIST sed-4.4.tar.xz 1181664 BLAKE2B 03804c209c2108cca4aa991cd68065fd03a15c726b6daf5212603835b5c046c63e9c2e4c28f76dfe165128f060db5b992c981f314d2fe230f30521545d00a468 SHA512 4e1b0a7403913f1e25047eb2292a0a9b3488b15b4463ce2803e05eaecbc2da19f477a18e6a70c992461c38ced90774415091aa2d8ce85cb74e391610d9eedb70
EBUILD sed-4.2.2.ebuild 1703 BLAKE2B 85de6422cc772bb64b6e4ccb3a8e385e21314f266497a30753dd37f193c95ec57f0522488efb6e956f582e34182ae38d13492b01cb3fe90d504b6af4f9ca25ef SHA512 83ad39ac0a61046ddfb1ceab35284b776bf1bac6656f7a60d3e4eee8070febec7bdbfe23138934d0b6fb688142759825deab25eb6988c90b54d269b553cc274b
EBUILD sed-4.3-r1.ebuild 1471 BLAKE2B ccfc211be1e8ee18580188db738958243c13af4ed0a42934386628a086199bb48ce1edac9609098545f599b352824fd3bbf1e984fbc02dc928676150f010c16f SHA512 a87cb60ca1b125d0db8b90f5cd4211b5f90316cee63d5543ab92e089a1c6782599d66b9fcea2431523126a1e7b1b1230d14c396fdf2c6de1d2704aacee08ea87
+EBUILD sed-4.4-r1.ebuild 1731 BLAKE2B 0023f4b656ec18b2b4ee250e387ee978fe377840e130b9a9d1b72255ead62ee3b799b5c1dd55c56cf29a277460f0abe7b7ac1c2646377e62692e501ede065345 SHA512 0c75b2e7d8c33c4fcd87199b7e76c44baf1e7c84f616c60f6d8a1d3667c41a443397fbf270033e585d739c78d40fc67ea3c8ae3e543feda3bb63c45d173ed37d
EBUILD sed-4.4.ebuild 1431 BLAKE2B 81ed2cb028f7f748629b8c9b73a2786ed48bab298e92ad10c1b6b5436ac03d515766ad1223d1cff4c8157714abaca950e9791b498fbb1558dbbe8f2609039dda SHA512 d1cc340b33bb8d5ac0565136d9dabf84d261f5496fb0ebfe27f69a2d37dc8031bedb43e610e744d7bd60de0b672afde5e6fbdb4862d556ed960de832f2f7b94a
-MISC metadata.xml 323 BLAKE2B 746a8514f64aa6bc67931a9a1c61ff47dd0ff984dee09d04afd44557986ef1fe87ebdbd844fb68bdbe8158ec16b6d776b6f9956f2b5611495af5aa3d56c8bff5 SHA512 ec3a11f7aafded3d4b5e12680358f39dbeb166f96af51eae8dafb21b186024ddb9b5b9ba36bde626be01b1938fd6f4bbcb58f0f8bad2208a84d44eaadc95652e
+MISC metadata.xml 454 BLAKE2B 3bb53d0a0a1d85cb0415e9c81db669e048c980923b6aad172ab2e666a995ff7e88dbcc4290f479613a60b83aeb62d1b7d9bf9b5d4ea9ee8a190bea6a87dff7e4 SHA512 4c30d1ec7669e56902672117382e8617718858e9aaad078a6ed298428f55396a81d336963560d3f4679499a0f1e291f99462601ab0c76768359086fa9bcb9b55
diff --git a/sys-apps/sed/metadata.xml b/sys-apps/sed/metadata.xml
index b738f8c54a01..ea2a7bdbf75c 100644
--- a/sys-apps/sed/metadata.xml
+++ b/sys-apps/sed/metadata.xml
@@ -8,4 +8,7 @@
<upstream>
<remote-id type="sourceforge">sed</remote-id>
</upstream>
+<use>
+ <flag name="forced-sandbox">Always enable --sandbox mode for simpler/secure runtime (disables e/r/w commands)</flag>
+</use>
</pkgmetadata>
diff --git a/sys-apps/sed/sed-4.4-r1.ebuild b/sys-apps/sed/sed-4.4-r1.ebuild
new file mode 100644
index 000000000000..26c3858da53b
--- /dev/null
+++ b/sys-apps/sed/sed-4.4-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Super-useful stream editor"
+HOMEPAGE="http://sed.sourceforge.net/"
+SRC_URI="mirror://gnu/sed/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="acl forced-sandbox nls selinux static"
+
+RDEPEND="acl? ( virtual/acl )
+ nls? ( virtual/libintl )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_bootstrap_sed() {
+ # make sure system-sed works #40786
+ export NO_SYS_SED=""
+ if ! type -p sed > /dev/null ; then
+ NO_SYS_SED="!!!"
+ ./bootstrap.sh || die "couldnt bootstrap"
+ cp sed/sed "${T}"/ || die "couldnt copy"
+ export PATH="${PATH}:${T}"
+ emake clean
+ fi
+}
+
+src_prepare() {
+ # Don't use sed before bootstrap if we have to recover a broken host sed.
+ src_bootstrap_sed
+
+ if use forced-sandbox ; then
+ # Upstream doesn't want to add a configure flag for this.
+ # https://lists.gnu.org/archive/html/bug-sed/2018-03/msg00001.html
+ sed -i \
+ -e '/^bool sandbox = false;/s:false:true:' \
+ sed/sed.c || die
+ # Make sure the sed took.
+ grep -q '^bool sandbox = true;' sed/sed.c || die "forcing sandbox failed"
+ fi
+}
+
+src_configure() {
+ local myconf=()
+ if use userland_GNU; then
+ myconf+=( --exec-prefix="${EPREFIX}" )
+ else
+ myconf+=( --program-prefix=g )
+ fi
+
+ export ac_cv_search_setfilecon=$(usex selinux -lselinux)
+ export ac_cv_header_selinux_{context,selinux}_h=$(usex selinux)
+ use static && append-ldflags -static
+ myconf+=(
+ $(use_enable acl)
+ $(use_enable nls)
+ )
+ econf "${myconf[@]}"
+}