summaryrefslogtreecommitdiff
path: root/sys-apps/selinux-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sys-apps/selinux-python
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sys-apps/selinux-python')
-rw-r--r--sys-apps/selinux-python/Manifest4
-rw-r--r--sys-apps/selinux-python/selinux-python-3.2.ebuild85
-rw-r--r--sys-apps/selinux-python/selinux-python-9999.ebuild18
3 files changed, 93 insertions, 14 deletions
diff --git a/sys-apps/selinux-python/Manifest b/sys-apps/selinux-python/Manifest
index d0f21e752384..1902f3d3d190 100644
--- a/sys-apps/selinux-python/Manifest
+++ b/sys-apps/selinux-python/Manifest
@@ -1,4 +1,6 @@
DIST selinux-python-3.1.tar.gz 2100549 BLAKE2B c5d207bad60c379259e3bfc8f029f76d4572818cdd41a263498ed4434a70eaf7ff51af7772cfb27de0e9e4af03bcf9906ab0f6a59e88de10e81cbe0e8c5928b8 SHA512 5dd98f77ae8ea8bac6a89ec7def76e12496b9a9f8c9612c4cc1dac7a8e8c60380a00c857426bfefbcb4273706addd2594e9b467f69408ef284f082a09d45bd49
+DIST selinux-python-3.2.tar.gz 2101106 BLAKE2B b4b185a7468de68eb2146011a9bc82ffb7db9878517833c1e8dfa23279aec3dfbf46a27b70b17c1e317a2c939bcf6d1748638fd4a078325b853de34ae3c51a6f SHA512 2c3483e27c4ad6942e23e39897e0eccf61b95d685ace62315678cb49739d300d4ca4a7a51fa7a9aacaa98737446a70923855d15827eb6275ffd6999be0b2a755
EBUILD selinux-python-3.1-r2.ebuild 2543 BLAKE2B fd5cf8e64f172da259a7ff0f6be5d9d3f4824584b2d4e816689b5ac2c00c516b3692e748debd0dab51db4ef2faf07b10510b6b39147c0238969a6ca9cce25c45 SHA512 ae2066a82dd516c983aae8f00b1a7c14d25f61120904ce3cfcaf5958866d659386860598b76137a6ed311e7c6ad550f710f4b6daf099db4c125501c6768c1c72
-EBUILD selinux-python-9999.ebuild 2545 BLAKE2B 7f5b9c6db2d0e88516e4e53512432b95e8c546fefce46b02efa481cc06aea80e0aafe7ad04aeb9e9bff328ab260b5c19f889bd3e17a87c9beaab91d2c51f0e6e SHA512 449604db5ba1d8331416e0d51bc6c5613d074ebcc3d309706a81392b745a6069dd1e041176c53c24a9632c318c21d65ffb4cb43947c41e728e9c5288b8a6dc07
+EBUILD selinux-python-3.2.ebuild 2383 BLAKE2B fcc4d47cd407f0004f2522e7341a424479310352c7452e30a6d5e09716e4b36c6bd4dc3887d4c6754a1fea99eb86ed165de097f8a5c5bbeae85529791f2ebd04 SHA512 9ac89baabe3bbfe17e87cabaaad5358a5d16aea252db7a407c58fb751fbf8306277c7df88ba54403251fdd843ece1dd2bef96155e870a71888f3cceccb86bbb5
+EBUILD selinux-python-9999.ebuild 2383 BLAKE2B fcc4d47cd407f0004f2522e7341a424479310352c7452e30a6d5e09716e4b36c6bd4dc3887d4c6754a1fea99eb86ed165de097f8a5c5bbeae85529791f2ebd04 SHA512 9ac89baabe3bbfe17e87cabaaad5358a5d16aea252db7a407c58fb751fbf8306277c7df88ba54403251fdd843ece1dd2bef96155e870a71888f3cceccb86bbb5
MISC metadata.xml 557 BLAKE2B 40a5075b9313be98cc5566696ebdf42dfa77814d2c5907832c06b8f846cb902023949bca3aa1b37a03a756649c6025f5f91357c0f6c73292b864396ea1c118cd SHA512 248d0177b4794bd342b35ce901f91a67227f1d8b256f6a56f06b3d424e94dbfb48b8500623bdccc2e0650402276cc1e50d1a7f475e2b04505ec0d4b4f2b590fe
diff --git a/sys-apps/selinux-python/selinux-python-3.2.ebuild b/sys-apps/selinux-python/selinux-python-3.2.ebuild
new file mode 100644
index 000000000000..def193bf03db
--- /dev/null
+++ b/sys-apps/selinux-python/selinux-python-3.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1 toolchain-funcs
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DESCRIPTION="SELinux core utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN#selinux-}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~mips ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libselinux-${PV}:=[python]
+ >=sys-libs/libsemanage-${PV}:=[python(+)]
+ >=sys-libs/libsepol-${PV}:=
+ >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
+ >=sys-process/audit-1.5.1[python,${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+
+ python_copy_sources
+}
+
+src_compile() {
+ building() {
+ emake -C "${BUILD_DIR}" \
+ CC="$(tc-getCC)" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+ }
+ python_foreach_impl building
+}
+
+src_install() {
+ installation() {
+ emake -C "${BUILD_DIR}" \
+ DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ install
+ python_optimize
+ }
+ python_foreach_impl installation
+
+ # Set version-specific scripts
+ for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
+ python_replicate_script "${ED}/usr/bin/${pyscript}"
+ done
+ for pyscript in semanage; do
+ python_replicate_script "${ED}/usr/sbin/${pyscript}"
+ done
+
+ # Create sepolgen.conf with different devel location definition
+ if [[ -f /etc/selinux/config ]];
+ then
+ local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
+ mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ local selinuxtype="${POLICY_TYPES%% *}";
+ if [[ -n "${selinuxtype}" ]];
+ then
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
+ fi
+ fi
+}
diff --git a/sys-apps/selinux-python/selinux-python-9999.ebuild b/sys-apps/selinux-python/selinux-python-9999.ebuild
index 59dad86d9671..def193bf03db 100644
--- a/sys-apps/selinux-python/selinux-python-9999.ebuild
+++ b/sys-apps/selinux-python/selinux-python-9999.ebuild
@@ -7,13 +7,6 @@ PYTHON_REQ_USE="xml"
inherit python-r1 toolchain-funcs
-MY_P="${P//_/-}"
-
-MY_RELEASEDATE="20200710"
-SEPOL_VER="${PV}"
-SELNX_VER="${PV}"
-SEMNG_VER="${PV}"
-
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DESCRIPTION="SELinux core utilities"
@@ -22,19 +15,18 @@ HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN#selinux-}"
+ S="${WORKDIR}/${P}/${PN#selinux-}"
else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~mips ~x86"
- S="${WORKDIR}/${MY_P}"
fi
LICENSE="GPL-2"
SLOT="0"
-DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
- >=sys-libs/libsemanage-${SEMNG_VER}:=[python(+)]
- >=sys-libs/libsepol-${SEPOL_VER}:=
+DEPEND=">=sys-libs/libselinux-${PV}:=[python]
+ >=sys-libs/libsemanage-${PV}:=[python(+)]
+ >=sys-libs/libsepol-${PV}:=
>=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
>=sys-process/audit-1.5.1[python,${PYTHON_USEDEP}]
${PYTHON_DEPS}"