summaryrefslogtreecommitdiff
path: root/sys-apps/systemd-utils/systemd-utils-254.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
commit783da4542a9c3e0e1ec703644212707cde610679 (patch)
tree3e0cf56ac37ddf9d5fdc6ff0ced9135b1c7fc5e0 /sys-apps/systemd-utils/systemd-utils-254.3.ebuild
parentd0041c590ed45bbfeae458ea926e36bc64e41dd7 (diff)
gentoo auto-resync : 10:09:2023 - 22:36:45
Diffstat (limited to 'sys-apps/systemd-utils/systemd-utils-254.3.ebuild')
-rw-r--r--sys-apps/systemd-utils/systemd-utils-254.3.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/sys-apps/systemd-utils/systemd-utils-254.3.ebuild b/sys-apps/systemd-utils/systemd-utils-254.3.ebuild
index 1912fe2b9f6b..849af65cc76c 100644
--- a/sys-apps/systemd-utils/systemd-utils-254.3.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-254.3.ebuild
@@ -310,7 +310,7 @@ multilib_src_compile() {
tmpfiles.d/{etc,static-nodes-permissions,var}.conf
)
if use test; then
- targets+=( test-tmpfiles )
+ targets+=( test-tmpfile-util )
fi
fi
if use udev; then
@@ -338,16 +338,12 @@ multilib_src_compile() {
)
if use test; then
targets+=(
- # Used by udev-test.pl
- systemd-detect-virt
- test/sys
- test-udev
-
test-fido-id-desc
test-udev-builtin
test-udev-event
test-udev-node
test-udev-util
+ udev-rule-runner
)
fi
fi
@@ -381,23 +377,19 @@ multilib_src_test() {
if use tmpfiles; then
tests+=(
test-systemd-tmpfiles.standalone
- test-tmpfiles
+ test-tmpfile-util
)
fi
if use udev; then
tests+=(
rule-syntax-check
test-fido-id-desc
+ test-udev
test-udev-builtin
test-udev-event
test-udev-node
test-udev-util
)
- if [[ -w /dev ]]; then
- tests+=( udev-test )
- else
- ewarn "Skipping udev-test (needs write access to /dev)"
- fi
fi
fi
if use udev; then
@@ -449,6 +441,7 @@ multilib_src_install() {
exeinto "${rootprefix}"/lib/udev
doexe src/udev/{ata_id,cdrom_id,fido_id,mtd_probe,scsi_id,v4l_id}
+ rm -f rules.d/99-systemd.rules
insinto "${rootprefix}"/lib/udev/rules.d
doins rules.d/*.rules