summaryrefslogtreecommitdiff
path: root/sys-apps/systemd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-30 22:42:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-30 22:42:58 +0100
commit3b4199328e240d392ef1f03900219cb88bdafcff (patch)
tree06007a008d485a5e0a169f2807b68f456e9df1b3 /sys-apps/systemd
parentaca0af8133e724b7edf0b5c6efe12c39077a3dc9 (diff)
gentoo auto-resync : 30:07:2023 - 22:42:58
Diffstat (limited to 'sys-apps/systemd')
-rw-r--r--sys-apps/systemd/Manifest2
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild48
2 files changed, 9 insertions, 41 deletions
diff --git a/sys-apps/systemd/Manifest b/sys-apps/systemd/Manifest
index 848523af400d..b8e7c7153abc 100644
--- a/sys-apps/systemd/Manifest
+++ b/sys-apps/systemd/Manifest
@@ -19,5 +19,5 @@ EBUILD systemd-253.5.ebuild 14588 BLAKE2B ac789628c1caa53681c78be188c85a660fd61a
EBUILD systemd-253.6.ebuild 14667 BLAKE2B 3b154c55c573e2306f871c362f3d7207fb9b7efee374f118cf4b94477a3e01060b473b293fe86d3ba0923fd9cd7d9e9f8b06490f59514002caadf1b203387e7d SHA512 3c39c8742b35540bb7d70e9277876c10e648e78d4e549cb65bb0a4b843aca3bbea91ee39e0698b294415e9e77dd6c7f350497fe5f841619e11cd2301950bafc0
EBUILD systemd-253.7.ebuild 14669 BLAKE2B 106db6ca3073de27cd0f7c72b30397da77cbd98dfe1d1357f67d39f61e722c47d7fd5b3b7378e329883e9894cfe90159f3db50400ca5d791b438907b00b797b3 SHA512 56e632a1f7d396607df97f3bfbde8e85ed4534b69b341e196356adf26f932f54db0bde0365ea5e4ef8c84e36662b61b7465ba4b3336c0eebbaa3932554c13eaa
EBUILD systemd-254.ebuild 14955 BLAKE2B 22ad4cec2f63bdaaa5f4f6d81cedcb84dd3c910241cbeeedb43b8ee1279c8981b7e783252eb0c88e1e688ced9aa38c9303523802dea3864d1509779fb035fde3 SHA512 b89300d9a6d0f553e42c1bb1524df2dba734c41fe7a6a6788935040b4a71e9f29d479405e38ce2fc78c8a62d89cd8c3b56d219c991e9fcedd3ac293c144c6ebf
-EBUILD systemd-9999.ebuild 14805 BLAKE2B 62d8ad8d32113194ed3719f90989aa1c912ec72764c4426ad1de10e53b54e30485b1f0beac558d91c3060e773af30f4b881fa84013147c67623303681760b633 SHA512 b6298270ce255d6c439ecaf84b5d4e60aa8f6d4fe5d9c0d030225216638d78558a667f5708e881aba7f027534da2249ef7567800278f2b0fb85a12ea7be8a38e
+EBUILD systemd-9999.ebuild 13695 BLAKE2B 5944a40e9785ee8977759a553dd1aef3de4c404d3ef2e072e8ee5d650c47f78241011b6b9f95ff11a038b9046c7357bc289342109cb33c7ccd248cb4516cb9e8 SHA512 00928f8f54b16527c77f17198fc5e17e618c0c323b7c839470edf6aa88267b729caea3d8a11f19d2d1f1c2c3f85ea4d19ffa9d34b87e64a8a6b325a952ab94fd
MISC metadata.xml 2612 BLAKE2B 60495769a304d0623f73de8eb305770eb93706fdcbea158a2de2beb72e5d04495fc5ef45b4e55d3003a9a70bc3f60a7a5d6880aaac9512647132be69f96112ad SHA512 397f63a498b46647edfb665f92680197607de5edef42c3c17ab96abf94f117d82eda4863bf138329e25880609e8c631e9d154277e8a548eafbe87e8b83e47ccc
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 2995dae33660..d8fc3cedd386 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -27,7 +27,7 @@ else
fi
inherit bash-completion-r1 linux-info meson-multilib pam python-single-r1
-inherit secureboot systemd toolchain-funcs udev usr-ldscript
+inherit secureboot systemd toolchain-funcs udev
DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://systemd.io/"
@@ -181,6 +181,9 @@ QA_FLAGS_IGNORED="usr/lib/systemd/boot/efi/.*"
QA_EXECSTACK="usr/lib/systemd/boot/efi/*"
pkg_pretend() {
+ if use split-usr; then
+ die "systemd no longer supports split-usr"
+ fi
if [[ ${MERGE_TYPE} != buildonly ]]; then
if use test && has pid-sandbox ${FEATURES}; then
ewarn "Tests are known to fail with PID sandboxing enabled."
@@ -249,9 +252,6 @@ src_prepare() {
)
fi
- # Fails with split-usr.
- sed -i -e '2i exit 77' test/test-rpm-macros.sh || die
-
default
}
@@ -271,10 +271,7 @@ multilib_src_configure() {
-Dpamlibdir="$(getpam_mod_dir)"
# avoid bash-completion dep
-Dbashcompletiondir="$(get_bashcompdir)"
- $(meson_use split-usr)
- $(meson_use split-usr split-bin)
- -Drootprefix="$(usex split-usr "${EPREFIX:-/}" "${EPREFIX}/usr")"
- -Drootlibdir="${EPREFIX}/usr/$(get_libdir)"
+ -Dsplit-bin=false
# Disable compatibility with sysvinit
-Dsysvinit-path=
-Dsysvrcnd-path=
@@ -356,9 +353,6 @@ multilib_src_test() {
}
multilib_src_install_all() {
- local rootprefix=$(usex split-usr '' /usr)
- local sbin=$(usex split-usr sbin bin)
-
# meson doesn't know about docdir
mv "${ED}"/usr/share/doc/{systemd,${PF}} || die
@@ -369,19 +363,15 @@ multilib_src_install_all() {
doins "${FILESDIR}"/legacy.conf
if ! use resolvconf; then
- rm -f "${ED}${rootprefix}/${sbin}"/resolvconf || die
+ rm -f "${ED}"/usr/bin/resolvconf || die
fi
if ! use sysv-utils; then
- rm "${ED}${rootprefix}/${sbin}"/{halt,init,poweroff,reboot,shutdown} || die
+ rm "${ED}"/usr/bin/{halt,init,poweroff,reboot,shutdown} || die
rm "${ED}"/usr/share/man/man1/init.1 || die
rm "${ED}"/usr/share/man/man8/{halt,poweroff,reboot,shutdown}.8 || die
fi
- if ! use resolvconf && ! use sysv-utils && use split-usr; then
- rmdir "${ED}${rootprefix}"/sbin || die
- fi
-
# https://bugs.gentoo.org/761763
rm -r "${ED}"/usr/lib/sysusers.d || die
@@ -393,7 +383,7 @@ multilib_src_install_all() {
keepdir /etc/udev/hwdb.d
- keepdir "${rootprefix}"/lib/systemd/{system-sleep,system-shutdown}
+ keepdir /usr/lib/systemd/{system-sleep,system-shutdown}
keepdir /usr/lib/{binfmt.d,modules-load.d}
keepdir /usr/lib/systemd/user-generators
keepdir /var/lib/systemd
@@ -403,14 +393,6 @@ multilib_src_install_all() {
newpamd "${FILESDIR}"/systemd-user.pam systemd-user
fi
- if use split-usr; then
- # Avoid breaking boot/reboot
- dosym ../../../lib/systemd/systemd /usr/lib/systemd/systemd
- dosym ../../../lib/systemd/systemd-shutdown /usr/lib/systemd/systemd-shutdown
- fi
-
- gen_usr_ldscript -a systemd udev
-
if use boot; then
python_fix_shebang "${ED}"
secureboot_auto_sign
@@ -467,20 +449,6 @@ pkg_preinst() {
dosym ../../../etc/sysctl.conf /usr/lib/sysctl.d/99-sysctl.conf
fi
- if ! use split-usr; then
- local dir
- for dir in bin sbin lib usr/sbin; do
- if [[ ! -L ${EROOT}/${dir} ]]; then
- eerror "'${EROOT}/${dir}' is not a symbolic link."
- FAIL=1
- fi
- done
- if [[ ${FAIL} ]]; then
- eerror "Migration to system layout with merged directories must be performed before"
- eerror "installing ${CATEGORY}/${PN} with USE=\"-split-usr\" to avoid run-time breakage."
- die "System layout with split directories still used"
- fi
- fi
if ! use boot && has_version "sys-apps/systemd[gnuefi(-)]"; then
ewarn "The 'gnuefi' USE flag has been renamed to 'boot'."
ewarn "Make sure to enable the 'boot' USE flag if you use systemd-boot."