summaryrefslogtreecommitdiff
path: root/sys-apps/sysvinit/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-27 16:34:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-27 16:34:32 +0100
commit1a7ba844ad2c84ac4ba0d37f510285e778c7ffc4 (patch)
tree6b0c029b423e831d2d4be3aea13954182623d7f4 /sys-apps/sysvinit/files
parenta12f416baa722b8bda57c0d527fb28b3d06b2aeb (diff)
gentoo auto-resync : 27:07:2023 - 16:34:32
Diffstat (limited to 'sys-apps/sysvinit/files')
-rw-r--r--sys-apps/sysvinit/files/sysvinit-3.05-fix-man-makefile.patch19
-rw-r--r--sys-apps/sysvinit/files/sysvinit-3.07-halt.patch53
2 files changed, 53 insertions, 19 deletions
diff --git a/sys-apps/sysvinit/files/sysvinit-3.05-fix-man-makefile.patch b/sys-apps/sysvinit/files/sysvinit-3.05-fix-man-makefile.patch
deleted file mode 100644
index e6079baca1f5..000000000000
--- a/sys-apps/sysvinit/files/sysvinit-3.05-fix-man-makefile.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-https://github.com/slicer69/sysvinit/commit/e7622b031dac56e1836d2c6e353da4b7f8367aab
-
-From: Adam Sampson <ats@offog.org>
-Date: Sun, 21 Aug 2022 22:13:09 +0100
-Subject: [PATCH] Use the .po files to work out which manpage dirs to create.
-
-The pattern being used here didn't match anything in a tarball release.
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -214,7 +214,7 @@ install: all
- fi
- $(INSTALL_DIR) $(ROOT)/usr/include/
- $(INSTALL_DATA) initreq.h $(ROOT)/usr/include/
-- for lang in '' $(subst ../man/,,$(wildcard ../man/po/??/)); do \
-+ for lang in '' $(patsubst ../man/po/%.po,%,$(wildcard ../man/po/??.po)); do \
- $(INSTALL_DIR) $(ROOT)$(MANDIR)/man1/$$lang; \
- $(INSTALL_DIR) $(ROOT)$(MANDIR)/man5/$$lang; \
- $(INSTALL_DIR) $(ROOT)$(MANDIR)/man8/$$lang; \
-
diff --git a/sys-apps/sysvinit/files/sysvinit-3.07-halt.patch b/sys-apps/sysvinit/files/sysvinit-3.07-halt.patch
new file mode 100644
index 000000000000..4e65a912ccde
--- /dev/null
+++ b/sys-apps/sysvinit/files/sysvinit-3.07-halt.patch
@@ -0,0 +1,53 @@
+https://github.com/slicer69/sysvinit/pull/18
+https://bugs.gentoo.org/911257
+
+From fca101c2ff428eb765958ae6e3aaa0eb1adc0fdf Mon Sep 17 00:00:00 2001
+From: Jesse <jsmith@resonatingmedia.com>
+Date: Thu, 27 Jul 2023 00:39:53 -0300
+Subject: [PATCH] Floppym provided patch which causes the halt command to call
+ "shutdown -h -H" instead of "shutdown -h" when halt is invoked without
+ parameters. This forces the shutdown command to set the INIT_HALT variable
+ and assume, unless other conditions apply, that the "halt" call really wants
+ to halt the machine and INIT_HALT should be set. In other words we assume
+ halt wants to halt unless told otherwise. Addresses downstream Gentoo bug ID
+ 911257.
+
+---
+ doc/Changelog | 11 +++++++++++
+ src/halt.c | 4 ++--
+ 2 files changed, 13 insertions(+), 2 deletions(-)
+
+diff --git a/doc/Changelog b/doc/Changelog
+index c00f6ef..b902756 100644
+--- a/doc/Changelog
++++ b/doc/Changelog
+@@ -1,3 +1,14 @@
++sysvinit (3.08) unreleased; urgency=low
++ * Floppym provided patch which causes the halt command
++ to call "shutdown -h -H" instead of "shutdown -h" when
++ halt is invoked without parameters. This forces the shutdown
++ command to set the INIT_HALT variable and assume, unless other
++ conditions apply, that the "halt" call really wants to halt the
++ machine and INIT_HALT should be set. In other words we
++ assume halt wants to halt unless told otherwise.
++ Addresses downstream Gentoo bug ID 911257.
++
++
+ sysvinit (3.07) released; urgency=low
+ * Fixed killall5 so that processes in the omit list are
+ not sent any signals, including SIGSTOP.
+diff --git a/src/halt.c b/src/halt.c
+index a469147..9bd3a4d 100644
+--- a/src/halt.c
++++ b/src/halt.c
+@@ -162,8 +162,8 @@ void do_shutdown(char *fl, int should_poweroff, char *tm)
+
+ args[i++] = "shutdown";
+ args[i++] = fl;
+- if ( (! strcmp(fl, "-h") ) && (should_poweroff) )
+- args[i++] = "-P";
++ if (! strcmp(fl, "-h"))
++ args[i++] = (should_poweroff ? "-P" : "-H");
+ if (tm) {
+ args[i++] = "-t";
+ args[i++] = tm;