summaryrefslogtreecommitdiff
path: root/sys-apps/texinfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /sys-apps/texinfo
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'sys-apps/texinfo')
-rw-r--r--sys-apps/texinfo/Manifest2
-rw-r--r--sys-apps/texinfo/texinfo-6.8.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/sys-apps/texinfo/Manifest b/sys-apps/texinfo/Manifest
index 70d88dd1b21c..98871dcdeda4 100644
--- a/sys-apps/texinfo/Manifest
+++ b/sys-apps/texinfo/Manifest
@@ -1,3 +1,5 @@
DIST texinfo-6.7.tar.gz 9027808 BLAKE2B ac9a47ae98f27ae55ea1844c74ead6fba256635a56e7a226a1bbdd9ee9ab33565ff8cc7a874410afe6463741285c8fcfd8ff835ae2802009e2d0758405559140 SHA512 a52aaa2f0113c6f14b3cb94fbf7191770017ff6ce2016292770831279cfbb898c2f7f720adee620e08d9d80a9505df89a689ba0c25e92f6579b28b075f7b8ee2
+DIST texinfo-6.8.tar.gz 10119420 BLAKE2B df9dc1698e7bb4f7c97ba4d44b08631502e3f997b91169ae64161b69701fbb0f85c82295ef6867e716a0addfd7c5677e14079645b167bd74933a0153fee92200 SHA512 f46dfb1c0f324a9c54959a8f256f0dcb8aaa59caccb0f027a5ee39a173b6e51a31a488f9d787707e7aa8401a439b2a01a1f3022dbae24ef377a1c021c1ebeb37
EBUILD texinfo-6.7.ebuild 1941 BLAKE2B 26caf30f52c31e1de0718ae11eee9043910d6d80b81c70797102c3a026c6e767ff68a9f6f055fb67c88019c56af8ed678fed14c5d4ac290d76c2a42fb9adfc38 SHA512 c1e18457082628d892e5b58a3f514a1058b0b53a681da0863f72da6a6120d98dee47104155e84618fbab2e794f6571cc3803c32577b9602ac670ecffe98efa69
+EBUILD texinfo-6.8.ebuild 1933 BLAKE2B 11ffd7f86c56a8b9f96e5251ab159762624cf2c7eeaa69905621fae108ad2a34ca033b1ea38471904f42c90e40f8212160e7f1b55bc0cc33aced9a1d5134f068 SHA512 d998953fb2e2f16074e5a570b7379e376058fc15b4dce565e1c26c7223fd7d60b3d8effb1310ace1ab2c4a7946d4180e2e201dcfb709be2182a04f958d07a6d3
MISC metadata.xml 539 BLAKE2B 5445a2b07c6bbecb3c33c64e80227f57ff80b17b0b440a3d0220a88ed1bb930deb1b0274eff8db1a64fe82c64e7f34b1183c533b1a1ca7b41694668e2c5b682b SHA512 4d0b0b223f04e6ebc4e7a7546dbf6b731fc0676657c8d3c3cd38a54c327f4eebda927f1793ead3f8f255bc82d7884b5acd6df8431674db48c2ebbbd1098cb032
diff --git a/sys-apps/texinfo/texinfo-6.8.ebuild b/sys-apps/texinfo/texinfo-6.8.ebuild
new file mode 100644
index 000000000000..3f25e5592134
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-6.8.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: if your package uses the texi2dvi utility, it must depend on the
+# virtual/texi2dvi package to pull in all the right deps. The tool is not
+# usable out-of-the-box because it requires the large tex packages.
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="https://www.gnu.org/software/texinfo/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls +standalone static"
+
+RDEPEND="
+ !=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2:0=
+ standalone? ( dev-lang/perl )
+ !standalone? (
+ dev-lang/perl:=
+ dev-perl/libintl-perl
+ dev-perl/Unicode-EastAsianWidth
+ dev-perl/Text-Unidecode
+ )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( >=sys-devel/gettext-0.19.6 )"
+
+src_prepare() {
+ default
+
+ if use prefix ; then
+ sed -i -e '1c\#!/usr/bin/env sh' util/texi2dvi util/texi2pdf || die
+ touch doc/{texi2dvi,texi2pdf,pdftexi2dvi}.1
+ fi
+}
+
+src_configure() {
+ # Respect compiler and CPPFLAGS/CFLAGS/LDFLAGS for Perl extensions. #622576
+ local -x PERL_EXT_CC="$(tc-getCC)" PERL_EXT_CPPFLAGS="${CPPFLAGS}" PERL_EXT_CFLAGS="${CFLAGS}" PERL_EXT_LDFLAGS="${LDFLAGS}"
+
+ use static && append-ldflags -static
+ local myeconfargs=( $(use_enable nls) )
+
+ if use standalone ; then
+ myeconfargs+=(
+ --without-external-libintl-perl
+ --without-external-Unicode-EastAsianWidth
+ --without-external-Text-Unidecode
+ --disable-perl-xs
+ )
+ else
+ myeconfargs+=(
+ --with-external-libintl-perl
+ --with-external-Unicode-EastAsianWidth
+ --with-external-Text-Unidecode
+ --enable-perl-xs
+ )
+ fi
+
+ econf "${myeconfargs[@]}"
+}