summaryrefslogtreecommitdiff
path: root/sys-apps/toybox/toybox-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /sys-apps/toybox/toybox-9999.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'sys-apps/toybox/toybox-9999.ebuild')
-rw-r--r--sys-apps/toybox/toybox-9999.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/sys-apps/toybox/toybox-9999.ebuild b/sys-apps/toybox/toybox-9999.ebuild
index 68a184db8ebe..5b1788940a17 100644
--- a/sys-apps/toybox/toybox-9999.ebuild
+++ b/sys-apps/toybox/toybox-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
inherit multiprocessing savedconfig toolchain-funcs
@@ -13,16 +13,12 @@ else
KEYWORDS="~amd64 ~x86"
fi
-# makefile is stupid
-RESTRICT="test"
-
DESCRIPTION="Common linux commands in a multicall binary"
HOMEPAGE="https://landley.net/code/toybox/"
# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
LICENSE="BSD-2"
SLOT="0"
-IUSE=""
src_prepare() {
default
@@ -32,7 +28,10 @@ src_prepare() {
src_configure() {
tc-export CC STRIP
export HOSTCC="$(tc-getBUILD_CC)"
- if [ -f .config ]; then
+ # Respect CFLAGS
+ export OPTIMIZE="${CFLAGS}"
+
+ if [[ -f .config ]]; then
yes "" | emake -j1 oldconfig > /dev/null
return 0
else