summaryrefslogtreecommitdiff
path: root/sys-apps/tuned/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/tuned/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/tuned/files')
-rw-r--r--sys-apps/tuned/files/tuned-2.7.0-upstream.patch39
-rw-r--r--sys-apps/tuned/files/tuned-2.7.1-makefile-rpm.patch19
-rw-r--r--sys-apps/tuned/files/tuned-2.7.1-sysctl.patch11
-rw-r--r--sys-apps/tuned/files/tuned.initd16
4 files changed, 85 insertions, 0 deletions
diff --git a/sys-apps/tuned/files/tuned-2.7.0-upstream.patch b/sys-apps/tuned/files/tuned-2.7.0-upstream.patch
new file mode 100644
index 000000000000..f864433b1941
--- /dev/null
+++ b/sys-apps/tuned/files/tuned-2.7.0-upstream.patch
@@ -0,0 +1,39 @@
+diff --git a/tuned-gui.py b/tuned-gui.py
+index 0555404..b169dec 100755
+--- a/tuned-gui.py
++++ b/tuned-gui.py
+@@ -89,7 +89,7 @@ class Base(object):
+ try:
+ self.controller = \
+ tuned.admin.DBusController(consts.DBUS_BUS,
+- consts.DBUS_OBJECT, consts.DBUS_INTERFACE)
++ consts.DBUS_INTERFACE, consts.DBUS_OBJECT)
+ self.controller.is_running()
+ except tuned.admin.exceptions.TunedAdminDBusException, ex:
+ response = self.tuned_daemon_exception_dialog.run()
+diff --git a/tuned.spec b/tuned.spec
+index 3a2dcec..1b46daf 100644
+--- a/tuned.spec
++++ b/tuned.spec
+@@ -334,8 +334,6 @@ fi
+ %changelog
+ * Tue Jul 19 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 2.7.0-1
+ - new-release
+- - rebase tuned to latest upstream
+- resolves: rhbz#1289048
+ - gui: fixed save profile
+ resolves: rhbz#1242491
+ - tuned-adm: added --ignore-missing parameter
+diff --git a/tuned/admin/admin.py b/tuned/admin/admin.py
+index ad501c0..cbdd1be 100644
+--- a/tuned/admin/admin.py
++++ b/tuned/admin/admin.py
+@@ -98,7 +98,7 @@ class Admin(object):
+
+ def _action_list(self):
+ self._print_profiles(self._profiles_locator.get_known_names_summary())
+- self._action_dbus_active()
++ self._action_active()
+ return True
+
+ def _dbus_get_active_profile(self):
diff --git a/sys-apps/tuned/files/tuned-2.7.1-makefile-rpm.patch b/sys-apps/tuned/files/tuned-2.7.1-makefile-rpm.patch
new file mode 100644
index 000000000000..408ef2b73c3a
--- /dev/null
+++ b/sys-apps/tuned/files/tuned-2.7.1-makefile-rpm.patch
@@ -0,0 +1,19 @@
+diff --git a/Makefile b/Makefile
+index df2a139..6200cae 100644
+--- a/Makefile
++++ b/Makefile
+@@ -19,8 +19,12 @@ else
+ GIT_PSUFFIX = .$(GIT_SUFFIX)
+ RPM_VERSION = $(NAME)-$(VERSION)-1$(GIT_PSUFFIX)
+ endif
+-UNITDIR = $(shell rpm --eval '%{_unitdir}' 2>/dev/null || echo /usr/lib/systemd/system)
+-TMPFILESDIR = $(shell rpm --eval '%{_tmpfilesdir}' 2>/dev/null || echo /usr/lib/tmpfiles.d)
++UNITDIR_FALLBACK = /usr/lib/systemd/system
++UNITDIR_DETECT = $(shell rpm --eval '%{_unitdir}' 2>/dev/null || echo $(UNITDIR_FALLBACK))
++UNITDIR = $(UNITDIR_DETECT:%{_unitdir}=$(UNITDIR_FALLBACK))
++TMPFILESDIR_FALLBACK = /usr/lib/tmpfiles.d
++TMPFILESDIR_DETECT = $(shell rpm --eval '%{_tmpfilesdir}' 2>/dev/null || echo $(TMPFILESDIR_FALLBACK))
++TMPFILESDIR = $(TMPFILESDIR_DETECT:%{_tmpfilesdir}=$(TMPFILESDIR_FALLBACK))
+ VERSIONED_NAME = $(NAME)-$(VERSION)$(GIT_PSUFFIX)
+
+ DATADIR = /usr/share
diff --git a/sys-apps/tuned/files/tuned-2.7.1-sysctl.patch b/sys-apps/tuned/files/tuned-2.7.1-sysctl.patch
new file mode 100644
index 000000000000..8e2a70fc377d
--- /dev/null
+++ b/sys-apps/tuned/files/tuned-2.7.1-sysctl.patch
@@ -0,0 +1,11 @@
+--- a/tuned/plugins/plugin_sysctl.py
++++ b/tuned/plugins/plugin_sysctl.py
+@@ -67,7 +67,7 @@
+ self._write_sysctl(option, value)
+
+ def _execute_sysctl(self, arguments):
+- execute = ["/sbin/sysctl"] + arguments
++ execute = ["sysctl"] + arguments
+ log.debug("executing %s" % execute)
+ return self._cmd.execute(execute)
+
diff --git a/sys-apps/tuned/files/tuned.initd b/sys-apps/tuned/files/tuned.initd
new file mode 100644
index 000000000000..61a25347b2e3
--- /dev/null
+++ b/sys-apps/tuned/files/tuned.initd
@@ -0,0 +1,16 @@
+#!/sbin/openrc-run
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+TUNED_PIDFILE="/run/tuned.pid"
+TUNED_LOGFILE="/var/log/tuned.log"
+
+command="/usr/sbin/tuned"
+command_args="-d --pid ${TUNED_PIDFILE} --log ${TUNED_LOGFILE}"
+pidfile=${TUNED_PIDFILE}
+
+description="tuned is a daemon for monitoring and adaptive tuning of system devices."
+
+depend() {
+ need dbus
+}