summaryrefslogtreecommitdiff
path: root/sys-apps/which
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-10 00:12:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-10 00:12:21 +0000
commit3a81cede4783e464b7485722b2eaac0280dbc570 (patch)
tree261618bfbe562244c237d48a7960d4952bc6b318 /sys-apps/which
parentb95a6fd4a7b591baa7cfc689f8ce5643592d07be (diff)
gentoo auto-resync : 10:02:2025 - 00:12:20
Diffstat (limited to 'sys-apps/which')
-rw-r--r--sys-apps/which/Manifest2
-rw-r--r--sys-apps/which/which-2.23.ebuild20
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/which/Manifest b/sys-apps/which/Manifest
index 30e75c41f105..e6835085cdd6 100644
--- a/sys-apps/which/Manifest
+++ b/sys-apps/which/Manifest
@@ -1,3 +1,5 @@
DIST which-2.21.tar.gz 149305 BLAKE2B 355888b0dfe3e4e1679a8a9e1255a935fa48be220408abc441fae69fe0b26bd39e0544ed20e75497ed5bccaa75e788d9aec17007c668f15eaf6b1599faa131a0 SHA512 d2f04a5c5291f2d7d1226982da7cf999d36cfe24d3f7bda145508efcfb359511251d3c68b860c0ddcedd66b15a0587b648a35ab6d1f173707565305c506dfc61
+DIST which-2.23.tar.gz 201930 BLAKE2B 64a3ae1f23a4c389f945f6c0985e6f6062b46785125a0d0659ff160560a4a473633d38af71b1505beeabba8336f5a9906f1ba58ab3494635e970bd5529b3936f SHA512 738807f79e8cfc5967541a28ae7021247c04c4177279f09be2c19c069af450a7e3b19baf9079fe5569b25b4630bb400be242a123647e52c9fe54f0ad007317bf
EBUILD which-2.21.ebuild 585 BLAKE2B bf0fee3337c761dc76e6a6e2ee9d04233a4fa6277d75f0328ed81465b636489a81e8358846adfede55d252900e2e9b21fcddd7381812ce5888beb33844317ba0 SHA512 7804ace758f358dce84611ccf9d98dbecf378ab5050bd7bc659404dfc4e26d3df2f1db79f9dc259ad0d6a2bb3c7dd075a34cb2e35055834aae1e1615e6965b9d
+EBUILD which-2.23.ebuild 579 BLAKE2B 3e692b62cb570b9319bafde68283e7cae83b76b2e61c61475b06d24b8e9fdb96db9180e75271fb25512a45856f497d4542e5994c76d3cd18b111f4cdfd1531b9 SHA512 327cbbb913c71a4da16c4006a1b2f655ee08fe4b47159028947a31f9fcf198c8a5d7b2ac1c1d6b66d4dd7275db864aca30494c6597a7c7f0f2b2bc615f34ab18
MISC metadata.xml 254 BLAKE2B f3a9f843cf94243d1129711770df727fcdc8808bca829ef784819cab6f5410dfa463cfed85182f8228c7de796a674dd602653ad3ef817a62c0c3e7198b23befe SHA512 b9fcd3084a7e197f6138e1ce8b0eff99c4c203c37a7d5c40de207040ba1501ef0e5b2f4e00216a567037bcd6d3394fdec6ff587484c9ba2fca9d04f431733b7c
diff --git a/sys-apps/which/which-2.23.ebuild b/sys-apps/which/which-2.23.ebuild
new file mode 100644
index 000000000000..62bcd5206bbf
--- /dev/null
+++ b/sys-apps/which/which-2.23.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Prints out location of specified executables that are in your path"
+HOMEPAGE="https://carlowood.github.io/which/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+src_configure() {
+ tc-export AR
+
+ CONFIG_SHELL="${BROOT}"/bin/bash econf
+}