summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-27 22:42:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-27 22:42:39 +0000
commit417348c68a53a9317b6afbf343381518a405f682 (patch)
tree2436ae4cc1751690d448293f351e3fa529909437 /sys-apps
parent4f5eafd9cc8e9b40e20b0a1abd96f1bcd634d0a0 (diff)
gentoo auto-resync : 27:01:2025 - 22:42:39
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/Manifest.gzbin51508 -> 51515 bytes
-rw-r--r--sys-apps/hw-probe/Manifest2
-rw-r--r--sys-apps/hw-probe/hw-probe-1.6.6.ebuild63
3 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/Manifest.gz b/sys-apps/Manifest.gz
index a53271b1d0d4..20afbcd416e8 100644
--- a/sys-apps/Manifest.gz
+++ b/sys-apps/Manifest.gz
Binary files differ
diff --git a/sys-apps/hw-probe/Manifest b/sys-apps/hw-probe/Manifest
index d1ff10279ec6..ec0e06f1cc38 100644
--- a/sys-apps/hw-probe/Manifest
+++ b/sys-apps/hw-probe/Manifest
@@ -1,4 +1,6 @@
AUX README.gentoo 296 BLAKE2B df18c0796912c5cfe6e8f88427ea690512bfd519aa3502528df6f6936571497937a22f8edcd9e9143d915e648f9b341043141cc6d0ae35de55d22d44c0335f6e SHA512 4ae61b89352a4bbe70f4ea1b85eb19e58c2b81475722dda25c289fbe15e7e6e07df51b08471c5d3c5d7a3b12cc09ba599e0d2158dee68c9c66f60908d57b4326
DIST hw-probe-1.6.5_p20230812.tar.gz 166015 BLAKE2B 1c5e3ab58aa28e1d5a757d75e8b462b7eaf3da1eb4baca308c681000b95c333e8ea3141b9af2a28e8453a449ea38cca9f5239996e216c0c7dfc4414fc8781b8a SHA512 633cda1e1d6a3104587b6ebf4faad98526e0d6daec5e9a26b319a4b5b76baeac063277eca9e81e7903b28cdebbb3db095f7526d1f46511f885e37b31e1032b7d
+DIST hw-probe-1.6.6.tar.gz 170004 BLAKE2B 887649e25ed238b0f0de8e52f587489ed0877f8f93655ebc1c99e1901501e7c3cbfffd5480705781cf91bc3658b58daf05cbd6066ecf1eb3c52d1786028b0bb5 SHA512 ca645549d0b8f8a8c1c8f69498dd8591b55a2a007850b508fe1d6a48cd7c6e3ee25102ed348cb9578989014b7f069c4b9453ed7e516ce57dcbded1166c6ad017
EBUILD hw-probe-1.6.5_p20230812.ebuild 2406 BLAKE2B 1a1006faa6066cbb05f99758154d1df0c1f6470c182370a8fa16b640fc75a7905dc776ac4addadf7b11fe9fbdacc7ecf4b82dbb6a98d7664ca904bf198a83d30 SHA512 da2e4e9c1d33e16ef2571305b462439663644e6893524a8a3ef1b51c273fb0c68ae8bc24fb55aff7b0d90cdbd0350d05b12ab2c3a1ffec30b47c0f7b63baee9c
+EBUILD hw-probe-1.6.6.ebuild 2317 BLAKE2B ef141c8e103d4cbf63e9f70a04da2b74214a0e564ce97a12d06da2a6c3d7c45d9a6511162bfa36c05946a36e3508aa53842c7e8896af6f0526af437a3e450e72 SHA512 f8e2a71f1f8ccd39f4bc24fc3ee99f2cb2c0072016ea321b7278e12661c744594883213726692e988e913cdc43a39693c823a16af4bd314f189d80a084a93ffe
MISC metadata.xml 647 BLAKE2B 522741fd8d5f7b64d686ce02dd5ccd7d9ba42df1e50a3e51921fa17c110c6db114ee22d5a903c8bb61a2a5f3884fad5e8b1a929a062af111fd52faf047638ab1 SHA512 ef6e4af1150d72b3cc26ba56267dae006ae8a19a8df2606a9f02df0dc6b091f0bd3dd9caee2171e896dd7b5e582b853f228e899dbd9281dd07b435a1da1f6b7b
diff --git a/sys-apps/hw-probe/hw-probe-1.6.6.ebuild b/sys-apps/hw-probe/hw-probe-1.6.6.ebuild
new file mode 100644
index 000000000000..bac9c9c73202
--- /dev/null
+++ b/sys-apps/hw-probe/hw-probe-1.6.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature readme.gentoo-r1
+
+DESCRIPTION="A tool to probe for hardware, check it's operability and find drivers"
+HOMEPAGE="https://github.com/linuxhw/hw-probe/"
+SRC_URI="https://github.com/linuxhw/hw-probe/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Digest-SHA1
+ net-misc/curl
+ sys-apps/dmidecode
+ sys-apps/edid-decode
+ sys-apps/hwinfo
+ sys-apps/pciutils
+ sys-apps/smartmontools
+ sys-apps/usbutils
+ virtual/perl-Data-Dumper
+"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "showing Machine Check Exceptions." app-admin/mcelog
+ optfeature "showing additional I/O statistics." app-admin/sysstat
+ optfeature "showing display data channel (ddc) information." app-misc/ddcutil
+ optfeature "showing smart card (reader) information." dev-libs/opensc
+ optfeature "showing Vulkan GPU hardware information." dev-util/vulkan-tools
+ optfeature "showing information of attached scanners." media-gfx/sane-backends
+ optfeature "showing GPU information provided by MESA." media-libs/mesa
+ optfeature "showing zeroconf statistics." net-dns/avahi
+ optfeature "showing HP printer statistics." net-print/hplip
+ optfeature "showing status about rfkill switches on communication devices." net-wireless/rfkill
+ optfeature "showing additional CPU capabilities." sys-apps/cpuid
+ optfeature "showing hard disk (HDD, SSD, ..) capabilities." sys-apps/hdparm
+ optfeature "showing available I2C sensors." sys-apps/i2c-tools
+ optfeature "showing additional hardware and system information detected by inxi." sys-apps/inxi
+ optfeature "showing information about tested memory for faults." sys-apps/memtester
+ optfeature "showing 'Plug & Play' devices." sys-apps/pnputils
+ optfeature "showing systemd boot process information." sys-apps/systemd
+ optfeature "showing ACPI statistics and tables." sys-power/iasl
+ optfeature "showing information about NUMA." sys-process/numactl
+ optfeature "showing additional GPU information provided by MESA progs." x11-apps/mesa-progs
+ optfeature "showing available Xinput devices." x11-apps/xinput
+}