summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-01 02:21:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-01 02:21:02 +0000
commitd682a95de35077b0728025627e082b67339fa249 (patch)
tree39d9937c5811d188bcc3ca56fd3305a42f94fde6 /sys-apps
parentc4b414ba84991b36b62c066b701385eaf44cdd49 (diff)
gentoo auto-resync : 01:01:2023 - 02:21:02
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/Manifest.gzbin48745 -> 48733 bytes
-rw-r--r--sys-apps/pcsc-tools/Manifest2
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.6.1.ebuild64
3 files changed, 66 insertions, 0 deletions
diff --git a/sys-apps/Manifest.gz b/sys-apps/Manifest.gz
index 27e5dba565db..ee4936ffe79a 100644
--- a/sys-apps/Manifest.gz
+++ b/sys-apps/Manifest.gz
Binary files differ
diff --git a/sys-apps/pcsc-tools/Manifest b/sys-apps/pcsc-tools/Manifest
index d752bf0bf887..0eaece451cef 100644
--- a/sys-apps/pcsc-tools/Manifest
+++ b/sys-apps/pcsc-tools/Manifest
@@ -1,4 +1,6 @@
AUX smartcard.cron 319 BLAKE2B fac8c4360b802de32ff5b0fc5c2ef41aacc28186001ee6f4f3a1cd878ed75cae3f7f78aaad58580d11a695b3fd624fdd412669c743b951818de1aef6d9d4cdf0 SHA512 cb34e75090ff0fde349b81867383ed776b4c89672039f42426e27d2fce77ba0575827d2627b82fc9c435d6091b26e7c2a0e51dbcd1bdd1c883b8c37000ed516e
DIST pcsc-tools-1.6.0.tar.bz2 304960 BLAKE2B a60d280d39689d7eaa407aa5857c63af0acda3791e5d9f5c2f62048260178dc728fb179aed3c369340e192ba9b3d5db04bacbe5cc6ef1519c7cde55e10ca6b45 SHA512 951014510dcfd011fc08c92a927ed8a39751c15cd9278e9bd61693a2743a82d4b88907e01e013738f6b5afb569cb4d9e9802ee575c731b83da33e92f96eb5d50
+DIST pcsc-tools-1.6.1.tar.bz2 313105 BLAKE2B 62169f4bab81cfe137098b863ae572df283498f7fcb6b6ecaef9122ccc530d6201805b13903826887c70363443d02e43d0d0fb88e15d5f634fc0e1e775c3ecaf SHA512 fc1a6bdea55ee1194d08998f229870b7fb65f53b3b5ddb209540980d95dab8dfb62d4bc865716d0120bb843d5095b0ad9286c42ad352e52c1cfe48ef28b5adaf
EBUILD pcsc-tools-1.6.0.ebuild 1390 BLAKE2B 7faab3fc2f66bcff8f46fa4a892eac268bd3dfc9acd1e5c655bd2fd242b025dde9d0af58d4798f756515279377da1a59db7ca975fb2b6d3639249bae5188b6bd SHA512 1381dae367689c8bafa9867b1eea875ad8e623a12ac4aa0bb1950d7a9cb2d118d0f92fb4988680bb1a718f07af50b19a05849eb6470b4551533bf86890bcde3c
+EBUILD pcsc-tools-1.6.1.ebuild 1394 BLAKE2B eccd059206be37f346d12c803c8fdc0eebf4e2ae58b260fc54ce56aff5f4e00878066c49ea4a311d69ba77084dc1b62887eef33b2eef9e6723b1f4a29ff8f7a9 SHA512 28b451001c5342a027c4363f1f79a7ba94910428e3413a2e55bb8a21785501480757deb6845b64739f3d38bdcff5027b4e69384b74ea7ebb11df876c81ca1af1
MISC metadata.xml 448 BLAKE2B f642f8f9a269fe6e3b082d4c17e2ab2c8aeb67ddcfd7a5bdaf66a95aedd6ffcfe0bcc936ad2c5e24904dd15814d61e609afc055ca5b6613cc854bc802cddb239 SHA512 feb5f0c59a283bd5f42b48cbd7fd148cd0716566438dd76c254732a9fea6e886c5e1d5416dff3c419a5fb77a03e240b3c399b0d7d81ee41ee09c02b590205d86
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.6.1.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.6.1.ebuild
new file mode 100644
index 000000000000..5d0778848964
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.6.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs xdg-utils
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/ https://github.com/LudovicRousseau/pcsc-tools"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gui network-cron"
+
+DEPEND=">=sys-apps/pcsc-lite-1.4.14"
+RDEPEND="
+ ${DEPEND}
+ dev-perl/pcsc-perl
+ gui? ( dev-perl/Gtk3 )
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=(
+ README Changelog
+)
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC="$(tc-getCC)"
+}
+
+src_install() {
+ einstalldocs
+
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ if use gui; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gui && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}