summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-15 23:49:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-15 23:49:15 +0100
commitfddb33ccaadabe03f5571606f796b45965b38e9c (patch)
treedba6d179254abac3ee319d7bde5191bebf09a5c3 /sys-apps
parent6fc112778f70ed827633ff345036db5b592ca1d0 (diff)
gentoo auto-resync : 15:04:2023 - 23:49:14
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/Manifest.gzbin49140 -> 49315 bytes
-rw-r--r--sys-apps/system-monitoring-center/Manifest3
-rw-r--r--sys-apps/system-monitoring-center/metadata.xml26
-rw-r--r--sys-apps/system-monitoring-center/system-monitoring-center-2.10.0.ebuild35
4 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/Manifest.gz b/sys-apps/Manifest.gz
index e17b48c08f93..cbe671da98fd 100644
--- a/sys-apps/Manifest.gz
+++ b/sys-apps/Manifest.gz
Binary files differ
diff --git a/sys-apps/system-monitoring-center/Manifest b/sys-apps/system-monitoring-center/Manifest
new file mode 100644
index 000000000000..649855a8b6cd
--- /dev/null
+++ b/sys-apps/system-monitoring-center/Manifest
@@ -0,0 +1,3 @@
+DIST system-monitoring-center-2.10.0.tar.gz 536051 BLAKE2B 198771c8ee79359644f2760954629026ce8edb4d451c83f8a2ca179f1ef59883ccb1dc9764388e6e778f5af9e5a96997ec70553be9bfefcbed60bce8a6e936b3 SHA512 ac46956b1e8cb1a21444f047c93ead522a1f99b2b2e63f342ac79e57c377cf3e7474e70d60410f7b657c9284f78ee00f3830fdd873e5ff9d2d500343077628c9
+EBUILD system-monitoring-center-2.10.0.ebuild 842 BLAKE2B 01fbc8f13aed75b7a0493bcf1443352a2851b1fde6b87a65a7304d24616b513ba2d16283782178b48ce9eac50156532110cb7b91083e9432b7f29eadca97f8f3 SHA512 7634a6efccfc5a676b7132274152881e2ab3e073b594780c5529d0da6dd273800627fc702dd466d7ec4223d3a2aaa890159f12ddb4c80f2bd027845782ef997a
+MISC metadata.xml 1342 BLAKE2B 2c160c0ee614f2badb06264876c618b6d652adfa42fa7eab484fb1ff367e7c8e849d25e7f6969e06623c4b58b2b062159600a0c8d5a778d1d238692816a1fa74 SHA512 8f8a6149401e3b32e967cc1f5c77a65cb607957d9375cc8d69741e95e627337bc4d8c59b4afd22ea6ff2e03e3ec31b519d7cf8aab6061d89d3d8b9bc2a2ecead
diff --git a/sys-apps/system-monitoring-center/metadata.xml b/sys-apps/system-monitoring-center/metadata.xml
new file mode 100644
index 000000000000..eb7f5c97f740
--- /dev/null
+++ b/sys-apps/system-monitoring-center/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Features: detailed system performance and usage usage monitoring/managing
+ features: monitoring CPU, RAM, Disk, Network, GPU hardware/usage
+ information, monitoring and managing processes and services (systemd),
+ monitoring users, sensors and general system information, supports
+ PolicyKit. No need to run the application with "sudo", hardware selection
+ options (selecting CPU cores, disks, network cards, GPUs), plotting
+ performance data of multiple devices at the same time, interactive charts
+ for querying performance data on any point, option for showing processes as
+ tree or list, optimized for low CPU usage and fast start, supports ARM
+ architecture, free and open source.
+ </longdescription>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/hakandundar34coding/system-monitoring-center/master/Changes.md</changelog>
+ <bugs-to>https://gitlab.com/hakandundar34coding/system-monitoring-center/-/issues/</bugs-to>
+ <remote-id type="github">hakandundar34coding/system-monitoring-center</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/system-monitoring-center/system-monitoring-center-2.10.0.ebuild b/sys-apps/system-monitoring-center/system-monitoring-center-2.10.0.ebuild
new file mode 100644
index 000000000000..6c32b80e8b88
--- /dev/null
+++ b/sys-apps/system-monitoring-center/system-monitoring-center-2.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit meson python-single-r1 xdg
+
+DESCRIPTION="Multi-featured system monitor GUI written in Python"
+HOMEPAGE="https://github.com/hakandundar34coding/system-monitoring-center/"
+SRC_URI="https://github.com/hakandundar34coding/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ sys-apps/dmidecode
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize "${ED}"/usr/share/${PN}
+
+ mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
+}