summaryrefslogtreecommitdiff
path: root/sys-auth/pam_p11
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sys-auth/pam_p11
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sys-auth/pam_p11')
-rw-r--r--sys-auth/pam_p11/Manifest2
-rw-r--r--sys-auth/pam_p11/pam_p11-0.3.1.ebuild7
2 files changed, 6 insertions, 3 deletions
diff --git a/sys-auth/pam_p11/Manifest b/sys-auth/pam_p11/Manifest
index 264ae86b1376..2cc6fbd7ad72 100644
--- a/sys-auth/pam_p11/Manifest
+++ b/sys-auth/pam_p11/Manifest
@@ -1,3 +1,3 @@
DIST pam_p11-0.3.1.tar.gz 422940 BLAKE2B b4c6d60a7ee31d808b9e928339f6e8aba3b56655b9f408ff7cd15ff4a397c89c00d00b0bbe70fc0b7bd6c6a246acd9c313c8f5b21a88e1474355c3407ff694f0 SHA512 caaa6882d4c007dfaba5974dc420bc45aa225f705679d170fdc9576aa49cbd24bba6985f14eb2bca97d4fe37aaf6088641add912dfbb93740b7d634f448addcf
-EBUILD pam_p11-0.3.1.ebuild 660 BLAKE2B eaee2435040036cb3bf8d833a85212f634e5ef2bddfbd2ad8a738ffd54c87350deb3d7c24dfb13edb452f5bd42d40789b97333985a59d216522e36f6c0222626 SHA512 9bb933072b9f80d52069cbcc5eae8cf5188cdee5f0bb45a7f203c2d98b1cce72e497db37172c8a9fbd3d199f600e6566391eb898a15b1f572a4e6112e23c5137
+EBUILD pam_p11-0.3.1.ebuild 778 BLAKE2B 6f87bcd1fd02e56258f06a51094dfd54db373c3f31e922c178de53fafef46c0ef789abb37d06e9b0bb0d5ed395cc2774e7fe2ddba285f2cb77b26a8171001d0a SHA512 e313c484855355d57c4665b69a38d6d0eb171861df8695578c61b13dd7ac2cb27dc0ec8120d7594c361929109672e6534625c06f90bf8bc3d8d1b7138eea6193
MISC metadata.xml 382 BLAKE2B 4c06443bd299d4d7971a10ae42872e5ad27e7ba203b4db1fe273db8de7d76f000342fde9776740fea7c98b8e3f8835ce4769d3889d696afd7a3c977061235f60 SHA512 de0b69fee7884757d5cd6801810abad965dcbff023e2e64345d9fe275495f3cd93b0cdb09d2a6fe5817e8816a304473cbde28f3ca73bf03ae9a562d2fc1f79f9
diff --git a/sys-auth/pam_p11/pam_p11-0.3.1.ebuild b/sys-auth/pam_p11/pam_p11-0.3.1.ebuild
index b812b0b6f4e0..0322e3038be0 100644
--- a/sys-auth/pam_p11/pam_p11-0.3.1.ebuild
+++ b/sys-auth/pam_p11/pam_p11-0.3.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools pam
+inherit flag-o-matic pam
DESCRIPTION="PAM module for authenticating against PKCS#11 tokens"
HOMEPAGE="https://github.com/opensc/pam_p11/wiki"
@@ -21,6 +21,9 @@ DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
src_configure() {
+ # Ugly way to work around deprecated declarations in openssl-3
+ append-cflags -Wno-error=deprecated-declarations
+
econf --with-pamdir="$(getpam_mod_dir)"
}