summaryrefslogtreecommitdiff
path: root/sys-auth/ykclient/ykclient-2.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sys-auth/ykclient/ykclient-2.15.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sys-auth/ykclient/ykclient-2.15.ebuild')
-rw-r--r--sys-auth/ykclient/ykclient-2.15.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/sys-auth/ykclient/ykclient-2.15.ebuild b/sys-auth/ykclient/ykclient-2.15.ebuild
index cec75e52208d..e119df25b795 100644
--- a/sys-auth/ykclient/ykclient-2.15.ebuild
+++ b/sys-auth/ykclient/ykclient-2.15.ebuild
@@ -1,19 +1,26 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Yubico C client library"
SRC_URI="http://opensource.yubico.com/yubico-c-client/releases/${P}.tar.gz"
HOMEPAGE="https://github.com/Yubico/yubico-c-client"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
LICENSE="BSD-2"
-IUSE="static-libs"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Tests require an active network connection, we don't want to run them
+RESTRICT="test"
-RDEPEND=">=net-misc/curl-7.21.1"
+RDEPEND="net-misc/curl"
DEPEND="${RDEPEND}"
-# Tests require an active network connection, we don't want to run them
-RESTRICT="test"
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}