summaryrefslogtreecommitdiff
path: root/sys-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
commit434d713861b70f6c6563d6ee50a8e64f14c970d9 (patch)
treeb72c523c72e764420f835ba9d63d43ffef687dcf /sys-auth
parentf78108598211053d41752a83e0345441bb9014ae (diff)
gentoo resync : 15.02.2018
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/Manifest.gzbin10887 -> 10881 bytes
-rw-r--r--sys-auth/google-authenticator/Manifest2
-rw-r--r--sys-auth/google-authenticator/google-authenticator-1.05.ebuild52
-rw-r--r--sys-auth/nss-mdns/Manifest4
-rw-r--r--sys-auth/nss-mdns/nss-mdns-0.13.ebuild52
-rw-r--r--sys-auth/nss-mdns/nss-mdns-9999.ebuild5
-rw-r--r--sys-auth/polkit-pkla-compat/Manifest2
-rw-r--r--sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1.ebuild6
8 files changed, 116 insertions, 7 deletions
diff --git a/sys-auth/Manifest.gz b/sys-auth/Manifest.gz
index a06bf617ed93..8d96bb9c541e 100644
--- a/sys-auth/Manifest.gz
+++ b/sys-auth/Manifest.gz
Binary files differ
diff --git a/sys-auth/google-authenticator/Manifest b/sys-auth/google-authenticator/Manifest
index 7ffe5e91fdab..df4356c8ad5e 100644
--- a/sys-auth/google-authenticator/Manifest
+++ b/sys-auth/google-authenticator/Manifest
@@ -1,4 +1,6 @@
DIST google-authenticator-1.04.tar.gz 54019 BLAKE2B 06afb1be1ceabb68bb7ba94921af415fe1dfd68b3b1ed75b58b3c5a58901ec482ae11063f487db0a7032868e833644022335ad9844f54734c2ad78c514f255a8 SHA512 e4b8ad74301312e17edd0a7f25257086fd805c8d5215b06b71d96e9a64a71b2c87d0c5a532d9eca21d6d67e30c02c2c2c77dbd338a2f49af25c32dcd355ee98e
+DIST google-authenticator-1.05.tar.gz 57778 BLAKE2B c31d7929e2aacffc159ee5384f6f31498585819b848f4f8b026519cf2f2fc566b8533e007844c64d348f1cf423a7175b3221f879c5c1ead360c4f1b3acea57ed SHA512 d97b26c6181dbce0612628484db37b1bf61e984fb2fb3d4974d04038e564404aa17415368dba524f0d17d96ec8d57ae4129b27f0c672d849d16ef03941d87996
EBUILD google-authenticator-1.04-r1.ebuild 1256 BLAKE2B 6719a49bc90468a752125b7a9c123d4691210602635925e12756b28fccdef35d0633dc7479230613b0c1e1300079d9e7b7a41e615fdbc6dcb7a30954c843fe6e SHA512 4d05c0f31011bf8899554bf6de92d2d621c3528d73072d8904387c2ab3662506a5d39b5ae812bdd5b30103e512707d382ff58044d0b72d0776eaa74f74cf9e88
+EBUILD google-authenticator-1.05.ebuild 1262 BLAKE2B 3b27489b8d18d5805611098bbfaf343db4c80a392617b3b902b9a63141fe731e3802378d4817fe8b7aedb522a5b3ada5617cc825d71f169063b77f7942255586 SHA512 c76193bd06000d3eb5b207eec16942eebc5bb096ce5be5fdd72dd5b78fef9e2b07beafd390d94a95933acd504ab49cb177625291ad3ffecaf3702eb3f7a5eb4f
EBUILD google-authenticator-9999.ebuild 1256 BLAKE2B 6719a49bc90468a752125b7a9c123d4691210602635925e12756b28fccdef35d0633dc7479230613b0c1e1300079d9e7b7a41e615fdbc6dcb7a30954c843fe6e SHA512 4d05c0f31011bf8899554bf6de92d2d621c3528d73072d8904387c2ab3662506a5d39b5ae812bdd5b30103e512707d382ff58044d0b72d0776eaa74f74cf9e88
MISC metadata.xml 262 BLAKE2B 9190d29ce12a5f82e0fc23c1cfb1bbd8642fe74392e1cbfcbac723b93255048ab06bcafc1b94ff52afe63be6dc1856f27b21022aab5357ae1f5b0204fd5df169 SHA512 fe36d12281e055298607afc0209c8bc1d3a3b9d61464b6f0d69b98b2d38b9c25bf6c979392be9427fd1ad4621b49b8e6c4b41a53ef28d4696150d1ee4525d8c3
diff --git a/sys-auth/google-authenticator/google-authenticator-1.05.ebuild b/sys-auth/google-authenticator/google-authenticator-1.05.ebuild
new file mode 100644
index 000000000000..cac4a833a725
--- /dev/null
+++ b/sys-auth/google-authenticator/google-authenticator-1.05.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/google/google-authenticator-libpam.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/google/google-authenticator-libpam/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S="${WORKDIR}/google-authenticator-libpam-${PV}"
+fi
+
+DESCRIPTION="PAM Module for two step verification via mobile platform"
+HOMEPAGE="https://github.com/google/google-authenticator-libpam"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/pam"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # We might want to use getpam_mod_dir from pam eclass,
+ # but the build already appends "/security" for us.
+ econf --libdir="/$(get_libdir)"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "For further information see"
+ elog "https://wiki.gentoo.org/wiki/Google_Authenticator"
+ elog ""
+ elog "If you want support for QR-Codes, install media-gfx/qrencode."
+ fi
+}
diff --git a/sys-auth/nss-mdns/Manifest b/sys-auth/nss-mdns/Manifest
index 58d5c566caef..e5178c640320 100644
--- a/sys-auth/nss-mdns/Manifest
+++ b/sys-auth/nss-mdns/Manifest
@@ -3,7 +3,9 @@ AUX nss-mdns-0.10-avahi-socket.patch 394 BLAKE2B df775332dc37a4f333985688f910b7b
AUX nss-mdns-0.10-ipv6.patch 15651 BLAKE2B 4fe76fdf2f39295bf6a6084662c396520fedd7fc00e67f5703b69605f5d22b3e74edf56cb8b752665145d5acfd44134b5e17d09533bdb191272e3e0771c68b9a SHA512 8021b5dbb7e484fc29041e54d88a01346ee1dac7840b1bc13caacb4460e7b6baa99d079f34e0b28e9d665e821ccddccc83580f315454c63bf7ba1b2f6ab4c230
DIST nss-mdns-0.10.tar.gz 353130 BLAKE2B 88cc7cbc908f397bbf52f590946b3bc8bc4c71585c9a0a52648ae3dd23b3f5ca9fbd24f0fc7c34dff08d7a4c8d72fec94a51a65650bed41b07aec6c81220d517 SHA512 7c9f4150648dfab34bc6f8551e5b58b0b7065e4c1472efb8ce1b00b2bd75627e5928b2c199d9dae742abe839968a8774e39c7646f8ce855d342b4d90252efc0e
DIST nss-mdns-0.11.tar.gz 382059 BLAKE2B 5523c76d6f7364efde54b9bf303dfdf34c11b96c9348bfd4a62d095215e7d6f32e0d44e22d21677d51700d458a10f9c36f7ccecb7b4add04fcba629ee19abc21 SHA512 9dceb0f244c4cd27b04ca2014637873a0d137464c26780dfdb228502b06b310991494b115e42e1057c45478361d0e441ec73099fbf56a13a5933618b72390af4
+DIST nss-mdns-0.13.tar.gz 380261 BLAKE2B 555b7b9df8ff15da423712fac04ccbc303395d38a07121906cf31871a8684c71e43809b80674a489d87397902a33f4d19b0ae49a4c384290bad227a24880476f SHA512 f1b379111fb758323179ea3e447d754e934308940b11a8402dfb6033264940d831266d15ae1ee0badfecd5cdc7f589b42e4363dfc058f5e62026017d97eb0a3b
EBUILD nss-mdns-0.10-r3.ebuild 1840 BLAKE2B dd41dd364d82e918747bf8876953e763d8fd9886cccf9706bd67aa4a4e637f369039fc0148f33bd2db893d3c66a2a92c2dddbc767ec668af62382fde61cdc93d SHA512 50265452786edd3ac7b554904a57fdf38b9a121641363bc14587633efada2017d7b36c7f131740ce69e2a5389fc4be2d4a6b5c52bb6193dd0320891748f3ce5a
EBUILD nss-mdns-0.11.ebuild 1667 BLAKE2B 35aea7515b9117cacc47f8680886d5d60e63752515712ba654655e127f40e4fdf40fc8ac6967e85d01e8b32e6894b84358d344faf95b5eb199c9fb7dcd9b6fa7 SHA512 4b4f9c48ea0bb498061b98f3add9b06b148e524140b798f3ac0b3a60e830a084506231118cbf3cfd3f7d3795b7c43e9e3dfe036713a03f45b4d8dd694549eace
-EBUILD nss-mdns-9999.ebuild 1596 BLAKE2B 5eac3ed93c9d9d291090b767c6d8c9193e6d0d749cc4d36a7e00fa8dd3bfed6fc99b7c9f6f0ca433f39b3d0257f8d71b02e6897fa039ceec6d181c8246621c65 SHA512 bdb772d5fcb650405dff7baa52049d1cc1943489b65ba0f786c8fb6ab22ea3ab14425a259e04515879b354db918efbc14cb32dbd22d9d628d18eb2fa7a7a1c21
+EBUILD nss-mdns-0.13.ebuild 1627 BLAKE2B 13c272a84c846067c33bffd9090ee3a8be79099b9b9e475a89f14dac54d6e760e0d85f32a243a9f7329d7f54aa07db534bc370f39bbb8d821e173405fdeca66c SHA512 975119757f391b43f8293602a45ebcc32f6eb535ff8c6e0b6efc830046a4449e89b973dda187451dfd948c0db21c4fcd4d9ec7647bae59ee58e84331cc61a242
+EBUILD nss-mdns-9999.ebuild 1633 BLAKE2B de0554c2f1c3ad64a4e258dbc1b07511caca5e706e03391ba5841fc8931a51b97ca1d85d55a38811198d28ebbf131ffce3a05f76b6b1fb64bbb1fc0a32277432 SHA512 b5363a99b05a31f1c5679f3f0b8200d3763f05f81795da3eb51b451f33edae95564ac45001e59e9afb2a311f4b13d856aafe67ea3b7213e172169854b3733ca8
MISC metadata.xml 795 BLAKE2B 9237e6e6cc772633d1e45db608880c8bf112a361a2914ccc8f413020d31905d10e5822c922659bd500072f47580c63c94a68f54171a259ae3dc28b0b17499387 SHA512 912e8a154a0672a58bd89ee1f52efd8d43cfbeff1f1c40def47d6bd7600fb9b74e1b11dd633ea1ad6f75ef9ae9979ac5b741cfd5df97ea6b0055b060df33c977
diff --git a/sys-auth/nss-mdns/nss-mdns-0.13.ebuild b/sys-auth/nss-mdns/nss-mdns-0.13.ebuild
new file mode 100644
index 000000000000..fea085203e9a
--- /dev/null
+++ b/sys-auth/nss-mdns/nss-mdns-0.13.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit multilib-minimal
+
+DESCRIPTION="Name Service Switch module for Multicast DNS"
+HOMEPAGE="https://github.com/lathiat/nss-mdns"
+SRC_URI="https://github.com/lathiat/nss-mdns/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=">=net-dns/avahi-0.6.31-r2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/check-0.11 )"
+
+multilib_src_configure() {
+ local myconf=(
+ # $(localstatedir)/run/... is used to locate avahi-daemon socket
+ --localstatedir=/var
+ )
+
+ ECONF_SOURCE=${S} \
+ econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ dodoc *.md
+
+ insinto /etc
+ doins "${FILESDIR}"/mdns.allow
+}
+
+pkg_postinst() {
+ ewarn "You have to modify your name service switch look up file to enable"
+ ewarn "multicast DNS lookups. If you wish to resolve only IPv6 addresses"
+ ewarn "use mdns6. For IPv4 addresses only, use mdns4. To resolve both"
+ ewarn "use mdns. Keep in mind that mdns will be slower if there are no"
+ ewarn "IPv6 addresses published via mDNS on the network. There are also"
+ ewarn "minimal (mdns?_minimal) libraries which only lookup .local hosts"
+ ewarn "and 169.254.x.x addresses."
+ ewarn
+ ewarn "Add the appropriate mdns into the hosts line in /etc/nsswitch.conf."
+ ewarn "An example line looks like:"
+ ewarn "hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4"
+ ewarn
+ ewarn "If you want to perform mDNS lookups for domains other than the ones"
+ ewarn "ending in .local, add them to /etc/mdns.allow."
+}
diff --git a/sys-auth/nss-mdns/nss-mdns-9999.ebuild b/sys-auth/nss-mdns/nss-mdns-9999.ebuild
index 22527697c7c8..4734cc555a17 100644
--- a/sys-auth/nss-mdns/nss-mdns-9999.ebuild
+++ b/sys-auth/nss-mdns/nss-mdns-9999.ebuild
@@ -13,10 +13,11 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="test"
RDEPEND=">=net-dns/avahi-0.6.31-r2[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/check-0.11 )"
src_prepare() {
default
diff --git a/sys-auth/polkit-pkla-compat/Manifest b/sys-auth/polkit-pkla-compat/Manifest
index fd5463e4d2d2..6f1756aecbd4 100644
--- a/sys-auth/polkit-pkla-compat/Manifest
+++ b/sys-auth/polkit-pkla-compat/Manifest
@@ -1,3 +1,3 @@
DIST polkit-pkla-compat-0.1.tar.xz 291148 BLAKE2B b993a17dc9f16e622f59ed5e716f36857a3196567a426f81fac75f1a0a774c9d6e608d36433e2b39a4d50dbd1699b5b686835fde7cbae6260c5a226c90ebe7b3 SHA512 968cf547db977731a6c6bb292fa86ef46a2ce8f74d008da62f219c20da8cdde94f6309dccba3be33d0111bfa34609799bdeee4d2464395c8837370d022d425c5
-EBUILD polkit-pkla-compat-0.1.ebuild 732 BLAKE2B bdd6c0d1129e5f8c80cfcb733701edce5e05bd20eb739e4980406a842f767299d371932612540d77233bd36605b6c85448e6a3f90e0ff55d725dc1685b8bbe0b SHA512 cdce406f34aaa262791686e945ba0ad43d7e6c8108bcefd09e18920eb8bad4baf6e9f79ef1a5619b2f31b467440d33d4fc7e8e762a962d4a4859205effdeff29
+EBUILD polkit-pkla-compat-0.1.ebuild 700 BLAKE2B 49f2b799e1ba3b87dedc849a5ff579324f03d86a9ec7c26c811cf7a99c72104ac43d60de8e789882818c8838daa2b13ed71ffb921132598440d5b08d68add162 SHA512 c3cea2ad1ae42bffd62fbce4c55c4b11396afabb1ad7bac52a22d3e01a64c1ae22698eaa5827df90cd5c91435db8d09d4e9bfb0805e1c535d46b3c0f7ce29403
MISC metadata.xml 228 BLAKE2B 6b6559027915d8578c02e363cc855e812c338acf7716fe4108a8b85c09152a086cb578e7361f4613a44e8b550d7e205ff43aea39dd9488951fa18c6e15042278 SHA512 4f5e63f918a0f8790db49c5b12173c673f86935f00796a04acfed573f618379b73b05b1869941e11f881fe69d4958f5287ce815fd710eadb6ac9f2680894caae
diff --git a/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1.ebuild b/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1.ebuild
index 20fb5c74f07c..ff1865e975e8 100644
--- a/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1.ebuild
+++ b/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
DESCRIPTION="Rules for polkit to add compatibility with pklocalauthority"
-HOMEPAGE="http://fedorahosted.org/polkit-pkla-compat/"
-SRC_URI="http://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.xz"
+HOMEPAGE="https://pagure.io/polkit-pkla-compat"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.xz"
LICENSE="LGPL-2"
SLOT="0"