summaryrefslogtreecommitdiff
path: root/sys-block/di/di-4.43.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-block/di/di-4.43.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-block/di/di-4.43.ebuild')
-rw-r--r--sys-block/di/di-4.43.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-block/di/di-4.43.ebuild b/sys-block/di/di-4.43.ebuild
new file mode 100644
index 000000000000..7cccda50f360
--- /dev/null
+++ b/sys-block/di/di-4.43.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Disk Information Utility"
+HOMEPAGE="http://www.gentoo.com/di/"
+SRC_URI="http://www.gentoo.com/di/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+RESTRICT="test" #405205, #405471
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.33-build.patch
+}
+
+src_configure() {
+ emake checkbuild
+ emake -C C config.h
+}
+
+src_compile() {
+ emake prefix=/usr CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake install prefix="${D}/usr"
+ # default symlink is broken
+ dosym di /usr/bin/mi
+ dodoc README
+}