summaryrefslogtreecommitdiff
path: root/sys-block/f3/f3-8.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-15 04:39:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-15 04:39:16 +0100
commit80765b090d10ae3f68b00e3befe5859f7212e536 (patch)
treed624666bb07bce025925d07a966e0fa276bc00c4 /sys-block/f3/f3-8.0-r1.ebuild
parent9f1c285c267548022db687a4fe85501b006d68b7 (diff)
gentoo auto-resync : 15:07:2023 - 04:39:16
Diffstat (limited to 'sys-block/f3/f3-8.0-r1.ebuild')
-rw-r--r--sys-block/f3/f3-8.0-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-block/f3/f3-8.0-r1.ebuild b/sys-block/f3/f3-8.0-r1.ebuild
new file mode 100644
index 000000000000..69e189a0304e
--- /dev/null
+++ b/sys-block/f3/f3-8.0-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Utilities to detect broken or counterfeit flash storage"
+HOMEPAGE="https://github.com/AltraMayor/f3"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/AltraMayor/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/AltraMayor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="extra"
+
+RDEPEND="elibc_musl? ( sys-libs/argp-standalone )"
+DEPEND="${RDEPEND}
+ extra? (
+ sys-block/parted
+ virtual/udev
+ )"
+
+DOCS=( changelog README.rst )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:-ggdb::' \
+ -e 's:^PREFIX =:PREFIX ?=:' \
+ Makefile || die
+
+ # bug #715518
+ use elibc_musl && append-ldflags -largp
+
+ tc-export CC
+}
+
+src_compile() {
+ default
+
+ if use extra; then
+ emake V=1 extra
+ fi
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+
+ if use extra; then
+ emake PREFIX="${ED}/usr" install-extra
+ fi
+
+ einstalldocs
+}