summaryrefslogtreecommitdiff
path: root/sys-block/gpart/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-block/gpart/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-block/gpart/files')
-rw-r--r--sys-block/gpart/files/gpart-0.1h-errno.patch20
-rw-r--r--sys-block/gpart/files/gpart-0.1h-l64seek.patch71
-rw-r--r--sys-block/gpart/files/gpart-0.1h-ntfs.patch75
-rw-r--r--sys-block/gpart/files/gpart-0.1h-openmode.patch11
-rw-r--r--sys-block/gpart/files/gpart-0.1h-vfat.patch17
-rw-r--r--sys-block/gpart/files/gpart-0.3-build.patch10
6 files changed, 204 insertions, 0 deletions
diff --git a/sys-block/gpart/files/gpart-0.1h-errno.patch b/sys-block/gpart/files/gpart-0.1h-errno.patch
new file mode 100644
index 000000000000..13041c20245d
--- /dev/null
+++ b/sys-block/gpart/files/gpart-0.1h-errno.patch
@@ -0,0 +1,20 @@
+--- gpart-0.1h/src/l64seek.c
++++ gpart-0.1h-working/src/l64seek.c
+@@ -16,6 +16,7 @@
+
+ #include "l64seek.h"
+
++#include <errno.h>
+
+ #define OSTACKLEN 16
+ static struct
+--- gpart-0.1h/src/disku.c
++++ gpart-0.1h-working/src/disku.c
+@@ -20,6 +20,7 @@
+ #include <string.h>
+ #include <sys/ioctl.h>
+ #include "gpart.h"
++#include <errno.h>
+
+ #if defined(__linux__)
+ #include <sys/mount.h>
diff --git a/sys-block/gpart/files/gpart-0.1h-l64seek.patch b/sys-block/gpart/files/gpart-0.1h-l64seek.patch
new file mode 100644
index 000000000000..8a14411a5ccc
--- /dev/null
+++ b/sys-block/gpart/files/gpart-0.1h-l64seek.patch
@@ -0,0 +1,71 @@
+--- gpart-0.1h.orig/src/l64seek.c
++++ gpart-0.1h/src/l64seek.c
+@@ -25,30 +25,11 @@
+ } ostck[OSTACKLEN];
+ static int osptr = -1;
+
+-#if defined(__linux__) && defined(__i386__)
+-_syscall5(int,_llseek,uint,fd,ulong,hi,ulong,lo,loff_t *,res,uint,wh)
+-#endif
+-
+-
+-
+ off64_t l64seek(int fd,off64_t offset,int whence)
+ {
+ off64_t ret = (off64_t)-1;
+
+-#if defined(__linux__) && defined(__i386__)
+- int iret;
+- unsigned long ohi, olo;
+-
+- ohi = (unsigned long)((offset >> 32) & 0xFFFFFFFF);
+- olo = (unsigned long)(offset & 0xFFFFFFFF);
+- iret = _llseek(fd,ohi,olo,&ret,whence);
+- if (iret == -1)
+- ret = (off64_t)-1;
+-#endif
+-
+-#if defined(__FreeBSD__) || (defined(__linux__) && defined(__alpha__))
+ ret = lseek(fd,offset,whence);
+-#endif
+
+ return (ret);
+ }
+--- gpart-0.1h.orig/src/l64seek.h
++++ gpart-0.1h/src/l64seek.h
+@@ -17,6 +17,8 @@
+ #ifndef _L64SEEK_H
+ #define _L64SEEK_H
+
++#include <sys/stat.h>
++#include <sys/types.h>
+ #include <unistd.h>
+
+ /*
+@@ -25,19 +27,7 @@
+ * offsets.
+ */
+
+-
+-#if defined(__linux__)
+-# include <linux/unistd.h>
+-# include <sys/types.h>
+- typedef int64_t off64_t;
+-#endif
+-
+-
+-#if defined(__FreeBSD__)
+- typedef off_t off64_t;
+-#endif
+-
+-
++typedef loff_t off64_t;
+ typedef off64_t s64_t;
+
+ off64_t l64seek(int fd, off64_t offset, int whence);
+@@ -45,5 +35,4 @@
+ int l64opush(int);
+ s64_t l64opop(int);
+
+-
+ #endif
diff --git a/sys-block/gpart/files/gpart-0.1h-ntfs.patch b/sys-block/gpart/files/gpart-0.1h-ntfs.patch
new file mode 100644
index 000000000000..1f887ac47135
--- /dev/null
+++ b/sys-block/gpart/files/gpart-0.1h-ntfs.patch
@@ -0,0 +1,75 @@
+Ripped out of debian
+
+--- gpart-0.1h.orig/src/gm_ntfs.h
++++ gpart-0.1h/src/gm_ntfs.h
+@@ -14,6 +14,9 @@
+ *
+ */
+
++#include <stdint.h>
++#include <asm/byteorder.h>
++
+ #ifndef _GM_NTFS_H
+ #define _GM_NTFS_H
+
+@@ -29,32 +32,38 @@
+ /* 'NTFS' in little endian */
+ #define NTFS_SUPER_MAGIC 0x5346544E
+
+-#if defined(i386) || defined(__i386__) || defined(__alpha__)
+-
+ /* unsigned integral types */
+ #ifndef NTFS_INTEGRAL_TYPES
+ #define NTFS_INTEGRAL_TYPES
+-typedef unsigned char ntfs_u8;
+-typedef unsigned short ntfs_u16;
+-typedef unsigned int ntfs_u32;
+-typedef s64_t ntfs_u64;
++typedef uint8_t ntfs_u8;
++typedef uint16_t ntfs_u16;
++typedef uint32_t ntfs_u32;
++typedef uint64_t ntfs_u64;
++typedef int8_t ntfs_s8;
++typedef int16_t ntfs_s16;
+ #endif /* NTFS_INTEGRAL_TYPES */
+-#endif /* defined(i386) || defined(__i386__) || defined(__alpha__) */
+-
+-
+-/* Macros reading unsigned integers from a byte pointer */
+-/* these should work for all little endian machines */
+-#define NTFS_GETU8(p) (*(ntfs_u8*)(p))
+-#define NTFS_GETU16(p) (*(ntfs_u16*)(p))
+-#define NTFS_GETU24(p) (NTFS_GETU32(p) & 0xFFFFFF)
+-#define NTFS_GETU32(p) (*(ntfs_u32*)(p))
+-#define NTFS_GETU64(p) (*(ntfs_u64*)(p))
+-
+-/* Macros reading signed integers, returning int */
+-#define NTFS_GETS8(p) ((int)(*(char*)(p)))
+-#define NTFS_GETS16(p) ((int)(*(short*)(p)))
+-#define NTFS_GETS24(p) (NTFS_GETU24(p) < 0x800000 ? (int)NTFS_GETU24(p) :
+-
+
++#define CPU_TO_LE16(a) __cpu_to_le16(a)
++#define CPU_TO_LE32(a) __cpu_to_le32(a)
++#define CPU_TO_LE64(a) __cpu_to_le64(a)
++
++#define LE16_TO_CPU(a) __cpu_to_le16(a)
++#define LE32_TO_CPU(a) __cpu_to_le32(a)
++#define LE64_TO_CPU(a) __cpu_to_le64(a)
++
++/* Macros reading unsigned integers */
++#define NTFS_GETU8(p) (*(ntfs_u8*)(p))
++#define NTFS_GETU16(p) ((ntfs_u16)LE16_TO_CPU(*(ntfs_u16*)(p)))
++#define NTFS_GETU24(p) ((ntfs_u32)NTFS_GETU16(p) | \
++ ((ntfs_u32)NTFS_GETU8(((char*)(p)) + 2) << 16))
++#define NTFS_GETU32(p) ((ntfs_u32)LE32_TO_CPU(*(ntfs_u32*)(p)))
++#define NTFS_GETU64(p) ((ntfs_u64)LE64_TO_CPU(*(ntfs_u64*)(p)))
++
++/* Macros reading signed integers */
++#define NTFS_GETS8(p) ((*(ntfs_s8*)(p)))
++#define NTFS_GETS16(p) ((ntfs_s16)LE16_TO_CPU(*(short*)(p)))
++#define NTFS_GETS24(p) (NTFS_GETU24(p) < 0x800000 ? \
++ (int)NTFS_GETU24(p) : \
++ (int)(NTFS_GETU24(p) - 0x1000000))
+
+ #endif /* _GM_NTFS_H */
diff --git a/sys-block/gpart/files/gpart-0.1h-openmode.patch b/sys-block/gpart/files/gpart-0.1h-openmode.patch
new file mode 100644
index 000000000000..ca13cc9420e6
--- /dev/null
+++ b/sys-block/gpart/files/gpart-0.1h-openmode.patch
@@ -0,0 +1,11 @@
+--- gpart.orig/src/gpart.c 2008-10-19 15:06:06.000000000 +0000
++++ gpart/src/gpart.c 2008-11-25 07:34:47.000000000 +0000
+@@ -1221,7 +1221,7 @@ static int make_mbr_backup(disk_desc *d,
+ {
+ int fd, ret = 0;
+
+- if ((fd = open(bfile,O_WRONLY|O_CREAT)) < 0)
++ if ((fd = open(bfile,O_WRONLY|O_CREAT, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH)) < 0)
+ return (ret);
+
+ if (write(fd,d->d_pt.t_boot,512) == 512)
diff --git a/sys-block/gpart/files/gpart-0.1h-vfat.patch b/sys-block/gpart/files/gpart-0.1h-vfat.patch
new file mode 100644
index 000000000000..7234ac689831
--- /dev/null
+++ b/sys-block/gpart/files/gpart-0.1h-vfat.patch
@@ -0,0 +1,17 @@
+Ripped out of debian
+
+--- gpart-0.1h.orig/src/gm_fat.h
++++ gpart-0.1h/src/gm_fat.h
+@@ -60,6 +60,10 @@
+ __u16 info_sector; /* filesystem info sector */
+ __u16 backup_boot; /* backup boot sector */
+ __u16 reserved2[6]; /* Unused */
+-};
+-
++} __attribute__ ((packed));
++/* "__attribute__ ((packed))"
++ added by davidc@debian.org,
++ as suggested by falk@zxmjz18.extern.uni-tuebingen.de
++ Fri Jul 07 18:04:15 2000
++ in debian bug report #66893 "FAT detection broken on Alpha" */
+ #endif /* _GM_FAT_H */
diff --git a/sys-block/gpart/files/gpart-0.3-build.patch b/sys-block/gpart/files/gpart-0.3-build.patch
new file mode 100644
index 000000000000..f45545d0fd80
--- /dev/null
+++ b/sys-block/gpart/files/gpart-0.3-build.patch
@@ -0,0 +1,10 @@
+--- gpart-0.3/Makefile.am
++++ gpart-0.3/Makefile.am
+@@ -1,6 +1,6 @@
+ AUTOMAKE_OPTIONS = foreign
+ SUBDIRS = src man
+
+-docdir = $(datadir)/doc/@PACKAGE@
++docdir = $(datadir)/doc/@PACKAGE@-@VERSION@
+ doc_DATA = Changes README.md
+ EXTRA_DIST = Changes README.md