summaryrefslogtreecommitdiff
path: root/sys-block/gpart/gpart-0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-block/gpart/gpart-0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-block/gpart/gpart-0.3.ebuild')
-rw-r--r--sys-block/gpart/gpart-0.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-block/gpart/gpart-0.3.ebuild b/sys-block/gpart/gpart-0.3.ebuild
new file mode 100644
index 000000000000..7b56760641f2
--- /dev/null
+++ b/sys-block/gpart/gpart-0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Partition table rescue/guessing tool"
+HOMEPAGE="https://github.com/baruch/gpart"
+SRC_URI="https://github.com/baruch/gpart/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.1h-errno.patch
+ "${FILESDIR}"/${PN}-0.3-build.patch
+)
+
+src_prepare() {
+ default
+
+ # Fix version string in build environment.
+ if [[ "$(awk -F , '/^AC_INIT/ {print $2}' configure.ac)" != ${PV} ]] ; then
+ sed "/^AC_INIT/s@, [[:digit:]\.]\+[[:alnum:]-]*,@, ${PV},@" \
+ -i configure.ac || die
+ fi
+
+ eautoreconf
+}