summaryrefslogtreecommitdiff
path: root/sys-block/noflushd/noflushd-2.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-block/noflushd/noflushd-2.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-block/noflushd/noflushd-2.8.ebuild')
-rw-r--r--sys-block/noflushd/noflushd-2.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-block/noflushd/noflushd-2.8.ebuild b/sys-block/noflushd/noflushd-2.8.ebuild
new file mode 100644
index 000000000000..c94cfcaffd46
--- /dev/null
+++ b/sys-block/noflushd/noflushd-2.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="A daemon to spin down your disks and force accesses to be cached"
+HOMEPAGE="http://noflushd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/noflushd/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_configure() {
+ econf \
+ --with-docdir=/usr/share/doc/${PF} \
+ --with-initdir=/etc/init.d
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc NEWS
+
+ newinitd "${FILESDIR}"/noflushd.rc6 noflushd
+ newconfd "${FILESDIR}"/noflushd.confd noflushd
+}
+
+pkg_postinst() {
+ ewarn "noflushd works with IDE devices only."
+ ewarn "It has possible problems with reiserfs, too."
+}