summaryrefslogtreecommitdiff
path: root/sys-block/sas2ircu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-20 12:25:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-20 12:25:59 +0100
commitc431a44e3cfa102e5ef2c9d6bbac48e28c9b15cb (patch)
tree763b8a8b758bcb259d7f7325aac3170f62061933 /sys-block/sas2ircu
parent1f3e27f8fde0df9246ce9151ced7d2dd4e96cb07 (diff)
gentoo auto-resync : 20:08:2024 - 12:25:59
Diffstat (limited to 'sys-block/sas2ircu')
-rw-r--r--sys-block/sas2ircu/Manifest1
-rw-r--r--sys-block/sas2ircu/sas2ircu-20-r2.ebuild125
2 files changed, 126 insertions, 0 deletions
diff --git a/sys-block/sas2ircu/Manifest b/sys-block/sas2ircu/Manifest
index 5489acaf7b7e..f995c2d1dfad 100644
--- a/sys-block/sas2ircu/Manifest
+++ b/sys-block/sas2ircu/Manifest
@@ -1,4 +1,5 @@
DIST SAS2IRCU_P20.zip 2777958 BLAKE2B ba8c3ef1cf353af90f32a53722b3a7039768c0f48e1d5b48766acdf1c1c05a039692e1edc2586140da5af0f1f2378f4bfaca219895317dc7974004f3aed25343 SHA512 a0a4fa7d07959aa6a81d3540e71e3cc248c23267875ca098da6a80850e008cbdf57b2d6456b5fe17ef890fd39ac550788c9769d169a0673578632f1a8c8a8311
DIST SAS2IRCU_User_Guide.pdf 794046 BLAKE2B e976f57ada3c51b58bfee24cd2f5d059f59b48bf388d93b146238d54aa09b06f6d450e3ccf149903871dfcdb32807a35d6f379738e149b410b7c1279f811153f SHA512 515869794be428ffbefcbfadac992912fb0eebab0cda640b315b4a231b5f25f1205978605f108b9009380015f3058c47e0ce4352c693ef23ab31980ea8b821a0
EBUILD sas2ircu-20-r1.ebuild 3334 BLAKE2B 851043a8e4544bf54eb4bc28d95ee4dab4d51127173664dfc4d3845aa16d15189b60135c7eb67894fe22c34bc6ac8d293589765bd66fd2ebeec8d9fd6a7dadb0 SHA512 df886d7f749708526d39dafde832cd636ab08e5f5bc13ba96961b831e0ce5b8a723d45d48f153f5ee34a2e3af5cc5c83f5887d5753194868bf539b3eca89bef8
+EBUILD sas2ircu-20-r2.ebuild 3733 BLAKE2B a94df4d53fc6e8b4b2bb1c791674bd88ae2dcaa511c9eceba91288fec92eb3ff85f3f78e576777be57adfd98a33e4a8028c9b2abd11c293a54dfd0794e293cf6 SHA512 4fe57109958d5e4519c24a3c8b0272f470c7334e77792fa61f4810ca1a319df5e9f9f67fd895ce67fc5166f47aa3201764300ac6f464fc600c8825b56a2c1376
MISC metadata.xml 322 BLAKE2B ea9fa3b358b3c5282387144c7123efbc0e87e5a06a90eafc95ccf19077e3eac241f1cd9a8cbfa0226c8f4e91f691ca50f0f457fea1af5cbf8f2bf7d42067dacc SHA512 b76f4d65f9bf12dc239775e31b594e131331b6238eb9ef2832e070cc5eb3070ce8b5cfdd94c26c58e660ab0ceb94fbcd072144c32e2d864f2243316b4f258f51
diff --git a/sys-block/sas2ircu/sas2ircu-20-r2.ebuild b/sys-block/sas2ircu/sas2ircu-20-r2.ebuild
new file mode 100644
index 000000000000..ecd241f6ef48
--- /dev/null
+++ b/sys-block/sas2ircu/sas2ircu-20-r2.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=SAS2IRCU
+MY_P="${MY_PN}_P${PV}"
+
+DISTFILE_BIN=${MY_P}.zip
+DISTFILE_DOC="SAS2IRCU_User_Guide.pdf"
+DOC_PV=12
+SRC_URI_BIN="https://docs.broadcom.com/docs/${DISTFILE_BIN}"
+# This is "SAS-2 Integrated RAID Configuration Utility (SAS2IRCU) User Guide"
+# and replaces the older SAS2_IR_User_Guide.pdf.
+# It contains additional material compared to the older PDF.
+SRC_URI_DOC="https://docs.broadcom.com/doc/12353380"
+
+inherit mount-boot secureboot linux-info
+
+DESCRIPTION="LSI MPT-SAS2 controller management tool"
+HOMEPAGE="https://www.broadcom.com/products/storage/host-bus-adapters/sas-9207-8e#tab-archive-drivers4-abc"
+SRC_URI="
+${SRC_URI_BIN}
+doc? ( ${SRC_URI_DOC} -> ${DISTFILE_DOC} )
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LSI"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ppc64 ~x86 ~x64-solaris"
+IUSE="doc uefi"
+RESTRICT="strip fetch mirror"
+
+BDEPEND="app-arch/unzip"
+QA_PREBUILT="opt/lsi/sas2ircu boot/efi/sas2ircu.efi"
+
+LICENSE_URL="http://www.lsi.com/cm/License.do?url=&prodName=&subType=Miscellaneous&locale=EN"
+
+pkg_pretend() {
+ use uefi && mount-boot_pkg_pretend
+}
+
+pkg_nofetch() {
+ elog "LSI has a mandatory click-through license on their binaries."
+ elog "Please visit ${SRC_URI_BIN} to agree to the license and download the binary."
+ elog "After downloading, move ${DISTFILE_BIN} into your DISTDIR directory"
+ if use doc; then
+ elog "Please also download 'SAS-2 Integrated RAID Configuration Utility User Guide' at ${SRC_URI_DOC}"
+ elog "and also place it into your DISTDIR directory, named ${DISTFILE_DOC}"
+ fi
+}
+
+pkg_setup() {
+ if ! use x86; then
+ # For newer kernels it needs to be enabled as well, don't know
+ # how to check for that short of running the binary.
+ local CONFIG_CHECK="CONFIG_IA32_EMULATION"
+ check_extra_config
+ fi
+}
+
+supportedcards() {
+ elog "This binary supports should support ALL cards, including, but not"
+ elog "limited to the following series:"
+ elog ""
+ elog "LSI SAS 2004"
+ elog "LSI SAS 2008"
+ elog "LSI SAS 2108"
+ elog "LSI SAS 2208"
+ elog "LSI SAS 2304"
+ elog "LSI SAS 2308"
+ elog "Dell PERC H200, H700"
+ elog "IBM System x3200 M2 (4367, 4368)"
+ elog "IBM System x3200 M3 (7327, 7328)"
+ elog "IBM System x3250 M2 (4190, 4191, 4194)"
+ elog "IBM System x3250 M3 (4251, 4252, 4261)"
+ elog "IBM System x3350 (4192, 4193)"
+ elog "IBM System x3400 (7973, 7974, 7975, 7976)"
+ elog "IBM System x3400 M2 (7836, 7837)"
+ elog "IBM System x3455 (7940, 7941)"
+ elog "IBM System x3500 (7977)"
+ elog "IBM System x3500 M2 (7839)"
+ elog "IBM System x3550 (7978, 1913)"
+ elog "IBM System x3550 M2 (7946, 4198)"
+ elog "IBM System x3650 (7979, 1914)"
+ elog "IBM System x3650 M2 (7947, 4199)"
+ elog "IBM System x3650 NAS (7979)"
+ elog "IBM System x3655 (7985, 7943)"
+ elog "IBM System x3755 (8877, 7163)"
+ elog "IBM System x3850 M2 (7141, 7144, 7233, 7234)"
+ elog "IBM System x3850 X5 (7145, 7146)"
+ elog "IBM System x3950 M2 (7141, 7233, 7234)"
+ elog "IBM System x3950 X5 (7145)"
+}
+
+src_unpack() {
+ unpack ${DISTFILE_BIN}
+}
+
+src_install() {
+ exeinto /opt/lsi/
+ use amd64 || use x86 && doexe sas2ircu_linux_x86_rel/sas2ircu
+ use ppc64 && doexe sas2ircu_linux_x86_rel/sas2ircu
+ use x64-solaris && doexe sas2ircu_solaris_x86_rel/sas2ircu
+ if use uefi; then
+ if use amd64; then
+ exeinto /boot/efi/
+ doexe sas2ircu_efi_ebc_rel/sas2ircu.efi
+ secureboot_auto_sign --in-place
+ fi
+ fi
+ dodoc Readme_Release_Notes_SAS2IRCU_Phase_${PV}.00.00.00.txt
+ dodoc SAS2IRCU_Phase${PV}.0-${PV}.00.00.00.pdf
+ use doc && dodoc "${DISTDIR}"/${DISTFILE_DOC}
+ dodir /opt/bin
+ dosym ../lsi/sas2ircu /opt/bin/sas2ircu
+}
+
+pkg_preinst() {
+ use uefi && mount-boot_pkg_preinst
+}
+
+pkg_prerm() {
+ use uefi && mount-boot_pkg_prerm
+}