summaryrefslogtreecommitdiff
path: root/sys-block/sas3ircu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-20 12:25:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-20 12:25:59 +0100
commitc431a44e3cfa102e5ef2c9d6bbac48e28c9b15cb (patch)
tree763b8a8b758bcb259d7f7325aac3170f62061933 /sys-block/sas3ircu
parent1f3e27f8fde0df9246ce9151ced7d2dd4e96cb07 (diff)
gentoo auto-resync : 20:08:2024 - 12:25:59
Diffstat (limited to 'sys-block/sas3ircu')
-rw-r--r--sys-block/sas3ircu/Manifest1
-rw-r--r--sys-block/sas3ircu/sas3ircu-16-r2.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/sys-block/sas3ircu/Manifest b/sys-block/sas3ircu/Manifest
index a298f2437eaf..45f5c592b297 100644
--- a/sys-block/sas3ircu/Manifest
+++ b/sys-block/sas3ircu/Manifest
@@ -1,4 +1,5 @@
DIST SAS3IRCU_P16.zip 6342932 BLAKE2B a5c4f9a83eb1f51a049e9f04c29c029580590500deb48ae03b0960c394946f1e89d40efc68a0d505004bda519e3174fc573111e95f028c09b1a0ae6bd18f98ed SHA512 cc44d64c500f2608895129414d95cc3d23fae5a3ae39bb28119f150b830ec20b6c934cd1d23dcd1253e9c38ca3b16a7020ae0b8386412638fd2dca6d93d92ac0
DIST SAS3_IR_UG.pdf 714573 BLAKE2B 09a3a47abf6118343f023f4cdf85ab2f5f583f806e305dafa6397d1099fc01ecc33b331afd10d63ac8bb75a365d09c931c19fc673fa707b5171feb23d64f97bf SHA512 4db16dedcadc3daf853e62531ac620af4a3e41d001b58fcd333692f9121d1ca3ec8b9de0113693506b31da714b9368ff55addb0398f2f843e4a6a1bf3d665433
EBUILD sas3ircu-16-r1.ebuild 2522 BLAKE2B dfca6870812dedc7756362c99ac2c7dc4acf85f6048c145bf6b1b6cbbccba6f924cde6bcf20d8acf13eca69022e5ca4191943825d1a34b8d75b68f24808497e4 SHA512 7a9d48ff46bd1687262e455b53df903fd8ce470c5c43e2e69170a19bc99491640394295603916cf99370941fc747a59c42f6e12e7c681f0df2112a1f0c164e48
+EBUILD sas3ircu-16-r2.ebuild 2683 BLAKE2B 7f9b95d1573097939bb00bcd03a1d28cc8194aadffe6fd1434ab90e7a679dbc51abc811c2cdc0b0050fc577aedf3e651ebfc69ea3b9d4848a17e2e4f66c309ce SHA512 985f7341e9346e1919816f98f1b5351b4ad056b3bb1e9d88b365a65b79f3f730c5632cb1dbb7b39036cb16dbd979a39f0006c4999f400f70f0ac98563f43cd51
MISC metadata.xml 314 BLAKE2B 0d1abced1dc2536da0775f6521e0dee6dac8ffb71b954540d8830dc2d4b1a77ab87e9ee486817152af046f14aaca898a9cdcfcfe9c3a87f43381236362eba095 SHA512 a049b4723f53c4cca6523432a4f1f005d07ec6e5a58224fb7dac65d4ab843c9d90eaa5a8526834010de17bdccb0aac998f03475ee7f1ff612bbe492890fe55ed
diff --git a/sys-block/sas3ircu/sas3ircu-16-r2.ebuild b/sys-block/sas3ircu/sas3ircu-16-r2.ebuild
new file mode 100644
index 000000000000..19b627edc362
--- /dev/null
+++ b/sys-block/sas3ircu/sas3ircu-16-r2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN^^}_P${PV}"
+
+DISTFILE_BIN="${MY_P}.zip"
+DISTFILE_DOC="SAS3_IR_UG.pdf"
+SRC_URI_BASE="https://docs.broadcom.com/docs-and-downloads/host-bus-adapters"
+
+inherit mount-boot secureboot
+
+DESCRIPTION="LSI MPT-SAS3 controller management tool"
+HOMEPAGE="https://www.broadcom.com/products/storage/host-bus-adapters/sas-9300-8e#downloads"
+SRC_URI="
+ ${SRC_URI_BASE}/host-bus-adapters-common-files/sas_sata_12g_p${PV}/${DISTFILE_BIN}
+ https://docs.broadcom.com/docs/${DISTFILE_BIN}
+ doc? ( "${SRC_URI_BASE}/${DISTFILE_DOC}" )
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LSI"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~x64-solaris"
+IUSE="doc uefi"
+RESTRICT="strip fetch mirror"
+
+BDEPEND="app-arch/unzip"
+
+QA_PREBUILT="opt/lsi/sas3ircu boot/efi/sas3ircu.efi"
+
+pkg_pretend() {
+ use uefi && mount-boot_pkg_pretend
+}
+
+pkg_nofetch() {
+ elog "Broadcom has a mandatory click-through license on their binaries."
+ elog "Please visit ${HOMEPAGE} and download ${DISTFILE_BIN} from the Mangement Software section."
+ elog "If the file has been moved again, the license form might be available at https://docs.broadcom.com/docs/${DISTFILE_BIN}"
+ elog "After downloading, move ${MY_P} into your DISTDIR directory"
+ if use doc; then
+ elog "Please also download 'SAS-3 Integrated RAID Configuration Utility User Guide' (${DISTFILE_DOC}) "
+ elog "and also place it into your DISTDIR directory"
+ fi
+ einfo "${SRC_URI}"
+}
+
+pkg_setup() {
+ use uefi && secureboot_pkg_setup
+}
+
+supportedcards() {
+ elog "This binary supports should support ALL cards, including, but not"
+ elog "limited to the following series:"
+ elog ""
+ elog "LSI SAS 3004"
+ elog "LSI SAS 3008"
+ elog "LSI SAS 3108"
+ elog "LSI SAS 3116"
+ elog "LSI SAS 3208"
+ elog "LSI SAS 3308"
+}
+
+src_install() {
+ # The second number is some sort of internal revision that is inconsistent between releases.
+ local DOCS=( IRCU_MPT_GEN3_Phase"${PV}".0-*.pdf "README_SAS3IRCU_P${PV}.txt" )
+ use doc && DOCS+=( "${DISTDIR}/${DISTFILE_DOC}" )
+
+ default
+
+ local ARCH
+ use amd64 && ARCH="x64"
+ use arm64 && ARCH="arm"
+ use ppc64 && ARCH="ppc64"
+ use x64-solaris && ARCH="solaris_x86"
+ use x86 && ARCH="x86"
+
+ exeinto /opt/lsi/
+ doexe sas3ircu_rel/sas3ircu/sas3ircu_linux_"${ARCH}"_rel/sas3ircu
+
+ if use uefi; then
+ if use amd64 || use arm64; then
+ exeinto /boot/efi/
+ doexe sas3ircu_rel/sas3ircu/sas3ircu_udk_uefi_"${ARCH}"_rel/sas3ircu.efi
+ secureboot_auto_sign --in-place
+ fi
+ fi
+
+ dodir /opt/bin
+ dosym ../lsi/sas3ircu /opt/bin/sas3ircu
+}
+
+pkg_preinst() {
+ use uefi && mount-boot_pkg_preinst
+}
+
+pkg_prerm() {
+ use uefi && mount-boot_pkg_prerm
+}