summaryrefslogtreecommitdiff
path: root/sys-block/seekwatcher/seekwatcher-0.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-27 10:33:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-27 10:33:45 +0100
commita12f416baa722b8bda57c0d527fb28b3d06b2aeb (patch)
tree00347496d39521fc572cc53fbd17037fbe73ca06 /sys-block/seekwatcher/seekwatcher-0.14.ebuild
parentef27446dc21d9fb7ee400987661cb759f6a6ee85 (diff)
gentoo auto-resync : 27:07:2023 - 10:33:45
Diffstat (limited to 'sys-block/seekwatcher/seekwatcher-0.14.ebuild')
-rw-r--r--sys-block/seekwatcher/seekwatcher-0.14.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-block/seekwatcher/seekwatcher-0.14.ebuild b/sys-block/seekwatcher/seekwatcher-0.14.ebuild
new file mode 100644
index 000000000000..06cc3475743f
--- /dev/null
+++ b/sys-block/seekwatcher/seekwatcher-0.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generates graphs from blktrace to help visualize IO patterns and performance"
+HOMEPAGE="https://github.com/trofi/seekwatcher"
+SRC_URI="https://github.com/trofi/seekwatcher/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ')
+ sys-block/blktrace
+"