summaryrefslogtreecommitdiff
path: root/sys-block/smp_utils/smp_utils-0.99.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sys-block/smp_utils/smp_utils-0.99.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sys-block/smp_utils/smp_utils-0.99.ebuild')
-rw-r--r--sys-block/smp_utils/smp_utils-0.99.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-block/smp_utils/smp_utils-0.99.ebuild b/sys-block/smp_utils/smp_utils-0.99.ebuild
new file mode 100644
index 000000000000..8e06ca005192
--- /dev/null
+++ b/sys-block/smp_utils/smp_utils-0.99.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Utilities for SAS management protocol (SMP)"
+HOMEPAGE="http://sg.danny.cz/sg/smp_utils.html"
+MY_PV="${PV/_beta/b}"
+MY_PV="${MY_PV/_p/r}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="http://sg.danny.cz/sg/p/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+DOCS=( AUTHORS ChangeLog COVERAGE CREDITS README )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}