summaryrefslogtreecommitdiff
path: root/sys-block/thin-provisioning-tools/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-20 17:35:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-20 17:35:36 +0100
commitb620fb1b0929ff9657a2588aaa42b85e3021c102 (patch)
tree5c4e9e39b5d3ea7fc569c26b0d4ba6db582249e6 /sys-block/thin-provisioning-tools/files
parentd473a706836012853193afc7000922601e4ada61 (diff)
gentoo resync : 20.10.2017
Diffstat (limited to 'sys-block/thin-provisioning-tools/files')
-rw-r--r--sys-block/thin-provisioning-tools/files/thin-provisioning-tools-0.7.4-disabled-tests_build_fix.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-block/thin-provisioning-tools/files/thin-provisioning-tools-0.7.4-disabled-tests_build_fix.patch b/sys-block/thin-provisioning-tools/files/thin-provisioning-tools-0.7.4-disabled-tests_build_fix.patch
new file mode 100644
index 000000000000..f9a64b2188d0
--- /dev/null
+++ b/sys-block/thin-provisioning-tools/files/thin-provisioning-tools-0.7.4-disabled-tests_build_fix.patch
@@ -0,0 +1,32 @@
+From 8d75be81120b9cf172c95d0153c5f845ed804234 Mon Sep 17 00:00:00 2001
+From: Adam Sampson <ats-github@offog.org>
+Date: Mon, 16 Oct 2017 13:07:36 +0100
+Subject: [PATCH] [functional-tests] fix build with testing disabled (#88)
+
+The rule for lib/libft.so is only enabled with --enable-testing,
+so the default target shouldn't depend unconditionally on it.
+With the default configure options, the build failed with:
+make: *** No rule to make target 'lib/libft.so', needed by 'all'. Stop.
+---
+ Makefile.in | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index e745739..02b75dd 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -21,8 +21,13 @@ V=@
+ PROGRAMS=\
+ bin/pdata_tools
+
++ifeq ("@TESTING@", "yes")
++TESTLIBS=\
++ lib/libft.so
++endif
++
+ .PHONY: all
+-all: $(PROGRAMS) lib/libft.so
++all: $(PROGRAMS) $(TESTLIBS)
+
+ SOURCE=\
+ base/output_file_requirements.cc \