summaryrefslogtreecommitdiff
path: root/sys-block/zram-init/zram-init-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-21 17:32:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-21 17:32:00 +0100
commit61f10f985e19dfe20a4d9552902625edd5b6eabb (patch)
tree50db31971b38c4e0358253ef5005058a46fc773e /sys-block/zram-init/zram-init-9999.ebuild
parent34dea8e38f88007799629d0a56b12dec480b1d21 (diff)
gentoo resync : 21.06.2021
Diffstat (limited to 'sys-block/zram-init/zram-init-9999.ebuild')
-rw-r--r--sys-block/zram-init/zram-init-9999.ebuild25
1 files changed, 11 insertions, 14 deletions
diff --git a/sys-block/zram-init/zram-init-9999.ebuild b/sys-block/zram-init/zram-init-9999.ebuild
index c591f149b38a..21f87df5e847 100644
--- a/sys-block/zram-init/zram-init-9999.ebuild
+++ b/sys-block/zram-init/zram-init-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
else
- SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/vaeth/zram-init/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
fi
@@ -29,18 +29,15 @@ RDEPEND="
DISABLE_AUTOFORMATTING=true
DOC_CONTENTS="\
-To use zram-init, activate it in your kernel and add it to the default runlevel:
- rc-update add zram-init default
+To use zram-init, activate it in your kernel and add it to the default
+runlevel: rc-update add zram-init default
If you use systemd enable zram_swap, zram_tmp, and/or zram_var_tmp with
-systemctl. You might need to modify the following file depending on the
-number of devices that you want to create:
- /etc/modprobe.d/zram.conf.
-If you use the \$TMPDIR as zram device with OpenRC, you should add zram-init
-to the boot runlevel:
- rc-update add zram-init boot
-Still for the same case, you should add in the OpenRC configuration file
-for the services using \$TMPDIR the following line:
- rc_need=\"zram-init\""
+systemctl. You might need to modify the following file depending on the number
+of devices that you want to create: /etc/modprobe.d/zram.conf.
+If you use the \$TMPDIR as zram device with OpenRC, you should add zram-init to
+the boot runlevel: rc-update add zram-init boot
+Still for the same case, you should add in the OpenRC configuration file for
+the services using \$TMPDIR the following line: rc_need=\"zram-init\""
src_prepare() {
default
@@ -64,7 +61,7 @@ src_install() {
readme.gentoo_create_doc
emake DESTDIR="${ED}" PREFIX="/usr" SYSCONFDIR="/etc" \
- BINDIR="${ED}/sbin" install
+ BINDIR="${ED}/sbin" SYSTEMDDIR="${ED}/lib/systemd/system" install
}
pkg_postinst() {