summaryrefslogtreecommitdiff
path: root/sys-boot/cromwell/cromwell-2.40-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-boot/cromwell/cromwell-2.40-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-boot/cromwell/cromwell-2.40-r3.ebuild')
-rw-r--r--sys-boot/cromwell/cromwell-2.40-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-boot/cromwell/cromwell-2.40-r3.ebuild b/sys-boot/cromwell/cromwell-2.40-r3.ebuild
new file mode 100644
index 000000000000..7ce7e1fd24b1
--- /dev/null
+++ b/sys-boot/cromwell/cromwell-2.40-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils mount-boot toolchain-funcs flag-o-matic
+
+DESCRIPTION="Xbox boot loader"
+HOMEPAGE="http://www.xbox-linux.org/wiki/Cromwell"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/${PF}-cvs-fixes.patch.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+RESTRICT="strip"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PF}-cvs-fixes.patch
+ epatch "${FILESDIR}"/${P}-gcc-4.6.patch #363535
+ sed -i 's:-Werror:-m32:' Makefile Rules.make || die
+ sed -i '/^EXTRA_CFLAGS/s:$: -m32:' Rules.make boot_rom/Makefile || die
+ sed -i \
+ -e '/^bin.imagebld:/,$s:\<gcc\>:${CC}:' \
+ Makefile || die
+ append-flags -m32
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" LD="$(tc-getLD)"
+}
+
+src_install() {
+ insinto /boot/${PN}
+ doins image/cromwell{,_1024}.bin xbe/xromwell.xbe
+}