summaryrefslogtreecommitdiff
path: root/sys-boot/elilo/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /sys-boot/elilo/files
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'sys-boot/elilo/files')
-rw-r--r--sys-boot/elilo/files/elilo-3.16-FLAGS.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/sys-boot/elilo/files/elilo-3.16-FLAGS.patch b/sys-boot/elilo/files/elilo-3.16-FLAGS.patch
new file mode 100644
index 000000000000..a77e44d0b186
--- /dev/null
+++ b/sys-boot/elilo/files/elilo-3.16-FLAGS.patch
@@ -0,0 +1,19 @@
+eliloalt is a rare native tool. Allow user to explicitly pass
+standart optimization flags via
+ $ make NATIIVE_CFLAGS=${CFLAGS} NATIVE_LDFLAGS
+https://bugs.gentoo.org/744931
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -42,10 +42,10 @@ all: $(TARGET)
+ # redefine local rule (we build a Linux/ia64 binary here)
+ #
+ %.o: %.c
+- $(CC) $(OPTIMFLAGS) $(DEBUGFLAGS) -c $< -o $@
++ $(CC) $(OPTIMFLAGS) $(NATIVE_CFLAGS) $(DEBUGFLAGS) -c $< -o $@
+
+ $(TARGET): %:%.o
+- $(CC) -o $@ $(OPTIMFLAGS) $(DEBUGFLAGS) $^
++ $(CC) -o $@ $(OPTIMFLAGS) $(NATIVE_CFLAGS) $(NATIVE_LDFLAGS) $(DEBUGFLAGS) $^
+
+ clean:
+ $(RM) -f $(TARGET) $(FILES)