summaryrefslogtreecommitdiff
path: root/sys-boot/grub/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
commit6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (patch)
treecee0a97398040001220ece3cd48c3d568bcddb4a /sys-boot/grub/files
parent1db00cc6e94b90c08090bb5b8c406622946c4ae5 (diff)
gentoo resync : 10.02.2019
Diffstat (limited to 'sys-boot/grub/files')
-rw-r--r--sys-boot/grub/files/grub-0.97-Add-esp-to-list-of-clobbered-registers.patch53
-rw-r--r--sys-boot/grub/files/grub-0.97-ncurses-pkgconfig.patch18
2 files changed, 0 insertions, 71 deletions
diff --git a/sys-boot/grub/files/grub-0.97-Add-esp-to-list-of-clobbered-registers.patch b/sys-boot/grub/files/grub-0.97-Add-esp-to-list-of-clobbered-registers.patch
deleted file mode 100644
index c550aabd6167..000000000000
--- a/sys-boot/grub/files/grub-0.97-Add-esp-to-list-of-clobbered-registers.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 5a52ee4b5cd152fa4ccd1c1f938ce2eba652af52 Mon Sep 17 00:00:00 2001
-From: Sergei Trofimovich <slyfox@gentoo.org>
-Date: Mon, 14 Dec 2015 23:59:17 +0000
-Subject: [PATCH] Add %esp to list of clobbered registers
-
-GCC assumes that it can combine stacks from
-outer
- grub_stage2()
-and inner
- trampoline doit()
-functions (optimisation -fcombine-stack-adjustments).
-
-But doit() function clobbers %esp in inline
-assebly statement as:
-
- asm volatile ("movl %%esp, %0\n\tmovl %1, %%esp\n"
- : "=&r" (realstack) : "r" (simstack));
-
-which tricks gcc into computing invalid local variable
-offsets from current %esp value.
-
-Fix by hinting gcc about %esp change in clobber list.
-
-Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
----
- grub/asmstub.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/grub/asmstub.c b/grub/asmstub.c
-index 6354806..44b056f 100644
---- a/grub/asmstub.c
-+++ b/grub/asmstub.c
-@@ -174,7 +174,7 @@ grub_stage2 (void)
- {
- /* Make sure our stack lives in the simulated memory area. */
- asm volatile ("movl %%esp, %0\n\tmovl %1, %%esp\n"
-- : "=&r" (realstack) : "r" (simstack));
-+ : "=&r" (realstack) : "r" (simstack) : "%esp");
-
- /* Do a setjmp here for the stop command. */
- if (! setjmp (env_for_exit))
-@@ -191,7 +191,7 @@ grub_stage2 (void)
- }
-
- /* Replace our stack before we use any local variables. */
-- asm volatile ("movl %0, %%esp\n" : : "r" (realstack));
-+ asm volatile ("movl %0, %%esp\n" : : "r" (realstack) : "%esp");
- }
-
- assert (grub_scratch_mem == 0);
---
-2.6.3
-
diff --git a/sys-boot/grub/files/grub-0.97-ncurses-pkgconfig.patch b/sys-boot/grub/files/grub-0.97-ncurses-pkgconfig.patch
deleted file mode 100644
index d62e4346c338..000000000000
--- a/sys-boot/grub/files/grub-0.97-ncurses-pkgconfig.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/configure.ac 2015-12-17 11:09:56.807893315 -0500
-+++ b/configure.ac 2015-12-17 11:11:06.697570856 -0500
-@@ -234,10 +234,14 @@
-
- # Unless the user specify --without-curses, check for curses.
- if test "x$with_curses" != "xno"; then
-+ PKG_CHECK_MODULES([NCURSES],[ncurses],[
-+ AC_DEFINE(HAVE_LIBCURSES, 1, [Define if you have a curses library])
-+ GRUB_LIBS="$GRUB_LIBS $NCURSES_LIBS"
-+ ],[
- AC_CHECK_LIB(ncurses, wgetch, [GRUB_LIBS="$GRUB_LIBS -lncurses"
- AC_DEFINE(HAVE_LIBCURSES, 1, [Define if you have a curses library])],
- [AC_CHECK_LIB(curses, wgetch, [GRUB_LIBS="$GRUB_LIBS -lcurses"
-- AC_DEFINE(HAVE_LIBCURSES, 1, [Define if you have a curses library])])])
-+ AC_DEFINE(HAVE_LIBCURSES, 1, [Define if you have a curses library])])])])
- fi
-
- AC_SUBST(GRUB_LIBS)